summaryrefslogtreecommitdiff
path: root/Build/source/libs/configure.ac
diff options
context:
space:
mode:
authorPeter Breitenlohner <peb@mppmu.mpg.de>2009-03-20 08:07:15 +0000
committerPeter Breitenlohner <peb@mppmu.mpg.de>2009-03-20 08:07:15 +0000
commitb89093a4be8467433b6dbabfa09b57e213a53fe0 (patch)
tree6f4fb6eecce8905febf68c34d5926699790466e1 /Build/source/libs/configure.ac
parent10d837d22d7d99b26f44847f92501f6037da4ec2 (diff)
new build system
git-svn-id: svn://tug.org/texlive/trunk@12451 c570f23f-e606-0410-a88d-b1316a301751
Diffstat (limited to 'Build/source/libs/configure.ac')
-rw-r--r--Build/source/libs/configure.ac48
1 files changed, 48 insertions, 0 deletions
diff --git a/Build/source/libs/configure.ac b/Build/source/libs/configure.ac
new file mode 100644
index 00000000000..b958f549bf2
--- /dev/null
+++ b/Build/source/libs/configure.ac
@@ -0,0 +1,48 @@
+dnl Process this file with autoconf to produce a configure script.
+dnl
+dnl Copyright (C) 2009 Peter Breitenlohner <tex-live@tug.org>
+dnl
+dnl This file is free software; the copyright holder
+dnl gives unlimited permission to copy and/or distribute it,
+dnl with or without modifications, as long as this notice is preserved.
+dnl
+AC_INIT([TeX Live libs], [2009], [tex-k@tug.org])
+AC_PREREQ([2.63])
+AC_CONFIG_SRCDIR([../build-aux/missing])
+AC_CONFIG_AUX_DIR([../build-aux])
+AC_CONFIG_MACRO_DIR([../m4])
+
+dnl See comment in ../configure.ac
+KPSE_SETUP([../])
+
+AM_INIT_AUTOMAKE([foreign dist-bzip2])
+AM_MAINTAINER_MODE
+
+AC_PROG_MKDIR_P
+
+AC_CONFIG_SUBDIRS([dummy])
+
+AC_MSG_CHECKING([for libraries to build])
+SUBLIBS=
+DIST_SUBLIBS=
+KPSE_FOR_PKGS([libs], [
+if test -x $srcdir/Kpse_Pkg/configure; then
+ if test "x$with_system_[]Kpse_pkg" != xyes && \
+ test "x$need_[]Kpse_pkg" = xyes; then
+ SUBLIBS="Kpse_Pkg $SUBLIBS"
+ fi
+dnl Cause 'make dist' to recurse into all sublibs dirs
+ DIST_SUBLIBS="Kpse_Pkg $DIST_SUBLIBS"
+dnl Cause 'configure -hr' and 'autoreconf' to recurse into all sublibs dirs
+ if false; then
+ AC_CONFIG_SUBDIRS(Kpse_Pkg)
+ fi
+fi
+])
+AC_SUBST([SUBLIBS])
+AC_SUBST([DIST_SUBLIBS])
+AC_MSG_RESULT([$SUBLIBS])
+
+AC_CONFIG_FILES([Makefile])
+
+AC_OUTPUT