summaryrefslogtreecommitdiff
path: root/Build/source/libs/configure.ac
diff options
context:
space:
mode:
authorPeter Breitenlohner <peb@mppmu.mpg.de>2013-07-07 14:29:53 +0000
committerPeter Breitenlohner <peb@mppmu.mpg.de>2013-07-07 14:29:53 +0000
commit0df6dd4d8aea6edc733de81fb7eec115ea59a36e (patch)
treee2f7056cb53c58c8ef5779450ac468091b2bd86d /Build/source/libs/configure.ac
parent3675a91dd83af3eaa1c1a12e91af1e6c86f710f8 (diff)
build system: additional Makefile fragments
better handling of dependencies for highly parallel make git-svn-id: svn://tug.org/texlive/trunk@31127 c570f23f-e606-0410-a88d-b1316a301751
Diffstat (limited to 'Build/source/libs/configure.ac')
-rw-r--r--Build/source/libs/configure.ac14
1 files changed, 7 insertions, 7 deletions
diff --git a/Build/source/libs/configure.ac b/Build/source/libs/configure.ac
index 1428b373122..998adeca666 100644
--- a/Build/source/libs/configure.ac
+++ b/Build/source/libs/configure.ac
@@ -21,25 +21,25 @@ KPSE_BASIC([libs])
AC_PROG_MKDIR_P
AC_MSG_CHECKING([for generic libraries to build])
-SUBLIBS=
-DIST_SUBLIBS=
+MAKE_SUBDIRS=
+CONF_SUBDIRS=
KPSE_FOR_PKGS([libs], [
if test -x $srcdir/Kpse_Pkg/configure; then
if test "x$with_system_[]Kpse_pkg" != xyes && \
test "x$need_[]Kpse_pkg" = xyes; then
- SUBLIBS="Kpse_Pkg $SUBLIBS"
+ MAKE_SUBDIRS="Kpse_Pkg $MAKE_SUBDIRS"
fi
dnl Cause 'make dist' to recurse into all sublibs dirs
- DIST_SUBLIBS="Kpse_Pkg $DIST_SUBLIBS"
+ CONF_SUBDIRS="Kpse_Pkg $CONF_SUBDIRS"
dnl Cause 'configure -hr' and 'autoreconf' to recurse into all sublibs dirs
if false; then
AC_CONFIG_SUBDIRS(Kpse_Pkg)
fi
fi
])
-AC_SUBST([SUBLIBS])
-AC_SUBST([DIST_SUBLIBS])
-AC_MSG_RESULT([$SUBLIBS])
+AC_SUBST([MAKE_SUBDIRS])
+AC_SUBST([CONF_SUBDIRS])
+AC_MSG_RESULT([$MAKE_SUBDIRS])
AC_CONFIG_FILES([Makefile])