summaryrefslogtreecommitdiff
path: root/Build/source/extra/xz/src/scripts/Makefile.am
diff options
context:
space:
mode:
authorKarl Berry <karl@freefriends.org>2014-04-19 22:09:10 +0000
committerKarl Berry <karl@freefriends.org>2014-04-19 22:09:10 +0000
commitf63732007b6a055afad48521b678be0a9c0ed7ae (patch)
tree1b698adf2ec8387c8fdef044a32d321ae50e9633 /Build/source/extra/xz/src/scripts/Makefile.am
parentf089b79c939f3448e2fa7fcc6687a6417b3107f8 (diff)
messed up xz timestamps, better retrieved from original anyway
git-svn-id: svn://tug.org/texlive/trunk@33544 c570f23f-e606-0410-a88d-b1316a301751
Diffstat (limited to 'Build/source/extra/xz/src/scripts/Makefile.am')
-rw-r--r--Build/source/extra/xz/src/scripts/Makefile.am55
1 files changed, 0 insertions, 55 deletions
diff --git a/Build/source/extra/xz/src/scripts/Makefile.am b/Build/source/extra/xz/src/scripts/Makefile.am
deleted file mode 100644
index 29bdbcd76de..00000000000
--- a/Build/source/extra/xz/src/scripts/Makefile.am
+++ /dev/null
@@ -1,55 +0,0 @@
-##
-## Author: Lasse Collin
-##
-## This file has been put into the public domain.
-## You can do whatever you want with this file.
-##
-
-nodist_bin_SCRIPTS = xzdiff xzgrep xzmore xzless
-dist_man_MANS = xzdiff.1 xzgrep.1 xzmore.1 xzless.1
-
-links = \
- xzdiff-xzcmp \
- xzgrep-xzegrep \
- xzgrep-xzfgrep
-
-if COND_LZMALINKS
-links += \
- xzdiff-lzdiff \
- xzdiff-lzcmp \
- xzgrep-lzgrep \
- xzgrep-lzegrep \
- xzgrep-lzfgrep \
- xzmore-lzmore \
- xzless-lzless
-endif
-
-install-exec-hook:
- cd $(DESTDIR)$(bindir) && \
- for pair in $(links); do \
- target=`echo $$pair | sed 's/-.*$$//' | sed '$(transform)'` && \
- link=`echo $$pair | sed 's/^.*-//' | sed '$(transform)'` && \
- rm -f $$link && \
- $(LN_S) $$target $$link; \
- done
-
-install-data-hook:
- cd $(DESTDIR)$(mandir)/man1 && \
- for pair in $(links); do \
- target=`echo $$pair | sed 's/-.*$$//' | sed '$(transform)'` && \
- link=`echo $$pair | sed 's/^.*-//' | sed '$(transform)'` && \
- rm -f $$link.1 && \
- $(LN_S) $$target.1 $$link.1; \
- done
-
-uninstall-hook:
- cd $(DESTDIR)$(bindir) && \
- for pair in $(links); do \
- link=`echo $$pair | sed 's/^.*-//' | sed '$(transform)'` && \
- rm -f $$link; \
- done
- cd $(DESTDIR)$(mandir)/man1 && \
- for pair in $(links); do \
- link=`echo $$pair | sed 's/^.*-//' | sed '$(transform)'` && \
- rm -f $$link.1; \
- done