summaryrefslogtreecommitdiff
path: root/Build/source/configure.in
diff options
context:
space:
mode:
authorJonathan Kew <jfkthame@googlemail.com>2006-07-26 09:19:11 +0000
committerJonathan Kew <jfkthame@googlemail.com>2006-07-26 09:19:11 +0000
commite88aafe4ca4779a73487925dea63e8b55dc5e251 (patch)
tree919e3241814583611d022541e94867b2d9a51789 /Build/source/configure.in
parent303b10f969384002e95d0fbe559a0151f601b811 (diff)
added teckit support to configure/make scripts
git-svn-id: svn://tug.org/texlive/trunk@1919 c570f23f-e606-0410-a88d-b1316a301751
Diffstat (limited to 'Build/source/configure.in')
-rw-r--r--Build/source/configure.in13
1 files changed, 12 insertions, 1 deletions
diff --git a/Build/source/configure.in b/Build/source/configure.in
index cf8da05bf39..964bc673e0e 100644
--- a/Build/source/configure.in
+++ b/Build/source/configure.in
@@ -101,6 +101,7 @@ sinclude(libs/gd/withenable.ac)
sinclude(libs/freetype/withenable.ac)
sinclude(libs/freetype2/withenable.ac)
sinclude(libs/icu-xetex/withenable.ac)
+sinclude(libs/teckit/withenable.ac)
NCURSESDIR=libs/ncurses
LIBT1DIR=libs/t1lib
@@ -111,6 +112,7 @@ LIBXPDFDIR=libs/xpdf
FREETYPEDIR=libs/freetype
FREETYPE2DIR=libs/freetype2
ICUDIR=libs/icu-xetex
+TECKITDIR=libs/teckit
GDDIR=libs/gd
test "$no_x" = yes && { with_xdvik=no; with_oxdvik=no; }
@@ -182,6 +184,12 @@ test "$with_xetex" != no && : ${needs_icu=yes}
: ${needs_icu=no}
export needs_icu
+# we need teckit for xetex
+test ! -d $srcdir/$TECKITDIR && : ${needs_teckit=no}
+test "$with_xetex" != no && : ${needs_teckit=yes}
+: ${needs_teckit=no}
+export needs_teckit
+
dnl We cannot use variables (e.g. $LIBPNGDIR) for sinclude, so...
sinclude(libs/libpng/libpng.ac)
sinclude(libs/zlib/zlib.ac)
@@ -192,8 +200,9 @@ sinclude(libs/gd/gd.ac)
sinclude(libs/freetype/freetype.ac)
sinclude(libs/freetype2/freetype2.ac)
sinclude(libs/icu-xetex/icu-xetex.ac)
+sinclude(libs/teckit/teckit.ac)
-LIBSDEP="$CURSESDEP $ZLIBDEP $LIBPNGDEP $LIBXPDFDEP $LIBT1DEP $GDDEP $FREETYPEDEP $FREETYPE2DEP $ICUDEP"
+LIBSDEP="$CURSESDEP $ZLIBDEP $LIBPNGDEP $LIBXPDFDEP $LIBT1DEP $GDDEP $FREETYPEDEP $FREETYPE2DEP $ICUDEP $TECKITDEP"
LIBSDIRS=
test "$needs_ncurses" = yes && test "$using_system_ncurses" != yes \
@@ -214,6 +223,8 @@ test "$needs_freetype2" = yes && test "$using_system_freetype2" != yes \
&& LIBSDIRS="$FREETYPE2DIR $LIBSDIRS"
test "$needs_icu" = yes && test "$using_system_icu" != yes \
&& LIBSDIRS="$ICUDIR $LIBSDIRS"
+test "$needs_teckit" = yes \
+ && LIBSDIRS="$TECKITDIR $LIBSDIRS"
AC_CONFIG_SUBDIRS([libs])