summaryrefslogtreecommitdiff
path: root/Build/source/configure.in
diff options
context:
space:
mode:
authorKarl Berry <karl@freefriends.org>2006-01-16 00:01:11 +0000
committerKarl Berry <karl@freefriends.org>2006-01-16 00:01:11 +0000
commit269d9a5ff80f6f2e0279be58cf9b09f4e5ed86fa (patch)
tree372d7bf0c625b2228368603ed671ab9ffc3c4140 /Build/source/configure.in
parentf155681c16a9cd956036dcfa53ab51e417f4d736 (diff)
initial source
git-svn-id: svn://tug.org/texlive/trunk@1479 c570f23f-e606-0410-a88d-b1316a301751
Diffstat (limited to 'Build/source/configure.in')
-rw-r--r--Build/source/configure.in65
1 files changed, 65 insertions, 0 deletions
diff --git a/Build/source/configure.in b/Build/source/configure.in
new file mode 100644
index 00000000000..e479b571236
--- /dev/null
+++ b/Build/source/configure.in
@@ -0,0 +1,65 @@
+dnl Written many years ago by Thomas Esser and others. Public domain.
+
+AC_INIT(TeX/texk/web2c/tex.web)
+
+AC_CONFIG_AUX_DIR(TeX/config)
+AC_SET_MAKE
+AC_PROG_CC
+AC_CANONICAL_SYSTEM
+
+dnl Various compiler directives
+AC_MSG_CHECKING(whether to define additional compiler specific flags)
+case "$target" in
+ alpha*-dec*)
+ if test "$CC" = "cc"; then
+ CFLAGS="$CFLAGS -Olimit 1000 -std1"; export CFLAGS
+ AC_MSG_WARN(Digital Unix's cc)
+ fi
+ ;;
+ hp*hpux*)
+ if test "$CC" = "cc"; then
+ CFLAGS="$CFLAGS -Aa +e -D_HPUX_SOURCE"; export CFLAGS
+ AC_MSG_WARN(HP-UX's cc)
+ fi
+ ;;
+ *)
+ AC_MSG_RESULT(no)
+ ;;
+esac
+
+#
+case $CC in
+ egcs)
+ # The egcs compiler (version 1.1) has a problem with force-mem, so:
+ CFLAGS="$CFLAGS -fno-force-mem";;
+esac
+
+AC_PROG_INSTALL
+AC_PROG_MAKE_SET
+AC_PROG_LN_S
+AC_FUNC_ALLOCA
+AC_PROG_RANLIB
+
+sinclude(TeX/tetex.ac)
+sinclude(TeX/withenable.ac)
+sinclude(TeX/utils/dialog/withenable.ac)
+sinclude(TeX/texk/withenable.ac)
+sinclude(TeX/texk/kpathsea/withenable.ac)
+sinclude(TeX/texk/kpathsea/xt.ac)
+sinclude(TeX/texk/web2c/withenable.ac)
+sinclude(TeX/texk/xdvik/withenable.ac)
+sinclude(TeX/libs/ncurses/withenable.ac)
+sinclude(TeX/libs/libtiff/withenable.ac)
+sinclude(TeX/libs/libtiff/libtiff.ac)
+sinclude(TeX/libs/libpng/withenable.ac)
+sinclude(TeX/libs/libpng/libpng.ac)
+sinclude(TeX/libs/zlib/withenable.ac)
+sinclude(TeX/libs/zlib/zlib.ac)
+sinclude(TeX/libs/t1lib/withenable.ac)
+sinclude(TeX/libs/t1lib/t1lib.ac)
+sinclude(TeX/libs/gd/withenable.ac)
+sinclude(TeX/libs/gd/gd.ac)
+
+AC_CONFIG_SUBDIRS(TeX)
+AC_CONFIG_FILES(Makefile)
+AC_OUTPUT()