summaryrefslogtreecommitdiff
path: root/Build/source/configure.in
diff options
context:
space:
mode:
authorPeter Breitenlohner <peb@mppmu.mpg.de>2008-04-07 12:06:18 +0000
committerPeter Breitenlohner <peb@mppmu.mpg.de>2008-04-07 12:06:18 +0000
commit41fdc70e57b74afa2a63e751e435055e5dfe7c58 (patch)
tree200d74ecd21d8b77bdcb5687576a6d7f012be322 /Build/source/configure.in
parent1999147223756159c17c4e47fbbaf7b7d0344f4f (diff)
respect library dependencies
git-svn-id: svn://tug.org/texlive/trunk@7345 c570f23f-e606-0410-a88d-b1316a301751
Diffstat (limited to 'Build/source/configure.in')
-rw-r--r--Build/source/configure.in40
1 files changed, 20 insertions, 20 deletions
diff --git a/Build/source/configure.in b/Build/source/configure.in
index 52422fb6f95..45bb670302e 100644
--- a/Build/source/configure.in
+++ b/Build/source/configure.in
@@ -95,12 +95,12 @@ sinclude(texk/web2c/withenable.ac)
sinclude(texk/web2c/xetexdir/withenable.ac)
sinclude(texk/xdvik/withenable.ac)
sinclude(libs/ncurses/withenable.ac)
+sinclude(libs/zlib/withenable.ac)
sinclude(libs/libpng/withenable.ac)
sinclude(libs/t1lib/withenable.ac)
-sinclude(libs/zlib/withenable.ac)
-sinclude(libs/gd/withenable.ac)
sinclude(libs/freetype/withenable.ac)
sinclude(libs/freetype2/withenable.ac)
+sinclude(libs/gd/withenable.ac)
sinclude(libs/icu-xetex/withenable.ac)
sinclude(libs/teckit/withenable.ac)
@@ -215,14 +215,14 @@ test "$with_xetex" != no && : ${needs_teckit=yes}
export needs_teckit
dnl We cannot use variables (e.g. $LIBPNGDIR) for sinclude, so...
-sinclude(libs/libpng/libpng.ac)
-sinclude(libs/zlib/zlib.ac)
sinclude(libs/ncurses/ncurses.ac)
+sinclude(libs/zlib/zlib.ac)
+sinclude(libs/libpng/libpng.ac)
sinclude(libs/xpdf/libxpdf.ac)
sinclude(libs/t1lib/t1lib.ac)
-sinclude(libs/gd/gd.ac)
sinclude(libs/freetype/freetype.ac)
sinclude(libs/freetype2/freetype2.ac)
+sinclude(libs/gd/gd.ac)
sinclude(libs/icu-xetex/icu-xetex.ac)
sinclude(libs/graphite-engine/graphite-engine.ac)
sinclude(libs/teckit/teckit.ac)
@@ -231,30 +231,30 @@ sinclude(libs/obsdcompat/libobsd-compat.ac)
LIBSDEP="$CURSESDEP $ZLIBDEP $LIBPNGDEP $LIBXPDFDEP $LIBT1DEP $GDDEP $FREETYPEDEP $FREETYPE2DEP $ICUDEP $GRAPHITEDEP $TECKITDEP $LIBOBSDDEP"
LIBSDIRS=
-test "$needs_teckit" = yes \
- && LIBSDIRS="$TECKITDIR $LIBSDIRS"
test "$needs_ncurses" = yes && test "$using_system_ncurses" != yes \
- && LIBSDIRS="$NCURSESDIR $LIBSDIRS"
-test "$needs_pnglib" = yes && test "$using_system_pnglib" != yes \
- && LIBSDIRS="$LIBPNGDIR $LIBSDIRS"
+ && LIBSDIRS="$LIBSDIRS $NCURSESDIR"
test "$needs_zlib" = yes && test "$using_system_zlib" != yes \
- && LIBSDIRS="$ZLIBDIR $LIBSDIRS"
+ && LIBSDIRS="$LIBSDIRS $ZLIBDIR"
+test "$needs_pnglib" = yes && test "$using_system_pnglib" != yes \
+ && LIBSDIRS="$LIBSDIRS $LIBPNGDIR"
test "$needs_libxpdf" = yes \
- && LIBSDIRS="$LIBXPDFDIR $LIBSDIRS"
+ && LIBSDIRS="$LIBSDIRS $LIBXPDFDIR"
test "$needs_libt1" = yes && test "$using_system_t1lib" != yes \
- && LIBSDIRS="$LIBT1DIR $LIBTYPE1DIR $LIBSDIRS"
-test "$needs_gd" = yes && test "$using_system_gd" != yes \
- && LIBSDIRS="$GDDIR $LIBSDIRS"
+ && LIBSDIRS="$LIBSDIRS $LIBT1DIR $LIBTYPE1DIR"
test "$needs_freetype" = yes && test "$using_system_freetype" != yes \
- && LIBSDIRS="$FREETYPEDIR $LIBSDIRS"
+ && LIBSDIRS="$LIBSDIRS $FREETYPEDIR"
test "$needs_freetype2" = yes && test "$using_system_freetype2" != yes \
- && LIBSDIRS="$FREETYPE2DIR $LIBSDIRS"
+ && LIBSDIRS="$LIBSDIRS $FREETYPE2DIR"
+test "$needs_gd" = yes && test "$using_system_gd" != yes \
+ && LIBSDIRS="$LIBSDIRS $GDDIR"
test "$needs_icu" = yes && test "$using_system_icu" != yes \
- && LIBSDIRS="$ICUDIR $LIBSDIRS"
+ && LIBSDIRS="$LIBSDIRS $ICUDIR"
+test "$needs_teckit" = yes \
+ && LIBSDIRS="$LIBSDIRS $TECKITDIR"
test "$needs_graphite" = yes \
- && LIBSDIRS="$GRAPHITEDIR $LIBSDIRS"
+ && LIBSDIRS="$LIBSDIRS $GRAPHITEDIR"
test "$needs_obsdcompat" = yes \
- && LIBSDIRS="$LIBOBSDCOMPATDIR $LIBSDIRS"
+ && LIBSDIRS="$LIBSDIRS $LIBOBSDCOMPATDIR"
dnl required subdir
AC_CONFIG_SUBDIRS([libs])