summaryrefslogtreecommitdiff
path: root/Build/source/configure.ac
diff options
context:
space:
mode:
authorPeter Breitenlohner <peb@mppmu.mpg.de>2012-05-21 12:47:05 +0000
committerPeter Breitenlohner <peb@mppmu.mpg.de>2012-05-21 12:47:05 +0000
commit3aebe98ebe4f3d35b226d03813343296b08baee0 (patch)
treee0944fb08700ee21ffd1b78900ac181cce7a0e42 /Build/source/configure.ac
parentbb6c171137b022a31470471ce7bb95e2818bc5fa (diff)
build system: Better detection of GNU make (cope with FreeBSD make)
git-svn-id: svn://tug.org/texlive/trunk@26536 c570f23f-e606-0410-a88d-b1316a301751
Diffstat (limited to 'Build/source/configure.ac')
-rw-r--r--Build/source/configure.ac6
1 files changed, 5 insertions, 1 deletions
diff --git a/Build/source/configure.ac b/Build/source/configure.ac
index e8eebc1a477..df1734efc5b 100644
--- a/Build/source/configure.ac
+++ b/Build/source/configure.ac
@@ -156,10 +156,14 @@ AC_CONFIG_SUBDIRS([auxdir/auxsub libs utils texk])
AC_CONFIG_FILES([Makefile])
+dnl Try to detect GNU make early, '-v' is verbose for BSD make.
+rm -f Makefile
+kpse_GNU_make=`${MAKE-make} -v 2>/dev/null | grep GNU`
+
AC_OUTPUT
dnl Most probably we need GNU make.
-if test -z "`${MAKE-make} -v 2>/dev/null | grep GNU`"; then
+if test -z "$kpse_GNU_make"; then
if test "x$enable_native_texlive_build" = xno; then
AC_MSG_WARN([Building TeX Live may require GNU make])
else