summaryrefslogtreecommitdiff
path: root/Build/source/configure.ac
diff options
context:
space:
mode:
authorPeter Breitenlohner <peb@mppmu.mpg.de>2011-12-06 14:50:09 +0000
committerPeter Breitenlohner <peb@mppmu.mpg.de>2011-12-06 14:50:09 +0000
commit6c7ac04da0ed0c0bcf3f63106addbd66c35d7388 (patch)
tree3bed1702a43b35d9ba17f669a343c35baf947691 /Build/source/configure.ac
parentd4098ae6af4055044c234a33fc9f42b2e4638999 (diff)
build system
- use TL specific installation directories only for `native' builds - replace ${prefix}/texmf => $(datarootdir)/texmf git-svn-id: svn://tug.org/texlive/trunk@24780 c570f23f-e606-0410-a88d-b1316a301751
Diffstat (limited to 'Build/source/configure.ac')
-rw-r--r--Build/source/configure.ac31
1 files changed, 22 insertions, 9 deletions
diff --git a/Build/source/configure.ac b/Build/source/configure.ac
index efa596b0f7e..fa755088f65 100644
--- a/Build/source/configure.ac
+++ b/Build/source/configure.ac
@@ -73,14 +73,19 @@ if test "x$LN_S" != "xln -s" && test "x$with_ln_s" != xno; then
AC_MSG_ERROR([You could use `--without-ln-s' to build without working `ln -s'])
fi
-if test "x$mandir" = 'x${datarootdir}/man'; then
- mandir='${prefix}/texmf/doc/man'
- ac_configure_args="$ac_configure_args '--mandir=$mandir'"
-fi
-
-if test "x$infodir" = 'x${datarootdir}/info'; then
- infodir='${prefix}/texmf/doc/info'
- ac_configure_args="$ac_configure_args '--infodir=$infodir'"
+if test "x$enable_native_texlive_build" = xyes; then
+ if test "x$datarootdir" = 'x${prefix}/share'; then
+ datarootdir='${prefix}'
+ ac_configure_args="$ac_configure_args '--datarootdir=$datarootdir'"
+ fi
+ if test "x$mandir" = 'x${datarootdir}/man'; then
+ mandir='${prefix}/texmf/doc/man'
+ ac_configure_args="$ac_configure_args '--mandir=$mandir'"
+ fi
+ if test "x$infodir" = 'x${datarootdir}/info'; then
+ infodir='${prefix}/texmf/doc/info'
+ ac_configure_args="$ac_configure_args '--infodir=$infodir'"
+ fi
fi
dnl Although quite unusual, it is possible to build Web2C (TeX & Co)
@@ -179,7 +184,6 @@ case $kpse_src$kpse_bld in
*' '*) AC_MSG_ERROR([Absolute source and/or build path with embedded spaces]);;
esac
AC_MSG_RESULT([
- prefix: $prefix
enable_native_texlive_build: $enable_native_texlive_build
enable_shared: $enable_shared
enable_multiplatform: $enable_multiplatform
@@ -187,5 +191,14 @@ AC_MSG_RESULT([
enable_libtool_hack: $enable_libtool_hack
enable_compiler_warnings: $enable_compiler_warnings
+ prefix: $prefix
+ includedir: $includedir
+ datarootdir: $datarootdir
+ mandir: $mandir
+ infodir: $infodir
+ exec_prefix: $exec_prefix
+ bindir: $bindir
+ libdir: $libdir
+
** Next run `make' to configure and build each library and program.
])