summaryrefslogtreecommitdiff
path: root/Build/source/configure.ac
diff options
context:
space:
mode:
authorPeter Breitenlohner <peb@mppmu.mpg.de>2009-11-10 10:34:20 +0000
committerPeter Breitenlohner <peb@mppmu.mpg.de>2009-11-10 10:34:20 +0000
commite4cae97633d68af424aef1494462550cef2dadeb (patch)
tree0e82baf23b3900e995c132775fc75213c0984cf4 /Build/source/configure.ac
parent558303c70cdfd3bc2465cb99c2f8d81a64efcf31 (diff)
towards TL2010: build system
git-svn-id: svn://tug.org/texlive/trunk@15977 c570f23f-e606-0410-a88d-b1316a301751
Diffstat (limited to 'Build/source/configure.ac')
-rw-r--r--Build/source/configure.ac28
1 files changed, 17 insertions, 11 deletions
diff --git a/Build/source/configure.ac b/Build/source/configure.ac
index 99387bc5894..9022a3f70a7 100644
--- a/Build/source/configure.ac
+++ b/Build/source/configure.ac
@@ -6,7 +6,7 @@ dnl This file is free software; the copyright holder
dnl gives unlimited permission to copy and/or distribute it,
dnl with or without modifications, as long as this notice is preserved.
dnl
-AC_INIT([TeX Live], [2009-11-09], [tex-k@tug.org])
+AC_INIT([TeX Live], [2009-11-10], [tex-k@tug.org])
AC_PREREQ([2.63])
AC_CONFIG_SRCDIR([m4/kpse-pkgs.m4])
AC_CONFIG_AUX_DIR([build-aux])
@@ -44,7 +44,8 @@ dnl
KPSE_SETUP([])
dnl Common code for all programs using libkpathsea.
-KPSE_COMMON([TeX Live top-level])
+KPSE_COMMON([TeX Live top-level], [dist-xz])
+KPSE_CANONICAL_HOST
AC_PATH_XTRA
@@ -109,31 +110,36 @@ if test "x$syslib_used:$enable_native_texlive_build" = xyes:yes; then
fi
KPSE_RESTORE_FLAGS
-AS_IF([test "x$cross_compiling:$enable_xetex" = xyes:yes],
- [AC_MSG_ERROR([Sorry, can not cross compile icu libraries required for XeTeX])])
-
AM_CONDITIONAL([build_kpathsea],
[test "x$need_kpathsea" = xyes && test "x$with_system_kpathsea" != xyes])
-AC_CONFIG_SUBDIRS([texk/kpathsea libs utils texk])
+AC_CONFIG_SUBDIRS([auxdir/auxsub texk/kpathsea libs utils texk])
AC_CONFIG_FILES([Makefile])
AC_OUTPUT
+dnl Most probably we need GNU make.
+if test -z "`${MAKE-make} -v 2>/dev/null | grep GNU`"; then
+ if test "x$enable_native_texlive_build" = xno; then
+ AC_MSG_WARN([Building TeX Live may require GNU make])
+ else
+ AC_MSG_ERROR([Building TeX Live requires GNU make])
+ fi
+fi
+
AS_IF([test "x$cross_compiling" = xyes],
- [AS_IF([test "x$build" = x],
- [AC_MSG_ERROR([when cross-compiling you must specify both --host and --build.])])
- msg_compiling="cross-compiling on $build"],
- [msg_compiling="compiling"])
+ [msg_compiling="cross-compiling on $build_alias for $host_alias"],
+ [msg_compiling="compiling for $kpse_build_alias"])
AC_MSG_RESULT([
** Configuration summary for $PACKAGE_STRING:
- $msg_compiling for $host
+ $msg_compiling
prefix: $prefix
enable_shared: $enable_shared
enable_multiplatform: $enable_multiplatform
enable_cxx_runtime_hack: $enable_cxx_runtime_hack
+ enable_compiler_warnings: $enable_compiler_warnings
** Next run `make' to configure and build each library and program.
])