summaryrefslogtreecommitdiff
path: root/Build/source/configure.ac
diff options
context:
space:
mode:
authorPeter Breitenlohner <peb@mppmu.mpg.de>2009-05-28 09:29:46 +0000
committerPeter Breitenlohner <peb@mppmu.mpg.de>2009-05-28 09:29:46 +0000
commit36701c8f42a42bbdcb3946c4ca5ba24f2440478f (patch)
tree573a53a1fe3545972829678f16cbd33f7137478b /Build/source/configure.ac
parentacead4a9aec4369046ab1eca84fec5e7308099fa (diff)
build system: check for working 'ln -s'
git-svn-id: svn://tug.org/texlive/trunk@13506 c570f23f-e606-0410-a88d-b1316a301751
Diffstat (limited to 'Build/source/configure.ac')
-rw-r--r--Build/source/configure.ac8
1 files changed, 8 insertions, 0 deletions
diff --git a/Build/source/configure.ac b/Build/source/configure.ac
index 5d418dae2c5..6f72b9ef507 100644
--- a/Build/source/configure.ac
+++ b/Build/source/configure.ac
@@ -50,6 +50,14 @@ AC_PATH_XTRA
AC_PROG_CXX
+AC_PROG_LN_S
+AC_ARG_WITH([ln-s],
+ AS_HELP_STRING([--without-ln-s],
+ [do build even if `ln -s' does not work]))[]dnl
+if test "x$LN_S" != "xln -s" && test "x$with_ln_s" != xno; then
+ AC_MSG_ERROR([You could use `--without-ln-s' to build without working `ln -s'])
+fi
+
## FIXME
if test "x$with_fontconfig" != x; then
AC_MSG_ERROR([Sorry, the configure option `--with-fontconfig' is no longer supported.