summaryrefslogtreecommitdiff
path: root/Build/source/configure.ac
diff options
context:
space:
mode:
authorPeter Breitenlohner <peb@mppmu.mpg.de>2009-06-15 15:10:25 +0000
committerPeter Breitenlohner <peb@mppmu.mpg.de>2009-06-15 15:10:25 +0000
commit273ed9c5b194dca51ed972db8071522d60733284 (patch)
tree5756fca71150fed35117a3b02a8648a3ec5e367f /Build/source/configure.ac
parentca19ba96de1003493b769ea8b13d12ebc0c883ca (diff)
implement compiler warnings
git-svn-id: svn://tug.org/texlive/trunk@13751 c570f23f-e606-0410-a88d-b1316a301751
Diffstat (limited to 'Build/source/configure.ac')
-rw-r--r--Build/source/configure.ac7
1 files changed, 6 insertions, 1 deletions
diff --git a/Build/source/configure.ac b/Build/source/configure.ac
index 15e32ac9697..53e92aa737f 100644
--- a/Build/source/configure.ac
+++ b/Build/source/configure.ac
@@ -6,7 +6,7 @@ dnl This file is free software; the copyright holder
dnl gives unlimited permission to copy and/or distribute it,
dnl with or without modifications, as long as this notice is preserved.
dnl
-AC_INIT([TeX Live], [2009-05-29], [tex-k@tug.org])
+AC_INIT([TeX Live], [2009-06-12], [tex-k@tug.org])
AC_PREREQ([2.63])
AC_CONFIG_SRCDIR([m4/kpse-pkgs.m4])
AC_CONFIG_AUX_DIR([build-aux])
@@ -100,8 +100,10 @@ fi
dnl We check that all required system libraries are usable, and may
dnl reduce frustration if anything is wrong by doing this first.
+dnl A native TeX Live build must not use any system libraries.
KPSE_SAVE_FLAGS
syslib_status=yes
+syslib_used=no
KPSE_ALL_SYSTEM_FLAGS
KPSE_FOR_PKGS([syslib],
[m4_sinclude(m4_if(Kpse_Pkg, [kpathsea], [texk/],
@@ -109,6 +111,9 @@ KPSE_FOR_PKGS([syslib],
if test "x$syslib_status" = xno; then
AC_MSG_ERROR([some requested system libraries failed])
fi
+if test "x$syslib_used:$enable_native_texlive_build" = xyes:yes; then
+ AC_MSG_ERROR([you can not use system libraries for a native TeX Live build])
+fi
KPSE_RESTORE_FLAGS
AS_IF([test "x$cross_compiling:$enable_xetex" = xyes:yes],