summaryrefslogtreecommitdiff
path: root/Build/source/Makefile.am
diff options
context:
space:
mode:
authorKarl Berry <karl@freefriends.org>2009-12-24 18:51:38 +0000
committerKarl Berry <karl@freefriends.org>2009-12-24 18:51:38 +0000
commita2eb7858f36f976971477d13bc9e87b40b554a31 (patch)
tree9883dd0cc977271c1bc913f2fc959fb4d0b20e08 /Build/source/Makefile.am
parent8f64709f205bc04159b5a6ca926d9c09e26061ae (diff)
run make check at make world
git-svn-id: svn://tug.org/texlive/trunk@16500 c570f23f-e606-0410-a88d-b1316a301751
Diffstat (limited to 'Build/source/Makefile.am')
-rw-r--r--Build/source/Makefile.am9
1 files changed, 9 insertions, 0 deletions
diff --git a/Build/source/Makefile.am b/Build/source/Makefile.am
index ec85b1543ee..d569191eb09 100644
--- a/Build/source/Makefile.am
+++ b/Build/source/Makefile.am
@@ -42,9 +42,18 @@ DIST_SUBDIRS = auxdir/auxsub texk/kpathsea libs utils texk
# and there is no install-hook or install-local.
world: all
## Serialize 'make all' and 'make install-strip'.
+ @echo "top-level make $@: running $(check_target)..."
+ $(MAKE) $(AM_MAKEFLAGS) $(check_target)
+##
+ @echo "top-level make $@: running install-strip..."
$(MAKE) $(AM_MAKEFLAGS) install-strip
##
@echo "top-level make $@: running texlinks in texk/tetex..."
cd texk/tetex && $(MAKE) $(AM_MAKEFLAGS) run-texlinks
##
@echo "make $@ done."
+
+# Allow for skipping make check if needed.
+check_target = check
+skip:
+.PHONY: skip