summaryrefslogtreecommitdiff
path: root/Build/source/Makefile.am
diff options
context:
space:
mode:
authorPeter Breitenlohner <peb@mppmu.mpg.de>2013-09-09 08:31:11 +0000
committerPeter Breitenlohner <peb@mppmu.mpg.de>2013-09-09 08:31:11 +0000
commit8ebb0079ddc9941c4bce2f9cb38fd1cd6957ebae (patch)
tree19f11e56c0c2b60f0455a08165bcec6c9f005cb1 /Build/source/Makefile.am
parent4fd3c95ff0083729460b52ee6594e137b882186e (diff)
Added a preliminary texlive.info
Various minor build fixes git-svn-id: svn://tug.org/texlive/trunk@31604 c570f23f-e606-0410-a88d-b1316a301751
Diffstat (limited to 'Build/source/Makefile.am')
-rw-r--r--Build/source/Makefile.am9
1 files changed, 9 insertions, 0 deletions
diff --git a/Build/source/Makefile.am b/Build/source/Makefile.am
index e328bf1dab6..80fa39e3a3f 100644
--- a/Build/source/Makefile.am
+++ b/Build/source/Makefile.am
@@ -7,6 +7,10 @@
##
ACLOCAL_AMFLAGS = -I m4 --force
+## The info files
+info_TEXINFOS = doc/texlive.texi
+doc_texlive_TEXINFOS = doc/build.texi doc/build-tools
+
## speed up distcheck
AM_DISTCHECK_CONFIGURE_FLAGS = -C
## check as well for symlinks
@@ -73,6 +77,11 @@ endif !cross
skip:
.PHONY: skip
+# Directly run texlinks.
+.PHONY: texlinks
+texlinks:
+ cd $(texlinks_dir) && $(MAKE) $(AM_MAKEFLAGS) run-texlinks
+
# Special target to run TRIP and TRAP tests and create diffs.
.PHONY: triptrap
triptrap: