summaryrefslogtreecommitdiff
path: root/Build/source/Makefile.am
diff options
context:
space:
mode:
authorDenis Bitouzé <dbitouze@wanadoo.fr>2021-02-25 18:23:07 +0000
committerDenis Bitouzé <dbitouze@wanadoo.fr>2021-02-25 18:23:07 +0000
commitc6101f91d071883b48b1b4b51e5eba0f36d9a78d (patch)
tree1bf7f5a881d7a4f5c5bf59d0b2821943dd822372 /Build/source/Makefile.am
parent07ee7222e389b0777456b427a55c22d0e6ffd267 (diff)
French translation for tlmgr updated
git-svn-id: svn://tug.org/texlive/trunk@57912 c570f23f-e606-0410-a88d-b1316a301751
Diffstat (limited to 'Build/source/Makefile.am')
-rw-r--r--Build/source/Makefile.am105
1 files changed, 0 insertions, 105 deletions
diff --git a/Build/source/Makefile.am b/Build/source/Makefile.am
deleted file mode 100644
index 7db6b6b5136..00000000000
--- a/Build/source/Makefile.am
+++ /dev/null
@@ -1,105 +0,0 @@
-## $Id$
-## Makefile.am for the TeX Live top-level
-##
-## Copyright 2016-2020 Karl Berry <tex-live@tug.org>
-## Copyright 2009-2015 Peter Breitenlohner <tex-live@tug.org>
-## You may freely use, modify and/or distribute this file.
-##
-## Ensure aclocal.m4 is up to date
-ACLOCAL = @ACLOCAL@ --force
-
-## speed up distcheck
-AM_DISTCHECK_CONFIGURE_FLAGS = -C
-## check as well for symlinks
-distuninstallcheck_listfiles = find . -type f -o -type l -print
-distcleancheck_listfiles = find . -type f -o -type l -print
-
-EXTRA_DIST = \
- Build \
- README.0overview \
- README.1prerequisites \
- README.2building \
- README.3installing \
- README.4layout \
- README.5configure \
- README.6cross \
- README.7coding \
- build-aux/README.TL \
- m4/ChangeLog \
- m4/README \
- reautoconf
-
-# Files not to be distributed
-include $(srcdir)/am/dist_hook.am
-
-SUBDIRS = . doc $(MAKE_SUBDIRS) libs utils texk
-DIST_SUBDIRS = auxdir/auxsub doc $(CONF_SUBDIRS) libs utils texk
-
-## Configure and build subdirs.
-##
-recurse_this =
-recurse_top =
-
-include $(srcdir)/am/recurse.am
-
-# This (world) is the default target for the ./Build script in TeX Live.
-.PHONY: world
-# Run texlinks here since the binaries won't be there
-# at install-data, and fmtutil.cnf won't be there at install-exec,
-# and there is no install-hook or install-local.
-texlinks_dir = texk/texlive/tl_support
-world: all
-# Serialize 'make all' and 'make install-strip'.
- @echo "top-level make $@: running install-strip..."
- $(MAKE) $(AM_MAKEFLAGS) install-strip
-#
-# Just in case it's not a full checkout.
- if test -d "$(texlinks_dir)"; then \
- echo "top-level make $@: making run-texlinks in $(texlinks_dir) ..."; \
- cd $(texlinks_dir) && $(MAKE) $(AM_MAKEFLAGS) run-texlinks; \
- else :; fi
-#
- @echo "top-level make $@: running $(check_target)..."
- $(MAKE) $(AM_MAKEFLAGS) $(check_target)
-#
- @echo "top-level make $@ done."
-
-# create file buildinfo.log in working directory, to record relevant
-# information about the build environment.
-buildinfo:
- -env MAKE="$(MAKE)" LDFLAGS="$(LDFLAGS)" \
- CC="$(CC)" CFLAGS="$(CFLAGS)" \
- CXX="$(CXX)" CXXFLAGS="$(CXXFLAGS)" \
- OBJCXX="$(OBJCXX)" OBJCXXFLAGS="$(OBJCXXFLAGS)" \
- $(srcdir)/doc/buildinfo.sh >buildinfo.log
-
-# should be harmless to run it, but just in case:
-build_info_target = buildinfo
-
-# run buildinfo first.
-all-recursive: buildinfo
-
-install-exec-hook:
- @echo "WARNING: make install does not result in a usable TeX!"
- @echo " ! The binaries require the myriad support files."
- @echo " ! See http://tug.org/texlive/distro.html"
- @echo " ! and http://tug.org/texlive/build.html#deploy, for example."
-
-# Allow for skipping make check if needed.
-if cross
-check_target = skip
-else !cross
-check_target = check
-endif !cross
-skip:
-.PHONY: skip
-
-# Convenience targets to run texlinks and reautoconf.
-.PHONY: texlinks
-texlinks:
- cd $(texlinks_dir) && $(MAKE) $(AM_MAKEFLAGS) run-texlinks
-
-# Special target to run TRIP and TRAP tests and create diffs.
-.PHONY: triptrap
-triptrap:
- cd texk && $(MAKE) $(AM_MAKEFLAGS) $@