summaryrefslogtreecommitdiff
path: root/Build/source/Makefile.am
diff options
context:
space:
mode:
authorPeter Breitenlohner <peb@mppmu.mpg.de>2009-05-22 10:00:29 +0000
committerPeter Breitenlohner <peb@mppmu.mpg.de>2009-05-22 10:00:29 +0000
commit7a1cbc2ef3e12bd173d6f20546e1e7b28d805379 (patch)
tree601e60d45f96b56189259a0bcab90e4e5a199b01 /Build/source/Makefile.am
parentf16f1251cbf575f1ed10f33874ade6da8dd53d21 (diff)
fix problem with parallel 'make world'
git-svn-id: svn://tug.org/texlive/trunk@13374 c570f23f-e606-0410-a88d-b1316a301751
Diffstat (limited to 'Build/source/Makefile.am')
-rw-r--r--Build/source/Makefile.am9
1 files changed, 6 insertions, 3 deletions
diff --git a/Build/source/Makefile.am b/Build/source/Makefile.am
index 61e2594ae2c..bdb2dddc7d2 100644
--- a/Build/source/Makefile.am
+++ b/Build/source/Makefile.am
@@ -32,11 +32,14 @@ endif !build_kpathsea
SUBDIRS += libs utils texk
# This is the default target for the Build script in TeX Live.
-#
-# run texlinks here since the binaries won't be there
+.PHONY: world
+# Run texlinks here since the binaries won't be there
# at install-data, and fmtutil.cnf won't be there at install-exec,
# and there is no install-hook or install-local.
-world: all install-strip
+world: all
+## Serialize 'make all' and 'make install-strip'.
+ $(MAKE) $(AM_MAKEFLAGS) install-strip
+##
echo "top-level make $@: running texlinks ..."
cd texk/tetex && $(MAKE) $(AM_MAKEFLAGS) run-texlinks
##