summaryrefslogtreecommitdiff
path: root/Build/source/Makefile.am
diff options
context:
space:
mode:
authorKarl Berry <karl@freefriends.org>2020-05-28 22:03:59 +0000
committerKarl Berry <karl@freefriends.org>2020-05-28 22:03:59 +0000
commit030005d0c8d0434c0c00a481799634ad045a6449 (patch)
treeb5ee729f13b79c2d9af50940e91513ebf7919165 /Build/source/Makefile.am
parentc88a7b89c9b0fb65a94c28f07ba277decc224f74 (diff)
do not run texlinks if it is not installed
git-svn-id: svn://tug.org/texlive/trunk@55329 c570f23f-e606-0410-a88d-b1316a301751
Diffstat (limited to 'Build/source/Makefile.am')
-rw-r--r--Build/source/Makefile.am7
1 files changed, 5 insertions, 2 deletions
diff --git a/Build/source/Makefile.am b/Build/source/Makefile.am
index 729fc8beb68..7db6b6b5136 100644
--- a/Build/source/Makefile.am
+++ b/Build/source/Makefile.am
@@ -53,8 +53,11 @@ world: all
@echo "top-level make $@: running install-strip..."
$(MAKE) $(AM_MAKEFLAGS) install-strip
#
- @echo "top-level make $@: making run-texlinks in $(texlinks_dir) ..."
- cd $(texlinks_dir) && $(MAKE) $(AM_MAKEFLAGS) run-texlinks
+# Just in case it's not a full checkout.
+ if test -d "$(texlinks_dir)"; then \
+ echo "top-level make $@: making run-texlinks in $(texlinks_dir) ..."; \
+ cd $(texlinks_dir) && $(MAKE) $(AM_MAKEFLAGS) run-texlinks; \
+ else :; fi
#
@echo "top-level make $@: running $(check_target)..."
$(MAKE) $(AM_MAKEFLAGS) $(check_target)