summaryrefslogtreecommitdiff
path: root/obsolete/language/thai/thailatex/doc/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'obsolete/language/thai/thailatex/doc/Makefile.am')
-rw-r--r--obsolete/language/thai/thailatex/doc/Makefile.am23
1 files changed, 23 insertions, 0 deletions
diff --git a/obsolete/language/thai/thailatex/doc/Makefile.am b/obsolete/language/thai/thailatex/doc/Makefile.am
new file mode 100644
index 0000000000..3862c47015
--- /dev/null
+++ b/obsolete/language/thai/thailatex/doc/Makefile.am
@@ -0,0 +1,23 @@
+DOC_FILES = orchid.tex utf-example.tex
+
+examplesdir = $(docdir)/examples
+examples_DATA = $(DOC_FILES)
+
+EXTRA_DIST = $(DOC_FILES) $(check_SCRIPTS)
+
+CLEANFILES = *.log *.aux *.ttex *.pdf
+
+SUFFIXES = .tex .pdf
+
+.tex.pdf:
+ if test "x$(SWATH)" != "xno" ; then \
+ $(SWATH) -f latex < $< > $@.ttex ; \
+ elif test "x$(CTTEX)" != "xno" ; then \
+ $(CTTEX) -W < $< > $@.ttex ; \
+ else \
+ cp $< $@.ttex ; \
+ fi
+ $(PDFLATEX) $@.ttex
+ $(PDFLATEX) $@.ttex
+ mv $@.pdf $@
+