summaryrefslogtreecommitdiff
path: root/graphics/asymptote/LspCpp/third_party/uri/deps/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/asymptote/LspCpp/third_party/uri/deps/CMakeLists.txt')
-rw-r--r--graphics/asymptote/LspCpp/third_party/uri/deps/CMakeLists.txt30
1 files changed, 30 insertions, 0 deletions
diff --git a/graphics/asymptote/LspCpp/third_party/uri/deps/CMakeLists.txt b/graphics/asymptote/LspCpp/third_party/uri/deps/CMakeLists.txt
new file mode 100644
index 0000000000..7d2eb81028
--- /dev/null
+++ b/graphics/asymptote/LspCpp/third_party/uri/deps/CMakeLists.txt
@@ -0,0 +1,30 @@
+# Note: CMake support is community-based. The maintainers do not use CMake
+# internally.
+
+cmake_minimum_required(VERSION 3.5)
+
+if (POLICY CMP0048)
+ cmake_policy(SET CMP0048 NEW)
+endif (POLICY CMP0048)
+
+project(googletest-distribution)
+set(GOOGLETEST_VERSION 1.11.0)
+
+if(NOT CYGWIN AND NOT MSYS AND NOT ${CMAKE_SYSTEM_NAME} STREQUAL QNX)
+ set(CMAKE_CXX_EXTENSIONS OFF)
+endif()
+
+enable_testing()
+
+include(CMakeDependentOption)
+include(GNUInstallDirs)
+
+#Note that googlemock target already builds googletest
+option(BUILD_GMOCK "Builds the googlemock subproject" ON)
+option(INSTALL_GTEST "Enable installation of googletest. (Projects embedding googletest may want to turn this OFF.)" ON)
+
+if(BUILD_GMOCK)
+ add_subdirectory( googlemock )
+else()
+ add_subdirectory( googletest )
+endif()