PS View

przegladarka — PostScript i PDF
wykorzystuje Ghostscript
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1. Przedstawienie programu i srodowiska

Program PS_View jest przegladarka dokumentéw postscriptowych i PDF-6w dostepna na wielu
platformach (wersje binarne sa przygotowane dla systeméw Linux i386 oraz MS Windows).
PS_View korzysta z interakcyjnego interpretera PostScriptu, jakim jest Ghostscript, i wymaga
obecnosci Ghostscriptu w wersji 7.00 lub nowsze;j.

PostScript (TM) jest jezykiem opisu grafiki opracowanym przez firme Adobe, ktéry jest
niekwestionowanym standardem $wiatowym. Interpretery PostScriptu dostepne sa we wszystkich
systemach operacyjnych, umozliwiajac druk dokumentéw tekstowych i graficznych na praktycznie
wszystkich drukarkach i fotonaswietlarkach.

PDF (Portable Document Format), réwniez produkt firmy Adobe, w ostatnich latach zyskuje
sobie coraz wieksza popularno$¢, zwtaszcza w Internecie, ale takze wypierajac PostScript
w zastosowaniach pre-press.

Ghostscript, produkt firmy Artifex (stworzony przez Petera L Deutsha), jest interpreterem
PostScriptu i PDF-a. Umozliwia takze otrzymywanie plikéw PDF z PostScriptu. Istotng cecha
Ghostscriptu jest jego otwarto$¢ i dostepnos¢ na warunkach licencji GPL (GNU Public License)
oraz obecno$¢ w wielu systemach operacyjnych (m.in. Linux, MS Windows i Mac OS). Najnowsza
wersje Ghostscriptu mozna pobraé z Internetu, np. ze strony http://wuw.ghostscript.com.

Ghostscript ,,nieuzbrojony” pozwala jedynie na najprostszy podglad kolejnych stron dokumentu.
PS_View tworzy graficzny interfejs do Ghostscriptu, ktéry umozliwia obejrzenie dowolnej strony
dokumentu (lub kilku na raz) w wybranym powiekszeniu, dowolng zmiane powiekszenia (zoom),
przesuniecia, obroty, lustrzane odbicie, mierzenie, drukowanie, a takze odswiezanie obrazu w tle
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i restart. PS_View wykorzystuje zaréwno system menu i mysz, jak i liczne skréty klawiszowe,
przyjmuje tez polecenia jezyka PostScript.

Innym znanym programem tego typu dostepnym zaréwno w Linuxie jak i MS Windows jest
GSview, ktérego autorem jest Russell Lang, Ghostgum Software Pty Ltd.

Na rys. 1 przedstawiony jest schemat logiczny modutéw wspdtpracujacych ze soba w programie
PS_View.

Rys. 1

PS_View.ps psv.wx.lua libgs.so/gsdll.dll
Podstawowy Skrypt wxLua
modut roboczy zawiadujacy Ghostscript
PS_View obstuga GUI
A A A
A A A
biblioteka biblioteka
wxLua wxGhostscript
i jej moduty

biblioteka wxWidgets

gswxluas/gswxlua.exe




Podstawowy modut PS_View zostat napisany w PostScripcie, a wiec wszystkie funkcje programu
realizowane s3 przez makra postscriptowe. Mozliwe jest wywotanie tych funkcji przez napisanie
odpowiedniej nazwy (by¢ moze poprzedzonej parametrami, zgodnie z notacja ONP jezyka
PostScript). Wszystkie operacje wykonywane za pomoca myszy, dostepne poprzez menu oraz
skréty klawiszowe ttumaczone s3 na wywotania odpowiednich makr. Lista makr PS_View
dostepnych dla uzytkownika znajduje sie w dodatku A.

Obstuga interfejsu graficznego zajmuje sie modut napisany w jezyku Lua z uzyciem biblioteki
graficznej wxWidgets (to bardzo efektywne i wygodne zestawienie jest owocem projektu wxLua).
Lua jest jezykiem skryptowym, co bardzo utatwia ewentualne modyfikacje programu i dodawanie
nowych funkcjonalnosci. wxWidgets jest wieloplatformowa biblioteka graficzna umozliwiajaca
korzystanie z rozmaitych kontrolek i funkcji interfejsu GUI w sposéb niezalezny od systemu.



1.1. Zawarto$¢ pakietu
Pakiet PS_View zawiera nastepujace pliki:

README — krotki tekstowy opis programu

gswxluas — program komunikujacy sie z Ghostscriptem i interpretujacy skrypt wxLua
(wersja Linuxowa, ELF i386)

gswxlua.exe — program komunikujacy sie z Ghostscriptem i interpretujacy skrypt wxLua
(wersja MS Windows, EXE WIN32)

psv.wx.lua — program wxLua, modut interfejsu graficznego

psv_view.ps — plik postscriptowy, modut roboczy

psv — skrypt powtoki uruchamiajacy PS_View

psv.bat — plik wsadowy uruchamiajacy PS_View

psv.exe — plik exe dla MS Windows, ,wrapper” réwnowazny psv.bat

psv.desktop  — plik opisujacy aplikacje dla X Window

PSV.Xpm — ikona programu dla X Window

psv_about.ps — plik postscriptowy, informacja o programie

psv_usage.pdf - plik PDF, instrukcja obstugi programu — ten dokument

en, pl — katalogi zawierajace ttumaczenia programu



1.2. Instalacja programu

Zaktadamy, ze w systemie jest poprawnie zainstalowany program Ghostscript (wersja 7.00 lub
nowsza, zalecane jest wersja > 8.50).

W systemie Linux pliki wymienione w poprzednim punkcie (z wyjatkiem psv) umieszczamy

w osobnym katalogu np. /usr/local/share/PS_View/. Skrypt powtoki umieszczamy w katalogu
wymienionym w systemowej Sciezce dostepu PATH (np. /usr/local/bin/) i dopisujemy w nim
Sciezke do pliku gswxluas. Mozna przenie$¢ pliki lokalizacyjne do odpowiedniego katalogu
systemowego (np. /usr/local/share/locale/), ale nie jest to konieczne. PS_View domyslnie
skorzysta z systemowej biblioteki Ghostscripta (najczesciej /usr/1ib/libgs.so, mozna wskazac
inna biblioteke wskazujac ja w menu Konfiguracja.

W systemie MS Windows pliki wymienione w poprzednim punkcie (z wyjatkiem psv.bat)
umieszczamy w osobnym katalogu np. C:\Program Files\PS_View\. Plik wsadowy
umieszczamy w katalogu wymienionym w systemowej $ciezce dostepu PATH (zwykle tam, gdzie
znajduja sie inne pliki wsadowe *.bat) i dopisujemy w nim $ciezke pliku gswxlua.exe. PS_View
domyslinie skorzysta z systemowej biblioteki Ghostscripta (odnalezionej w rejestrze, mozna
wskazaé inng biblioteke wskazujac ja w menu Konfiguracja.



2. Postugiwanie sie programem

2.1. Uruchomienie PS_View

Jest kilka sposobéw uruchamiania PS_View.

2.1.1. Sposéb ,konsolowy”

PS_View uruchamiamy wykonujac plik wsadowy psv (lub psv.bat) z parametrem, bedacym
nazwa dokumentu do ogladania. Jesli uruchomimy psv bez parametru, to w trybie dialogu mozna
otworzy¢ pozadany dokument. Jesli korzystamy z programu nawigacyjnego (np. Far, Midnight
Commander, DOS Navigator, Norton Commander), to mozna skojarzy¢ pliki z rozszerzeniem ps,
eps, a takze pdf z plikiem wsadowym psv. | uruchamia¢ PS_View z okreSlonym dokumentem,
najezdzajac belka na dany plik postscriptowy lub PDF i naciskajac Enter lub klikajac podwdjnie
mysza.

2.1.2. Sposéb ,,okienkowy”

a) W systemie Linux wgrywamy do odpowiedniego katalogu (np. /usr/share/applications)
plik psv.desktop. Z poziomu menadzera okien mozemy program doda¢ do odpowiedniego
menu, albo udostepni¢ na pulpicie. Przeniesienie na ikone programu ikony pliku PS lub PDF-a
spowoduje uruchomienie PS_View z tym plikiem jako ogladanym dokumentem.

b) W systemie MS Windows w menu Programy, lub na pulpicie tworzymy skrét do pliku psv.exe.
Przeniesienie na jego ikone ikony pliku PS lub PDF-a spowoduje uruchomienie PS_View z tym
plikiem jako ogladanym dokumentem.
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Oczywiscie podwdjne klikniecie na ikonie programu psv w obu systemach uruchamia PS_View
z komunikatem ,,File not opened”. Wybierajac polecenie menu File - Open, w trybie dialogu
mozna otworzy¢ pozadany dokument.

c) Mozemy takze dokona¢ asocjacji typéw plikéw (np. z rozszerzeniem .ps (.prn, .eps),
z PS_View, tak aby systemowa operacja ,otwarcia” tych plikéw odbywata sie standardowo
przez PS_View.

2.2. Zamkniecie PS_View

Zwykte wyjscie z programu odbywa sie za pomoca polecenia menu File > Quit, mamy
wéwczas mozliwos$¢ zapisania pliku restartowego (por. 2.6).

Program mozna tez zamkna¢ w sposéb ,,ogélnowindowsowy", klikajac lewym klawiszem myszy na
krzyzyk w prawym gérnym narozniku okna programu lub uzywajac skrétu klawiszowego A1t+F4.
Takie zamkniecie nie powoduje zapisania restartu.
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2.3. Interfejs (obraz, menu, pasek stanu, konsola, skréty klawiszowe)

PS_View po uruchomieniu tworzy dwa okna: okno obrazu i okno konsoli (z tym, ze to drugie
standardowo jest ukryte, por. rys. 2).

‘£ ALA ps - Ghostseript =1 4]
AFPL Ghostscript 5.00 (2002-11-21) a
Copyright (C) 2002 artofeode LLC, Benicia,
This softwars comes with NO WARRANTY: see
G3> (START) 492 412 /STARTSIZE EVENTCOMMA
GS» (MENT) 482 393 /RESIZE EVENTCOMIAND
GSr (STATUS) 492 373 /RESIZE EVENTCOMMAND
5>

“%> (RESIZE) 492 414 /RESIZE EVENTCOMMAND
> /UP_ARR /NORM KEYCOMMAND

>

& ALA.ps - Ghostscript + PS_View
Fie Edt | View Pages Giids kFrames  Options Help

Zoomin 1+HumpadFlus

Zoom gut

eNumpadiinus

Center CHiF11 180 (upsidedown]

Reset zoom & pastion F11
Reset hiansformations  Shit+F11
>~@ ma kot W@ .

Zoom: 12,4304 A 2 3

okl Page: 1/2 | Angen |

Rys. 2.



2.3.1. Okno obrazu

W gérnej czesci okna znajduje sie menu rozwijalne, ktére umozliwia sterowanie programem
za pomocg myszy lub, po wcisnieciu klawisza Alt, przez naciskanie klawiszy podkreslonych
liter i cyfr. Istnieja tez skréty klawiszowe (zapisane po prawej stronie nazw pdl menu), ktérymi
wygodnie wywotuje sie czesciej uzywane funkcje programu bez koniecznosci rozwijania menu.
Petna lista skrotéow klawiszowych podana jest w dodatku B. Warto je zapamietac i ich uzywad.

Zasadnicza cze$¢ okna zajmuje kadr wybranej strony ogladanego dokumentu. W przypadku
zwyktych dokumentéw PS i PDF strona jest przedstawiona jako biaty prostokat o wymiarach
prostokata ograniczajacego (bounding box) umieszczony na szarym tle. W przypadku, gdy
prostokat ograniczajacy nie jest okreslony, szarego tta nie stosuje sie. Szare tto mozna usunaé
(przywrécic) wybierajac polecenie menu Options = Background off (om).

W dolnej czesci okna znajduje sie listwa stanu informujaca o stanie dokumentu, zawiera ona
(od lewej):

- znaczek OK pojawiajacy sie, gdy poprawnie zakonczona zostata kolejna akcja (lub ERR
w przypadku bfedu),

« numer kolejny ogladanej strony lub zakres stron (w przypadku pracy wielostronicowej)
oraz liczba wszystkich stron dokumentu,

* kat obrotu (wielokrotno$¢ 90 stopni),

« informacje o odbiciu lustrzanym (pionowym lub poziomym),

* biezacy wspétczynnik przeskalowania (zoom),

* miejsce na komunikaty (np. wyniki pomiaréw) i sygnaty btedu.
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2.3.2. Okno konsoli

Jest to okno tekstowe stowarzyszone z programem PS_View. Zawiera ono zapis dialogu
prowadzonego z Ghostscriptem (szczegdtowos¢ tego zapisu mozna regulowac parametrami
wywotania -v i -q). Okno konsoli spetnia wazna role podczas debuggingu, gdyz w przypadku
wystapienia btedu w ogladanym dokumencie, w oknie konsoli pojawia sie petniejszy opis btednej
sytuacji. Uzytkownik moze wtaczyé okno konsoli, wybierajac pozycje Show PS console w menu
Options (albo wywotujac program z opcja —c). Wytaczenia konsoli dokonuje sie klikajac
standardowo na jej prawy gérny rég. Po ustawieniu sie na dolnej czesci okna konsoli, dowolny
tekst napisany przez uzytkownika jest interpretowany jako ciagg komend postscriptowych. Mozna
tez pisa¢ komendy postscriptowe bedac w oknie obrazu, s3 one przekazywane do konsoli, nawet
gdy okno konsoli jest ukryte.

2.4. Otwieranie dokumentéw

Wybranie polecenia menu File - Open powoduje otwarcie standarowego okna dialogowego
systemu Windows, umozliwiajacego otwarcie nowego dokumentu PS (EPS) lub PDF. PS_View
w jednym oknie (instancji) moze pracowac najwyzej z jednym dokumentem, tak wiec otwarcie
nowego pliku powoduje zakonczenie pracy z poprzednim dokumentem, jesli byt otwarty. Praca
z wieloma dokumentami réwnoczesnie jest mozliwa, gdy zostang one otwarte w réznych
instancjach PS_View.
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2.5. Odswiezanie

Mozliwa jest modyfikacja lub ponowne utworzenie dokumentu, ktérego obraz pokazuje PS_View,
wéwcezas wykonanie w PS_View operacji od$wiezajacej obraz (np. File - Refresh lub Edit
- Redraw), badZz ponowne uruchomienie PS_View (w tej samej instancji) powoduje interpretacje
zmodyfikowanego dokumentu i ustawienie sie — jesli to mozliwe — w tej samej pozycji ekranu.
Jesli chcemy otworzy¢ kolejne okno dla tego samego dokumentu, nalezy wywotaé program

z dodatkowym parametrem -n.

2.6. Restart

Wychodzac z programu PS_View za pomoca polecenia menu File - Quit, otrzymujemy
propozycje zapisania pliku umozliwiajacego restart, czyli zachowanie pozycji ekranu w dokumencie
(tzn. numeru strony, pozycji na stronie i innych waznych parametréw), umozliwiajace odtworzenie
tej pozycji przy ponownym wejSciu do programu. Plik restartowy zwykle zapisywany jest

w biezacym katalogu lub w miejscu wskazanym przez podanie odpowiedniej nazwy pliku
restartowego w pliku konfiguracyjnym. Informacje restartowe mozna tez zapisa¢ lub wezytac (bez
opuszczania programu) za pomoca poleced menu File & Restart = Save (Save as)

(File > Restart - Load (Load from)). Mechanizm restartu utatwia ustawienie ekranu

w takiej samej pozycji dla kilku réwnoczesnie otwartych (w réznych instancjach programu)
dokumentéw, np. wyciagéw barwnych. Wystarczy w kazdej otwartej instancji wczytac ten sam
plik restartowy.
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2.7. DSC

Nawigowanie w wielostronicowym dokumencie postscriptowym oparte jest na analizie komentarzy
strukturalnych zgodnych z DSC (document structuring conventions), ktérych obecnosé¢

i poprawno$¢ jest niezbednym warunkiem umozliwiajacym wiasciwe przetwarzanie i podziat
dokumentu na sktadniki strukturalne. Oczekujemy, ze w dokumencie postscriptowym daja

sie wyodrebni¢ (by¢ moze pojawiajace sie wielokrotnie lub pominiete) nastepujace sktadniki
strukturalne: Prolog Setup Page. ..

Prolog to zestaw makr, fontéw itd., uzywanych w dalszej czesci dokumentu. Wszystkie czesci
dokumentu zakwalifikowane jako prolog s3 interpretowane przez PS_View tylko raz, po wczytaniu
nowego lub zmienionego dokumentu.

Setup to zestaw makr, fontéw itd. uzywanych w dalszej czeSci dokumentu. Czesci dokumentu
zakwalifikowane jako setup, poprzedzajace w dokumencie przetwarzang strone s3 interpretowane
przez PS_View przed kazdym wysSwietleniem strony.

Page (strona) to cze$¢ dokumentu zawierajaca elementy wystepujace tylko na jednej stronie.
Zaktadamy, ze zadne elementy na stronie nie wptywaja na zawarto$¢ (interpretacje) innych stron.
Jedli ten warunek nie jest spetniony (a czasem rzeczywiscie nie jest!), to wyswietlony obraz
zalezy od kolejnosci w jakiej przegladamy strony, moze to tez prowadzi¢ do wystapienia btedu.
Wewnatrz stron spodziewamy sie tez wystapienia inkluzji (np. EPS-6w), ktérych komentarze
strukturalne pomijamy.
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Ponizej przedstawiamy zestawienie rozpoznawanych przez PS_View komentarzy strukturalnych
oraz nadawanych im znaczen.

%/%BeginDocument Poczatek inkluzji (ignorowanie DSC, czekanie na koniec inkluzji)
%%EndDocument Koniec inkluzji (wznowienie interpretacji DSC)
%/%BoundingBox: Wyznaczenie prostokata ograniczajacego dokumentu
%/%HiResBoundingBox:

%%DocumentMedia:

%%BeginProlog Poczatek prologu (koniec setupu, koniec strony)

%/BeginSetup

%DVIPSEndSection

%DVIPSBeginSection | Poczatek setupu (koniec prologu, koniec strony)

%DVIPSSectionPage: Poczatek strony (koniec prologu, koniec setupu, koniec strony)
hlhPage:

%% Page:

%LEOF Koniec dokumentu
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2.8. Zmiana strony

Polecenia menu z grup Pages oraz Options - Set multipage - Bundle stuza do zmiany
ogladanej strony dokumentu (lub grupy stron, w przypadku pracy wielostronicowej). Operacje
zwigzane z praca wielostronicowa opisane sa w 2.14.

Polecenie menu Pages - Next powoduje przejScie na kolejng strone w ogladanym dokumencie.
Poprzedzenie polecenia liczbg catkowita powoduje przejscie o te liczbe stron w przéd (lub w tyt,
gdy jest to liczba ujemna). Takze nacisniecie klawisza Enter (jesli nie jeste$ w trakcie wpisywania
nazwy makra) powoduje przejscie do nastepnej strony.

Polecenie menu Pages > Previous powoduje przejScie na poprzednig strone w ogladanym
dokumencie. Poprzedzenie polecenia liczba catkowita powoduje przejscie o te liczbe stron w tyt
(lub w przéd, gdy jest to liczba ujemna).

Polecenie menu Pages > Specified powoduje przejScie na strone o podanym numerze. Numer
strony podaje sie w oknie dialogowym. Uzycie makra pn (lub réwnowaznie np) poprzedzonego
liczba catkowita umozliwia bezposrednie (tzn. bez dialogu) przejscie na wybrana strone (por.
dodatek A).

Polecenie menu Pages > First powoduje przejécie na pierwsza strone dokumentu.

Polecenie menu Pages - Last powoduje przejscie na ostatnig strone dokumentu.
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2.9. Widok strony

Grupa polecen w menu View obejmuje operacje umozliwiajace zmiany widoku w obrebie dane;j
strony dokumentu (zoom, przesuwanie, obroty, lustrzane odbicie).

2.9.1. Zoom

Wygodnym sposobem powiekszenia wybranego fragmentu obrazu jest wyznaczenie tego
fragmentu przez przesuwanie mysza z wcisnietym lewym klawiszem.

Zmniejszenie obrazu osiagamy uzywajac myszy do wyznaczenia jaki fragment nowego ekranu ma
stanowi¢ wtasnie widziany obraz. Osigga sie to poprzez przesuwanie mysza z wcisnietym lewym
klawiszem przy nacisnietym klawiszu Ctrl.

Powiekszenie (zmniejszenie) obrazu jest osiggalne réwniez z menu: View - Zoom in (View
- Zoom out) Powiekszenie (zmniejszenie) zachowuje pofozenie srodka ekranu. Wartos$¢
domysina wspétczynnika powiekszenia (zmniejszenia) wynosi zoom_factor = 1,414. Mozna ja
zmieni¢ wykonujac w menu Options - Set zoom factor.

Przydatne do ustalania kadru okazuja sie takze polecenia View > Fit to BB, View > Fit
to width, View > Fit to height, ktére tak zmniejszaja lub powiekszaja obraz, aby caty
prostokat ograniczajacy strony ogladanego dokumentu, tzw. bounding box (odpowiednio: tylko
jego szeroko$¢ lub wysoko$¢) miescit sie w oknie programu.

W przypadku pracy wielostronicowej (Options = Set multipage) polecenia View > Fit to
BB, View - Fit to width, View > Fit to height dotycza catej paczki wyswietlanych stron
(jej tacznej szerokosci lub wysokosci).
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2.9.2. Przesuniecia

Kadr widoczny na ekranie mozna zmienié, bez zmiany powiekszenia, dokonujac przesuniecia
ekranu w lewo (prawo, gére dét), zaleznie od operacji menu:

View > Move - Left

View > Move - Right

View > Move - Up

View - Move - Down.

Operacje przesuniecia mozna poprzedzi¢ liczbg catkowita, wyrazajaca wielko$¢ kroku przesuniecia.
Domyslnie jest to 1/10 szerokosci (wysokosci) okna.

Krok mozna tez podaé poleceniem menu Options > Set shift length.

Do przesuwania wygodnie uzywa sie klawiszy strzatek (por. dodatek B). Mnemotechnika: strzatka
w gore lub w lewo przenosi nas ,wyzej" w tekscie. Uzycie strzatki przesuniecia z réwnoczesnie
wcisnietym klawiszem Shift przesuwa ekran o krok 5 razy wiekszy od domysinego (podanego).

Przesuwanie ekranu mozna tez realizowaé, uzywajac kétka myszy: normalnie — géra, dot,
z nacisnietym klawiszem Ctrl — lewo, prawo.

Do przesuwania mozna wreszcie uzy¢ myszy, wlokac z wcisnietym lewym klawiszem myszy,
przy wcisnietym na klawiaturze klawiszu spacji. Odpowiada to ,tapaniu i ciggnieciu” obrazka,
w odréznieniu od przesuwania ekranu za pomoca klawiszy (lub kétka myszy).
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Do umieszczenia na $rodku ekranu strony postscriptowej (wyznaczonej przez prostokat
ograniczajacy) lub paczki stron, w przypadku trybu wielostronicowego, stuzy polecenie View
> Center. Powiekszenie nie ulega zmianie.

Natomiast klawisze kursora i klawisze Home, End, Page Up i Page Down, w potaczeniu
z klawiszem Ctrl powoduja pozycjonowanie odpowiednio krawedzi i rogdw strony postscriptowej
na krawedziach okna.

2.9.3. Obroty

Polecenia menu:

View > Rotate > 90 clockwise

View > Rotate - 90 anticlockwise

View > Rotate = 180 (upsidedown)

powoduja obrdcenie obrazu widocznego na ekranie odpowiednio: o 90 stopni zgodnie z ruchem
wskazéwek zegara, o 90 stopni przeciwnie do ruchu wskazéwek zegara, o 180 stopni.

2.9.4. Odbicie lustrzane

Polecenia menu:

View - Flip - Horizontal

View - Flip - Vertical

powoduja odbicie obrazu widocznego na ekranie wzgledem odpowiednio: pionowej lub poziomej
osi symetrii okna ekranu.
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2.9.5. Przywracanie ustawien domysinych

Polecenie menu View > Reset zoom & position powoduje wyswietlenie na Srodku ekranu
obrazu ogladanej strony (stron) z powiekszeniem 1. Nie ulega zmianie biezacy kat ani odbicie
lustrzane.

Polecenie menu View - Reset transformations powoduje wyswietlenie na $rodku ekranu
obrazu ogladanej strony (stron) z powiekszeniem 1, katem 0 i bez odbicia lustrzanego.

2.10. Ramki i mierzenie

Za pomocg PS_View mozna otrzymaé informacje o rozmiarach strony dokumentu oraz mierzyé
obiekty widoczne na ekranie.

Do mierzenia rozmiaréw elementéw dokumentu stuza dwa krzyze pomiarowe, kolejno nanoszone
na ekran za pomoca myszy, przy wcisnietym prawym klawiszu myszy. Gdy widoczny jest jeden
krzyz, na pasku stanu wyswietlana jest pozycja jego $rodka. Krzyz pomiarowy mozna przesuwad,
dopdki wcisniety jest prawy klawisz myszy. Dodatkowo, gdy wciéniety jest klawisz Shift, mozna
na pasku stanu zobaczy¢ zmieniajace sie pozycje krzyza podczas ruchu. Przy widocznych dwéch
krzyzach, wyswietlane s3 odlegtosci dx, dy, dz miedzy ich Srodkami oraz katy alpha i beta
nachylenia przekatnych prostokata wyznaczonego przez krzyze (por. rys. 4). Wyniki pomiaréw
mozna przywréci¢ poleceniem Grids & frames - Measure.

Krzyze pomiarowe gasi proba dostawienia trzeciego krzyza lub naciéniecie prawego klawisza myszy
przy wcisnietym klawiszu Ctrl.
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& ALA_ps - Ghostscript + PS_View
Fle Edt Yiew Pages GrdstFiames Optons Help

dy dz

beta
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ok Page: 141 | Ange0 | FipNone | Zoom B3001  dwe0.525 cp=0.256 ce=0584 om alpha=26.041 beta=63953

Rys 4.
Polecenie Grids & frames - Bounding Box wyswietla prostokat ograniczajacy strony

postscriptowej (bounding box) oraz podaje jego rozmiary na pasku stanu. Strony dokumentu,
gdy znany jest bounding box, wyswietlane s3 w biatych prostokatach o rozmiarach prostokata

ograniczajacego umieszczonych na szarym tle.
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Polecenie Grids & frames > Page wysSwietla ramke strony postscriptowej dokumentu oraz
podaje jej rozmiary na pasku stanu. Format strony ustalany bywa jedng z komend PostScriptu:
setpage, setpageparams, setpagedevice lub bezparametrowa komenda typu a4, a3, letter itd.

Polecenie Grids & frames - Printer wysSwietla ramke drukarki, tzn. ten fragment ekranu,
ktéry przy biezacych ustawieniach mozna wydrukowaé poleceniem File - Print. ramka
drukarki jest podwdjna (odlegtos¢ podramek wynosi 6mm) dla wyrdznienia tych czesci dokumentu,
ktére wprawdzie mieszcza sie na stronie, ale wystaja poza pole zadruku wiekszosci drukarek.

Polecenie Grids & frames > Unit grid wyswietla siatke jednostki miary wybranej przez
uzytkownika (por. Options > Set unit). Nazwa jednostki pojawia sie na pasku stanu.

Polecenie Grids & frames > Fine grid wyswietla dwie siatki: jednostki miary wybranej
przez uzytkownika oraz jednostki towarzyszacej (wielokrotnosci lub podwielokrotnosci). Nazwy
wyswietlanych jednostek pojawiaja sie na pasku stanu.

Polecenie Grids & frames - Window grid wyswietla siatke dzielaca wymiary okna programu
na 10 réwnych czesci. W takich jednostkach podaje sie krok przesuniecia ekranu (z wyjatkiem
przesuniecia realizowanego za pomoca myszy).

2.11. Drukowanie

Za pomoca PS_View, wywotujac polecenie File & frames - Print, mozna wydrukowaé
fragment ogladanej strony dokumentu, ktéry wyznaczony jest ramka drukarkowa (por. polecenie
Grids & frames - Printer). Rozmiar papieru i orientacje drukowania wybiera sie za pomoca
polecen zebranych w podmenu Options - Set media.
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2.12. Jednostki

Operacje z grupy Options = Set unit pozwalaja przyjac biezace jednostki dtugosci, w ktérych
podawane s3 rozmiary prostokata ograniczajacego, strony postscriptowej, potozenia i odlegtosci
krzyzy pomiarowych, wyswietlane siatki. Ponizej znajduje si¢ tablica dostepnych jednostek
gtéwnych wraz z jednostkami towarzyszacymi (wielokrotnosciami lub podwielokrotnosciami
jednostki gtéwnej, wykorzystywanymi do wyswietlania siatki poleceniem Grids & frames

- Fine grid)

Jednostka gtéwna Jednostka pomocnicza
cm centymetr mm

mm milimetr cm

in (cal, 1in = 25,4 mm) 1/12in

pt (punkt, 1 in = 72,27 pt) pc (pica, 1 pc = 12 pt)
dd (didot, 1 dd = 1.07 pt) cc (cycero, 1 cc = 12 dd)
bp (punkt postscriptowy, 1 in = 72 bp) 12 bp

2.13. Formaty ,,papieru”

Operacje z grupy Options > Set media pozwalaja przyjaé format strony, ktéra domysinie
(tzn., gdy Zoom = 1) miesci sie w oknie. Jest to zarazem rozmiar ramki drukarkowe;.
Poszczegdlne formaty odpowiadaja kilku standardowym formatom papieru, z wyjatkiem polecenia
> BoundingBox, przy ktdérym rozmiarem strony staje sie prostokat ograniczajacy dokumentu.
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2.14. Praca wielostronicowa

PS_View umozliwia prace w trybie wielostronicowym, tzn. réwnoczesne wyswietlanie kilku
kolejnych stron dokumentu. Odlegto$¢ miedzy stronami, mierzona wzgledem prostokatéw
ograniczajacych, okresla sie w oknie dialogowym, uaktywnionym za pomoca polecenia menu
Options - Set multipage -> Distance.

Polecenie menu Options - Set multipage > 2x1 powoduje wyswietlenie obok siebie dwéch
kolejnych stron dokumentu (np. rozktadéwki). Kolejne polecenia - 2x1 reverse, > 1x2,

> 1x2 reverse réwniez stuza do wyswietlania dwéch stron naraz, ale w odwrotnej kolejnosci
lub utozonych jedna nad druga.

Polecenie & mxn umozliwia ustawienie na ekranie pewnej liczby stron w tablicy m x n, ktérej
rozmiary podaje sie w oknie dialogowym. Dodatkowo polecenie > Permutation umozliwia
wybranie jednej z o$miu wybranych permutacji wskazanej w oknie dialogowym przez podanie
uktadu tablicy 2 x 2. Przy wiekszych tablicach zaktadamy, ze wiersze (kolumny) zawieraja
kolejne strony, wyswietlane w kolejnosci wskazanej przez uktad w tablicy 2 x 2. Oczywiscie,
nie wyczerpuje to wszystkich mozliwosci. Inne permutacje tez s3 dostepne, choé¢ w mniej
wygodny sposéb. Np. napisanie (w oknie konsoli) 3 2 [1 2 3 4 5 6] multipage spowoduje
wyswietlenie tablicy 3 x 2 stron w zwyktej kolejnosci. Dalsze préby pozostawiamy dociekliwym.

Polecenie > Vertical tape wyswietla dokument jako ,tasme filmowa", ze stronami
ustawionymi jedna nad druga. Przesuwajac sie w dét lub do géry przechodzimy na sasiednie
strony.
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Uzycie polecen menu z grupy Pages w odniesieniu do trybu wielostronicowego powoduje przejscie
do ogladania nowej paczki stron, z zatozeniem, ze numery stron zmieniaja sie o wielokrotnos¢
paczki, natomiast nie zmienia sie pozycja stron na ekranie. W kazdym przypadku numery stron
objetych paczka wyswietlone sg na pasku stanu.

Istnieje specjalna grupa polecen menu Options > Set multipage > Bundle obejmujaca
operacje przesuwajace zawartos¢ paczki stron. Dla przyktadu, polecenie > Page down usuwa

z paczki strone o najmniejszym numerze, a dokfada do paczki strone kolejna. Jesli podano liczbe,
bedaca parametrem polecenia, to jego dziatanie ulega zwielokrotnieniu. Kolejne polecenia z tej
grupy dziataja analogicznie.

WHtaczenie opcji Options > Set multipage > Cycle on spowoduje ,dotaczanie” koncowych
stron dokumentu przed jego pierwsza strong oraz ,dotaczanie” poczatkowych stron dokumentu
po jego ostatniej stronie, a wiec poczatkowe i koncowe paczki stron s3 zawsze wypetnione,
jesli tylko dokument posiada wystarczajaca liczbe stron. Umozliwia to np. obejrzenie ostatniej

i pierwszej strony dokumentu (oktadki) jako jednej rozktadéwki.

Dodatek A. Makra PS_View

Ponizej przedstawiamy liste tych makr PS_View, ktére moga stuzy¢ jako skréty operacji menu.
Charakteryzuja si¢ one fatwymi do zapamigtania, krétkimi nazwami. W celu uzycia, wystarczy
napisaé nazwe makra, a po niej nacisna¢ Enter (nawet bez przetaczania sie na okno konsoli).
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Niektére z makr wykorzystuja opcjonalny parametr poprzedzajacy nazwe makra, oznaczony na
liscie jako:

{(FILE_NAME_R)}, {(FILE_NAME_P)} — nazwa pliku w nawiasach okragtych,

{PAGE}, {INCR}, {STEP} — liczba catkowita,

{MAG}, {SHIFT_IN}, {SHIFT} — utamek dziesietny.

Gdy parametr jest pominiety, to przyjmowane sg wartosci domysine:

{(FILE_NAME_R)} = (!ps_rest.ps)

{(FILE_NAME_P)} nazwa pliku podana w specyfikacji biezacej drukarki w pliku PS_Locaw.ps
{INCR} =1

{STEP} =1

{SHIFT} =1

{PAGE}, {MAG}, {SHIFT_IN} — wartosci domyslnych nie przyjmuje sie

Po prawej stronie przedstawiamy polecenia menu odpowiadajace tym makrom.
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{(FILE_NAME_R) }
{(FILE_NAME_R) }
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{PAGE}
{INCR}
{INCR}

{INCR}
{INCR}

rr
wr

pn (np)

pf (fp)
pl (1p)
sn

sp

spf

spl

wbb
wwd
wht
cbb

gg

ggg
fr

File - Restart - Load
File - Restart > Save
z parametrem: wynik dialogu Pages > Specified
bez parametru: wyswietlenie numeru biezacej strony

Pages <> Next

Pages - Previous

Pages - First
Pages > Last

Options - Set
Options > Set
Options - Set
Options - Set
Pages - Reset
Pages - Reset
View -> Fit to
View > Fit to
View > Fit to
View - Center
Grids & Frames
Grids & Frames
Grids & Frames
Grids & Frames

multipage - Bundle - Page up
multipage > Bundle - Page down
multipage - Bundle - Home
multipage - Bundle - End

zoom & position

transformations

BB

width

height

- Window grid
- Unit grid
- Fine grid
- Printer



{MAG}

{SHIFT_IN}

{STEP}

{SHIFT}
{SHIFT}
{SHIFT}
{SHIFT}

{(FILE_NAME_P)}

{INCR}
{INCR}

pg
bb

re

Grids & Frames - Page

Grids & Frames - Bounding Box

z parametrem: wynik dialogu Options - Set zoom factor
bez parametru: wyswietlenie wartosci wspoétczynnika powiekszenia
z parametrem: wynik dialogu Options - Set shift length
bez parametru: wyswietlenie wartosci kroku przesuniecia

View - Zoom in

View - Zoom out

View > Rotate > 90 anticlockwise
View - Flip - Horizontal

View - Flip - Vertical

View > Move > Left

View > Move - Right

View > Move > Up

View > Move -> Down

Edit > Redraw

File - Print

wynik dialogu File - Quit (z zapisaniem restartu)
Edit - Undo

Edit - Redo

leave wynik dialogu File > Quit (bez zapisania restartu)
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Dodatek B. Skroty klawiszowe

Wygodne operowanie programem zapewniajg skréty klawiszowe, ktére wraz z odpowiadajacymi
im poleceniami menu przedstawia ponizsza lista.

Ctrl+0 File - Open

Ctrl+R File - Refresh

F2 File - Restart - Save
F3 File - Restart - Load
Esc, F4 File - Quit

Del, NumpadAsterisk Edit - Undo

Ins, Shift+NumpadAsterisk Edit - Redo

Ctrl+Z Edit - Undo-redo toggle
F10 Edit - Redraw

Greater, Ctrl+NumpadPlus View - Zoom in

Less, Ctrl+NumpadMinus View - Zoom out

F12 View > Fit to BB
Ctrl+F12 View - Fit to width
Shift+F12 View - Fit to height
Left Arrow View > Move - Left
Right Arrow View > Move - Right
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Up Arrow
Down Arrow
Ctrl+Tab
Ctrl+F11
F11
Shift+F11
PgDn

PgUp

Home

End

F5

F6

F9

F7

F8
Shift+PgUp
Shift+PgDn
Shift+Home
Shift+End
F1

View >
View >
View >
View >
View >
¢

View

Move > Up

Move - Down

Rotate - 90 anticlockwise
Center

Reset zoom position

Reset transformations

Pages > Next

Pages - Previous

Pages > First

Pages - Last

Grids Frames - Bounding Box

Grids Frames - Page

Grids Frames - Printer

Grids Frames - Unit grid

Grids Frames - Fine grid

Options
Options
Options
Options
Help >

- Set multipage - Bundle -> Page up
-> Set multipage > Bundle - Page down
- Set multipage - Bundle - Home

- Set multipage - Bundle - End

Usage

31



i

www.bop.com.pl



