PSView dla Windows

przegladarka — PostScript i PDF
wykorzystuje Ghostscript

INSTRUKCJA OBStUGI
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1. Przedstawienie programu i sSrodowiska

Program PSView jest przegladarka dokumentéw postscriptowych i PDF-6w dziatajaca w systemie
Windows 9x, ME, NT, 2000, XP. PSView korzysta z interakcyjnego interpretera PostScriptu,
jakim jest Ghostscript, i wymaga obecno$ci Ghostscriptu w wersji 7.00 lub nowszej.

PostScript (TM) jest jezykiem opisu grafiki opracowanym przez firme Adobe, ktéry jest
niekwestionowanym standardem $wiatowym. Interpretery PostScriptu dostepne sg we wszystkich
systemach operacyjnych, umozliwiajac druk dokumentéw tekstowych i graficznych na praktycznie
wszystkich drukarkach i fotonaswietlarkach.

PDF (Portable Document Format), rowniez produkt firmy Adobe, w ostatnich latach zyskuje
sobie coraz wigksza popularno$¢, zwtaszcza w Internecie, wypierajac juz Postscript na najnowszych
fotonaswietlarkach.

Ghostscript, produkt firmy Aladdin, jest interpreterem PostScriptu i PDF-a. Umozliwia takze
otrzymywanie plikbw PDF z PostScriptu. Istotna cecha Ghostscriptu jest jego darmowa
dostepnos¢ na swiecie (np. na warunkach licencji Aladdin Free Public License lub GNU) oraz
obecno$¢ w gtéwnych systemach operacyjnych (Windows, Linux, Mac OS). Najnowsza wersje
Ghostscriptu mozna pobra¢ z Internetu, np. ze strony http://www.ghostscript.com.

Ghostscript ,,nieuzbrojony” pozwala jedynie na najprostszy podglad kolejnych stron dokumentu.
PSView tworzy graficzny interfejs do Ghostscriptu, ktéry umozliwia obejrzenie dowolnej

strony dokumentu (lub kilku na raz) w wybranym powiekszeniu, zmiane powiekszenia (zoom),
przesuniecia, obroty, lustrzane odbicie, mierzenie, drukowanie, a takze odswiezanie obrazu w tle
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i restart. PSView wykorzystuje mysz oraz liczne skréty klawiszowe, przyjmuje tez polecenia jezyka
PostScript.

Innym znanym programem tego typu dostepnym w systemie Windows jest GSview, ktérego
autorem jest Russell Lang, Ghostgum Software Pty Ltd.

Na rys. 1 przedstawiony jest schemat logiczny modutéw wspédtpracujacych ze sobg w programie
PSView.

PS_View.ps gsdll.dll
Podstawowy
modut roboczy Ghostscript
PSView
A A
v gswpsv.exe |
Okno R Okno
obrazu " konsoli
Rys. 1



Podstawowy modut PSView zostat napisany w PostScripcie, a wiec wszystkie funkcje programu
realizowane sg przez makra postscriptowe. Mozliwe jest wywotanie tych funkcji przez napisanie
odpowiedniej nazwy (by¢ moze poprzedzonej parametrami, zgodnie z notacja ONP jezyka
PostScript). Wszystkie operacje wykonywane za pomoca myszy, dostepne poprzez menu

oraz skréty klawiszowe ttumaczone s3 na wywotania odpowiednich makr. Lista makr PSView

dostepnych dla uzytkownika znajduje sie w dodatku A.
1.1. Zawartos¢ pakietu
Pakiet PSView zawiera nastepujace pliki:
— program komunikujacy sie z Ghostscriptem i zapewniajacy interfejs
uzytkownika
— plik wsadowy uruchamiajacy PSView
— rozszerzenie linii wywotania, uzycie parametréw Ghostsripta
— plik postscriptowy, ustawienia drukarek, parametry PSView
— plik postscriptowy, modut roboczy
— plik postscriptowy, informacja o programie

— plik PDF, instrukcja obstugi programu — ten dokument
(montaz w wersji do druku — plik )



1.2. Instalacja programu

Zaktadamy, ze w systemie Windows (9x, ME, NT, 2000, XP) jest poprawnie zainstalowany
program Ghostscript (wersja 7.00 lub nowsza).

Pliki wymienione w 1.1 (z wyjatkiem ) umieszczamy w osobnym katalogu np.

i nazwe tego katalogu dopisujemy do Sciezki bedacej trescia zmiennej Srodowiskowej

(taka zmienna jest ustawiona w typowej instalacji Ghostscripta). Plik wsadowy umieszczamy
w katalogu wymienionym w systemowej $ciezce dostepu (zwykle tam, gdzie znajduja sie
inne pliki wsadowe ).

2. Postugiwanie sie programem

2.1. Uruchomienie PSView

Jest kilka sposobéw uruchamiania PSView.

2.1.1. Sposéb ,,DOS-owy”

PSView uruchamiamy wykonujac plik wsadowy z parametrem, bedacym nazwa
dokumentu do ogladania. Jesli uruchomimy bez parametru, to w trybie dialogu
mozna otworzy¢ pozadany dokument. Jesli korzystamy z programu nawigacyjnego (np. Far,
DOS Navigator, Norton Commander), to mozna skojarzy¢ pliki z rozszerzeniem ps, , a takze
z plikiem wsadowym i uruchamia¢ PSView z okre$lonym dokumentem, najezdzajac
belka na dany plik postscriptowy lub PDF i naciskajac Enter lub klikajac podwdjnie mysza.
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2.1.2. Sposéb ,Windowsowy”

a) Na pulpicie tworzymy skrét do pliku wsadowego . Zmieniamy ikone na wtasciwa dla
programu gswpsv.exe i ustawiamy parametry programu, tak by uruchamiany byt w postaci
zminimalizowanej i zamykat okno po zakonczeniu. Przeniesienie na jego ikone ikony pliku PS
lub PDF-a spowoduje uruchomienie PSView z tym plikiem jako ogladanym dokumentem.

Podwdjne klikniecie na ikonie pliku gvp.bat uruchamia PSView z komunikatem ,File not opened”.
Wybierajac polecenie menu File - Open, w trybie dialogu mozna otworzy¢ pozadany dokument.

b) W oknie M6j komputer dokonujemy asocjacji plikéw z rozszerzeniem
itd.) z PSView, tak aby otwarcie tych plikéw w Windowsach odbywato sie standardowo
przez PSView. W tym celu otwieramy okno M6j komputer - Widok - Opcje folderdw
> Typy plikéw (por. rys. 2). Wyszukujemy interesujacy nas typ, np. ps file i wybieramy
Edytuj... Teraz mozemy zmieni¢ ikone na zgodna z programem gswpsv.exe i znébw wybraé
Edytuj. .., aby do pola Aplikacja do wykonania akcji przenie$¢ linie wywotania z pliku

Podwdjne klikniecie na ikonce pliku PS spowoduje uruchomienie PSView na tym dokumencie.



Rys. 2



2.2. Zamkniecie PSView

Zwykfe wyjscie z programu odbywa sie za pomoca polecenia menu File - Quit, mamy
wéwczas mozliwos$¢ zapisania pliku restartowego (por. 2.6).

Program mozna tez zamkna¢ w sposéb ,,ogélnowindowsowy”, klikajac lewym klawiszem myszy na
krzyzyk w prawym gérnym narozniku okna programu lub uzywajac skrétu klawiszowego A1t+F4.
Takie zamkniecie nie powoduje zapisania restartu.

2.3. Interfejs (obraz, menu, pasek stanu, konsola, skréty klawiszowe)

PSView po uruchomieniu wyswietla na ogét dwa okna: okno obrazu i okno konsoli (por. rys. 3).

2.3.1. Okno obrazu

W gérnej czesci okna znajduje sie menu rozwijalne, ktére umozliwia sterowanie programem
za pomoca myszy lub, po wcisnieciu klawisza Alt, przez naciskanie klawiszy podkreslonych
liter i cyfr. Istnieja tez skroty klawiszowe (zapisane po prawej stronie nazw pdl menu), ktérymi
wygodnie wywotuje sie czesciej uzywane funkcje programu bez koniecznosci rozwijania menu.
Petna lista skrétéw klawiszowych podana jest w dodatku B. Warto je zapamietaé i ich uzywaé.

Zasadnicza cze$¢ okna zajmuje kadr wybranej strony ogladanego dokumentu. W przypadku
zwyktych dokumentéw PS i PDF strona jest przedstawiona jako biaty prostokat o wymiarach
prostokata ograniczajacego (bounding box) umieszczony na szarym tle. W przypadku, gdy
prostokat ograniczajacy nie jest okreslony, szarego tta nie stosuje sie. Szare tto mozna usunaé
(przywréci¢) wybierajac polecenie menu Options = Background off (on).
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File Edit

Wiew Pages Grds&Framee  Options  Help

Zoomin Greater, Ctil+NumpadPlus
Zoom out Less, Chl+Mumpadiinus
Fit to BB F12

Fit by wicithy Chl+F12

Fit by bieight Shift+F12

Move

90 clockwize
Flip 3
LCenter Chl+F11 180 [upsidedown]

AFPL Ghostscript 5.00 (2002-11-21)
Copyright (C) 2002 artofcode LLC,

This software comes with NO WARRANTY:
G5> (START) 492 412 /STARTSIZE EVENTCOMMA
G3> (MENU) 492 393 /RESIZE EVENTCOMMAND

G3> (STATUS) 492 373 /RESIZE EVENTCOMMAND

G3x

“f> (REIIZE) 492 414 fREIIZE EVENTCOMMAND

> /UP_LER /NORM EETCOMMAND
=

Reset zoom & position F11
Reset ransformations  Shift+F11

Ala ma kotke.

o]

Page: 1/2 | Ange 0 | FlipMore | Zoom 124504

=1ofx]

-
Eenicia,

see

Rys. 3.
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W dolnej czesci okna znajduje sie listwa stanu informujaca o stanie dokumentu, zawiera ona (od
lewej):

* znaczek OK pojawiajacy sie, gdy poprawnie zakonczona zostata kolejna akgja,

« numer kolejny ogladanej strony lub zakres stron (w przypadku pracy wielostronicowej) oraz
liczba wszystkich stron dokumentu,

« kat obrotu (wielokrotnos¢ 90 stopni),

« informacje o odbiciu lustrzanym (pionowym lub poziomym),

* biezacy wspdtczynnik przeskalowania (zoom),

* miejsce na komunikaty (np. wyniki pomiaréw) i sygnaty btedu.

2.3.2. Okno konsoli

Jest to okno tekstowe stowarzyszone z programem PSView. Zawiera ono zapis dialogu
prowadzonego z Ghostscriptem. Okno konsoli spetnia wazna role podczas debuggingu, gdyz

w przypadku wystapienia btedu w ogladanym dokumencie, w oknie konsoli pojawia sie¢ petniejszy
opis btednej sytuacji. Uzytkownik moze wytaczyé (wiaczyé) okno konsoli, klikajac dowolnym
klawiszem myszy na ikonce programu w lewym gérnym rogu okna obrazu i wybierajac opcje Hide
console (Show console). Po ustawieniu sie na oknie konsoli, dowolny tekst napisany przez
uzytkownika jest interpretowany jako ciag komend postscriptowych. Mozna tez pisaé komendy
postscriptowe bedac w oknie obrazu, s3 one przekazywane do konsoli, nawet gdy okno konsoli
jest ukryte.
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2.4. Otwieranie dokumentéw

Wybranie polecenia menu File - Open powoduje otwarcie standarowego okna dialogowego
systemu Windows, umozliwiajacego otwarcie nowego dokumentu PS (EPS) lub PDF. PSView
w jednym oknie (instancji) moze pracowad najwyzej z jednym dokumentem, tak wiec otwarcie
nowego pliku powoduje zakonczenie pracy z poprzednim dokumentem, jesli byt otwarty. Praca
z wieloma dokumentami réwnoczesnie jest mozliwa, gdy zostang one otwarte w réznych
instancjach PSView.

2.5. Odswiezanie

Mozliwa jest modyfikacja lub ponowne utworzenie dokumentu, ktérego obraz pokazuje PSView,
woéwczas wykonanie w PSView operacji od$wiezajacej obraz (np. File - Refresh lub Edit
- Redraw), badz ponowne uruchomienie PSView (w tej samej instancji) powoduje interpretacje
zmodyfikowanego dokumentu i ustawienie sie — jesli to mozliwe — w tej samej pozycji ekranu.

2.6. Restart

Wychodzac z programu PSView za pomoca polecenia menu File - Quit, otrzymujemy
propozycje zapisania pliku umozliwiajacego restart, czyli zachowanie pozycji ekranu w dokumencie
(tzn. numeru strony, pozycji na stronie i innych waznych parametréw), umozliwiajace odtworzenie
tej pozycji przy ponownym wejéciu do programu. Plik restartowy zwykle zapisywany jest

w biezacym katalogu lub w miejscu wskazanym przez podanie odpowiedniej nazwy pliku
restartowego w pliku . Informacje restartowe mozna tez zapisa¢ lub wezytaé (bez
opuszczania programu) za pomoca poleceih menu File = Restart = Save (Save as)
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(File - Restart - Load (Load from)). Mechanizm restartu utatwia ustawienie ekranu
w takiej samej pozycji dla kilku réwnoczesnie otwartych (w réznych instancjach programu)
dokumentéw, np. wyciggéw barwnych. Wystarczy w kazdej otwartej instancji wczytaé ten sam
plik restartowy.

2.7. DSC

Nawigowanie w wielostronicowym dokumencie postscriptowym oparte jest na analizie komentarzy
strukturalnych zgodnych z DSC (document structuring conventions), ktérych obecnosé¢

i poprawno$¢ jest niezbednym warunkiem umozliwiajacym wiasciwe przetwarzanie i podziat
dokumentu na sktadniki strukturalne. Oczekujemy, ze w dokumencie postscriptowym daja

sie wyodrebni¢ (by¢ moze pojawiajace sie wielokrotnie lub pominiete) nastepujace sktadniki
strukturalne: Prolog Setup Page. ..

Prolog to zestaw makr, fontéw itd., uzywanych w dalszej czesci dokumentu. Wszystkie czesci
dokumentu zakwalifikowane jako prolog sa interpretowane przez PSView tylko raz, po wczytaniu
nowego lub zmienionego dokumentu.

Setup to zestaw makr, fontéw itd. uzywanych w dalszej czeSci dokumentu. Czesci dokumentu
zakwalifikowane jako setup, poprzedzajace w dokumencie przetwarzang strone s3 interpretowane
przez PSView przed kazdym wyswietleniem strony.

Page (strona) to cze$¢ dokumentu zawierajaca elementy wystepujace tylko na jednej stronie.
Zaktadamy, ze zadne elementy na stronie nie wptywaja na zawarto$¢ (interpretacje) innych stron.
Jedli ten warunek nie jest spetniony (a czasem rzeczywiscie nie jest!), to wyswietlony obraz
zalezy od kolejnosci w jakiej przegladamy strony, moze to tez prowadzi¢ do wystapienia btedu.
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Wewnatrz stron spodziewamy sie tez wystapienia inkluzji (np. EPS-6w), ktérych komentarze
strukturalne pomijamy.

Ponizej przedstawiamy zestawienie rozpoznawanych przez PSView komentarzy strukturalnych
oraz nadawanych im znaczen.

h%BeginDocument Poczatek inkluzji (ignorowanie DSC, czekanie na koniec inkluzji)
%%EndDocument Koniec inkluzji (wznowienie interpretacji DSC)
%/BoundingBox: Wyznaczenie prostokata ograniczajacego dokumentu
%/%HiResBoundingBox:

%/hkDocumentMedia:

%%BeginProlog Poczatek prologu (koniec setupu, koniec strony)

%/%BeginSetup

/DVIPSEndSection

%DVIPSBeginSection | Poczatek setupu (koniec prologu, koniec strony)

%DVIPSSectionPage: Poczatek strony (koniec prologu, koniec setupu, koniec strony)
%hPage:
%/ Page:

%HEQF Koniec dokumentu




2.8. Zmiana strony

Polecenia menu z grup Pages oraz Options - Set multipage - Bundle stuza do zmiany
ogladanej strony dokumentu (lub grupy stron, w przypadku pracy wielostronicowej). Operacje
zwigzane z praca wielostronicowa opisane sa w 2.14.

Polecenie menu Pages > Next powoduje przejscie na kolejna strone w ogladanym dokumencie.
Poprzedzenie polecenia liczbg catkowita powoduje przejicie o te liczbe stron w przéd (lub w tyt,
gdy jest to liczba ujemna).

Polecenie menu Pages - Previous powoduje przejscie na poprzednia strone w ogladanym
dokumencie. Poprzedzenie polecenia liczba catkowita powoduje przejécie o te liczbe stron w tyt
(lub w przéd, gdy jest to liczba ujemna).

Polecenie menu Pages - Specified powoduje przejScie na strone o podanym numerze. Numer
strony podaje sie w oknie dialogowym. Uzycie makra pn (lub réwnowaznie np) poprzedzonego
liczbg catkowita umozliwia bezposrednie (tzn. bez dialogu) przejscie na wybrana strone (por.
dodatek A).

Polecenie menu Pages - First powoduje przejscie na pierwszg strone dokumentu.

Polecenie menu Pages - Last powoduje przejscie na ostatnig strone dokumentu.

2.9. Widok strony

Grupa polecen w menu View obejmuje operacje umozliwiajace zmiany widoku w obrebie danej
strony dokumentu (zoom, przesuwanie, obroty, lustrzane odbicie).
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2.9.1. Zoom

Wygodnym sposobem powiekszenia wybranego fragmentu obrazu jest wyznaczenie tego
fragmentu przez przesuwanie mysza z wcisnietym lewym klawiszem.

Zmniejszenie obrazu osiaggamy uzywajac myszy do wyznaczenia jaki fragment nowego ekranu ma
stanowi¢ wtasnie widziany obraz. Osigga sie to poprzez przesuwanie mysza z wcisnietym lewym
klawiszem przy nacis$nietym klawiszu Ctrl.

Powiekszenie (zmniejszenie) obrazu jest osiggalne réwniez z menu: View = Zoom in (View
- Zoom out) Powiekszenie (zmniejszenie) zachowuje pofozenie srodka ekranu. Warto$¢
domysina wspétczynnika powiekszenia (zmniejszenia) wynosi zoom_factor = 1,414. Mozna ja
zmieni¢ wykonujac w menu Options - Set zoom factor.

Przydatne do ustalania kadru okazuja si¢ takze polecenia View > Fit to BB, View > Fit
to width, View > Fit to height, ktére tak zmniejszaja lub powiekszaja obraz, aby caty
prostokat ograniczajacy strony ogladanego dokumentu, tzw. bounding box (odpowiednio: tylko
jego szerokos¢ lub wysoko$¢) miescit sie w oknie programu.

W przypadku pracy wielostronicowej (Options = Set multipage) polecenia View - Fit to
BB, View - Fit to width, View - Fit to height dotycza catej paczki wyswietlanych stron
(jej tacznej szerokosci lub wysokosci).
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2.9.2. Przesuniecia

Kadr widoczny na ekranie mozna zmieni¢, bez zmiany powigkszenia, dokonujac przesuniecia
ekranu w lewo (prawo, gére dét), zaleznie od operacji menu:

View > Move - Left

View - Move - Right

View > Move - Up

View - Move - Down.

Operacje przesunigcia mozna poprzedzi¢ liczba catkowity, wyrazajaca wielko$¢ kroku przesuniecia.
Domyslnie jest to 1/10 szerokosci (wysokosci) okna.

Krok mozna tez podaé poleceniem menu Options - Set shift length.

Do przesuwania wygodnie uzywa sie klawiszy strzatek (por. dodatek B). Mnemotechnika: strzatka
w goére lub w lewo przenosi nas ,wyzej” w tekscie. Uzycie strzatki przesuniecia z réwnoczesnie
wcisnietym klawiszem Shift przesuwa ekran o krok 5 razy wiekszy od domyslnego (podanego).

Przesuwanie ekranu mozna tez realizowaé, uzywajac kétka myszy: normalnie — géra, dét,
z nacisnietym klawiszem Ctrl — lewo, prawo.

Do przesuwania mozna wreszcie uzy¢ myszy, wlokac z wcisnietym lewym klawiszem myszy,
przy wcisnietym na klawiaturze klawiszu spacji. Odpowiada to ,tapaniu i ciagnieciu” obrazka,
w odréznieniu od przesuwania ekranu za pomoca klawiszy (lub kétka myszy).
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Do umieszczenia na $rodku ekranu strony postscriptowej (wyznaczonej przez prostokat
ograniczajacy) lub paczki stron, w przypadku trybu wielostronicowego, stuzy polecenie View
-~ Center. Powiekszenie nie ulega zmianie.

2.9.3. Obroty

Polecenia menu:

View - Rotate > 90 clockwise

View - Rotate - 90 anticlockwise

View > Rotate - 180 (upsidedown)

powoduja obrécenie obrazu widocznego na ekranie odpowiednio: o 90 stopni zgodnie z ruchem
wskazéwek zegara, o 90 stopni przeciwnie do ruchu wskazéwek zegara, o 180 stopni.

2.9.4. Odbicie lustrzane

Polecenia menu:

View - Flip - Horizontal

View - Flip - Vertical

powoduja odbicie obrazu widocznego na ekranie wzgledem odpowiednio: pionowej lub poziome;j
osi symetrii okna ekranu.
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2.9.5. Przywracanie ustawienn domysinych

Polecenie menu View - Reset zoom & position powoduje wyswietlenie na srodku ekranu
obrazu ogladanej strony (stron) z powiekszeniem 1. Nie ulega zmianie biezacy kat ani odbicie
lustrzane.

Polecenie menu View - Reset transformations powoduje wyswietlenie na Srodku ekranu
obrazu ogladanej strony (stron) z powiekszeniem 1, katem 0 i bez odbicia lustrzanego.

2.10. Ramki i mierzenie

Za pomocg PSView mozna otrzymaé informacje o rozmiarach strony dokumentu oraz mierzy¢
obiekty widoczne na ekranie.

Do mierzenia rozmiaréw elementéw dokumentu stuza dwa krzyze pomiarowe, kolejno nanoszone
na ekran za pomoca myszy, przy wcisnietym prawym klawiszu myszy. Gdy widoczny jest jeden
krzyz, na pasku stanu wyswietlana jest pozycja jego $rodka. Krzyz pomiarowy mozna przesuwad,
dopdki wcisniety jest prawy klawisz myszy. Dodatkowo, gdy wcisniety jest klawisz Shift, mozna
na pasku stanu zobaczy¢ zmieniajace sie pozycje krzyza podczas ruchu. Przy widocznych dwdch
krzyzach, wyswietlane sa odlegtosci dx, dy, dz miedzy ich Srodkami oraz katy alpha i beta
nachylenia przekatnych prostokata wyznaczonego przez krzyze (por. rys. 4). Wyniki pomiaréw
mozna przywroci¢ poleceniem Grids & frames - Measure.

Krzyze pomiarowe gasi préba dostawienia trzeciego krzyza lub nacisniecie prawego klawisza myszy
przy wcisnigtym klawiszu Ctrl.
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| Page 141 éngle.0 | FimNone | Zoom 63001 ds=0.525 dy=0.255 d=0.584 cm alpha=26.041 beta=63953
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Polecenie Grids & frames - Bounding Box wysSwietla prostokat ograniczajacy strony
postscriptowej (bounding box) oraz podaje jego rozmiary na pasku stanu. Strony dokumentu,
gdy znany jest bounding box, wyswietlane s3 w biatych prostokatach o rozmiarach prostokata
ograniczajacego umieszczonych na szarym tle.

Polecenie Grids & frames - Page wySwietla ramke strony postscriptowej dokumentu oraz
podaje jej rozmiary na pasku stanu. Format strony ustalany bywa jedng z komend PostScriptu:
setpage, setpageparams, setpagedevice lub bezparametrowa komenda typu a4, a3, letter itd.

Polecenie Grids & frames - Printer wyswietla ramke drukarki, tzn. ten fragment ekranu,
ktéry przy biezacych ustawieniach mozna wydrukowac poleceniem File - Print. ramka
drukarki jest podwdjna (odlegtos¢ podramek wynosi 6mm) dla wyrdznienia tych czesci dokumentu,
ktére wprawdzie mieszczg sie na stronie, ale wystaja poza pole zadruku wigkszosci drukarek.

Polecenie Grids & frames - Unit grid wyswietla siatke jednostki miary wybranej przez
uzytkownika (por. Options - Set unit). Nazwa jednostki pojawia sie na pasku stanu.

Polecenie Grids & frames > Fine grid wyswietla dwie siatki: jednostki miary wybranej
przez uzytkownika oraz jednostki towarzyszacej (wielokrotnosci lub podwielokrotnosci). Nazwy
wyswietlanych jednostek pojawiaja sie na pasku stanu.

Polecenie Grids & frames - Window grid wyswietla siatke dzielaca wymiary okna programu
na 10 réwnych czesci. W takich jednostkach podaje sie krok przesuniecia ekranu (z wyjatkiem
przesuniecia realizowanego za pomoca myszy).
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2.11. Drukowanie

Za pomoca PSView, wywotujac polecenie File & frames - Print, mozna wydrukowaé
fragment ogladanej strony dokumentu, ktéry wyznaczony jest ramka drukarkowa (por. polecenie
Grids & frames - Printer). Rozmiar papieru i orientacje drukowania wybiera sie za pomoca
poleceni zebranych w podmenu Options = Set media. Urzadzenie drukujace wybiera sie (na
razie) edytujac plik pomocniczy , w ktérym zebrane s3 opisy niektérych urzadzen
wyjéciowych dostepnych w Ghostscripcie.

Uzytkownik moze dotaczyé wtasne opisy urzadzen. Opis ma postaé stownika zawierajacego
nastepujace definicje, pozycje nieistotne lub takie, ktére sa zgodne z domysInymi wartosciami,
przedstawionymi na ponizszej liscie, mozna poming¢.

/printer_name (laserjet) def J nazwa urzadzenia Ghostscriptu
/printer_output (!ps_out.jep) def J, drukowanie do pliku !ps_out.jep
/printer_x_corr O def % korekta przesuniecia w poziomie

/printer_y_corr O def % korekta przesuniecia w poziomie

/printer_x_marg O def % margines poziomy drukarki

/printer_y_marg O def % margines poziomy drukarki

/printer_spot /gs_spot load def 7 funkcja plamki (rastra)

/printer_freq 46 def J, liniatura

/printer_angle 45 def 7 kat rastra

/printer_xy_res [300 300] def % rozdzielczo$¢ pozioma i pionowa urzadzenia

Wyboru urzadzenia dokonuje si¢ poleceniem prs z parametrem — nazwa stownika. W praktyce
oznacza to ,,odprocentowanie” wtasciwej linii na koncu pliku
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Jednym ze zdefiniowanych urzadzen jest winprn, czyli druk na drukarce zainstalowanej w systemie
Windows. Przy wybraniu tej mozliwosci, ostatecznego wyboru drukarki dokonuje sie podczas
dialogu w standardowym oknie dialogowym zwigzanym z drukiem.

2.12. Jednostki

Operacje z grupy Options - Set unit pozwalaja przyjac biezace jednostki dtugosci, w ktérych
podawane s3 rozmiary prostokata ograniczajacego, strony postscriptowej, potozenia i odlegtosci
krzyzy pomiarowych, wyswietlane siatki. Ponizej znajduje si¢ tablica dostepnych jednostek
gtéwnych wraz z jednostkami towarzyszacymi (wielokrotnosciami lub podwielokrotnosciami
jednostki gtéwnej, wykorzystywanymi do wyswietlania siatki poleceniem Grids & frames

- Fine grid)

Jednostka gtéwna Jednostka pomocnicza
cm centymetr mm

mm milimetr cm

in (cal, 1in = 25,4 mm) 1/12in

pt (punkt, 1 in = 72,27 pt) pc (pica, 1 pc = 12 pt)
dd (didot, 1 dd = 1.07 pt) cc (cycero, 1 cc = 12 dd)
bp (punkt postscriptowy, 1 in = 72 bp) 12 bp
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2.13. Formaty ,,papieru”

Operacje z grupy Options - Set media pozwalaja przyjaé format strony, ktéra domysinie
(tzn., gdy Zoom = 1) miesci sie w oknie. Jest to zarazem rozmiar ramki drukarkowe;.
Poszczegdlne formaty odpowiadaja kilku standardowym formatom papieru, z wyjatkiem polecenia
-~ BoundingBox, przy ktérym rozmiarem strony staje sie prostokat ograniczajacy dokumentu.

2.14. Praca wielostronicowa

PSView umozliwia prace w trybie wielostronicowym, tzn. réwnoczesne wyswietlanie kilku
kolejnych stron dokumentu. Odlegto$¢ miedzy stronami, mierzong wzgledem prostokatéw
ograniczajacych, okresla sie w oknie dialogowym, uaktywnionym za pomoca polecenia menu
Options > Set multipage - Distance.

Polecenie menu Options - Set multipage - 2x1 powoduje wyswietlenie obok siebie dwdch
kolejnych stron dokumentu (np. rozktadéwki). Kolejne polecenia > 2x1 reverse, > 1x2,

> 1x2 reverse réwniez stuza do wyswietlania dwéch stron naraz, ale w odwrotnej kolejnosci
lub utozonych jedna nad druga.

Polecenie - mxn umozliwia ustawienie na ekranie pewnej liczby stron w tablicy m x n, ktérej
rozmiary podaje sie w oknie dialogowym. Dodatkowo polecenie > Permutation umozliwia
wybranie jednej z odmiu wybranych permutacji wskazanej w oknie dialogowym przez podanie
uktadu tablicy 2 x 2. Przy wiekszych tablicach zaktadamy, ze wiersze (kolumny) zawieraja
kolejne strony, wyswietlane w kolejnosci wskazanej przez uktad w tablicy 2 x 2. Oczywiscie,
nie wyczerpuje to wszystkich mozliwosci. Inne permutacje tez s3 dostepne, choé¢ w mniej
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wygodny sposéb. Np. napisanie (w oknie konsoli) 3 2 [1 2 3 4 5 6] multipage spowoduje
wyswietlenie tablicy 3 x 2 stron w zwyktej kolejnosci. Dalsze préby pozostawiamy dociekliwym.

Polecenie > Vertical tape wyswietla dokument jako ,tasme filmowg”, ze stronami
ustawionymi jedna nad druga. Przesuwajac sie w dét lub do géry przechodzimy na sasiednie
strony.

Uzycie polecen menu z grupy Pages w odniesieniu do trybu wielostronicowego powoduje przejscie
do ogladania nowej paczki stron, z zatozeniem, ze numery stron zmieniaja sie o wielokrotnos¢
paczki, natomiast nie zmienia sie pozycja stron na ekranie. W kazdym przypadku numery stron
objetych paczka wyswietlone sg na pasku stanu.

Istnieje specjalna grupa polecen menu Options - Set multipage > Bundle obejmujaca
operacje przesuwajace zawartos¢ paczki stron. Dla przyktadu, polecenie > Page down usuwa

z paczki strone o najmniejszym numerze, a doktada do paczki strong kolejng. Jesli podano liczbe,
bedaca parametrem polecenia, to jego dziatanie ulega zwielokrotnieniu. Kolejne polecenia z tej
grupy dziataja analogicznie.

Witaczenie opcji Options - Set multipage - Cycle on spowoduje ,dotaczanie” koncowych
stron dokumentu przed jego pierwsza strong oraz ,dotaczanie” poczatkowych stron dokumentu
po jego ostatniej stronie, a wiec poczatkowe i koncowe paczki stron s3 zawsze wypetnione,
jesli tylko dokument posiada wystarczajaca liczbe stron. Umozliwia to np. obejrzenie ostatniej

i pierwszej strony dokumentu (oktadki) jako jednej rozktadéwki.
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Dodatek A. Makra PSView

Ponizej przedstawiamy liste tych makr PSView, ktére moga stuzy¢ jako skréty operacji menu.
Charakteryzuja sie one tatwymi do zapamietania, krétkimi nazwami. W celu uzycia, wystarczy
napisa¢ nazwe makra, a po niej nacisna¢ Enter (nawet bez przefaczania sie na okno konsoli).
Niektére z makr wykorzystuja opcjonalny parametr poprzedzajacy nazwe makra, oznaczony na
liscie jako:

{(FILE_NAME_R) }, {(FILE_NAME_P) } — nazwa pliku w nawiasach okragtych,

{PAGE}, {INCR}, {STEP} — liczba catkowita,

{MAG}, {SHIFT_IN}, {SHIFT} — utamek dziesietny.

Gdy parametr jest pominiety, to przyjmowane s3 wartosci domysine:
{(FILE_NAME_R)} = (!ps_rest.ps)

{(FILE_NAME_P)} nazwa pliku podana w specyfikacji biezacej drukarki w pliku
{INCR} =1

{STEP} =1

{SHIFT} =1

{PAGE}, {MAG}, {SHIFT_IN} — wartosci domyslnych nie przyjmuje si¢

Po prawej stronie przedstawiamy polecenia menu odpowiadajace tym makrom.
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{(FILE_NAME_R) } rr File > Restart > Load
{(FILE_NAME_R) } wr File > Restart > Save
{PAGE}  pn (np) z parametrem: wynik dialogu Pages - Specified
bez parametru: wyswietlenie numeru biezacej strony
{INCR} n Pages > Next
{INCR} P Pages > Previous
pf (fp) Pages > First
pl (1p) Pages - Last

{INCR} sn Options > Set multipage - Bundle > Page up
{INCR} sp Options > Set multipage - Bundle > Page down

spf Options - Set multipage - Bundle -> Home

spl Options - Set multipage - Bundle -> End

W Pages > Reset zoom & position

i Pages - Reset transformations

wbb View > Fit to BB

wwd View - Fit to width

wht View > Fit to height

cbb View - Center

g Grids & Frames - Window grid

gg Grids & Frames - Unit grid

geg Grids & Frames - Fine grid

fr Grids & Frames - Printer
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{MAG}

{SHIFT_IN}

{STEP}

{SHIFT}
{SHIFT}
{SHIFT}
{SHIFT}

{(FILE_NAME_P) }

{INCR}
{INCR}

pg
bb

Grids & Frames - Page

Grids & Frames - Bounding Box

z parametrem: wynik dialogu Options - Set zoom factor
bez parametru: wyswietlenie wartosci wspétczynnika powiekszenia
z parametrem: wynik dialogu Options - Set shift length
bez parametru: wyswietlenie wartosci kroku przesuniecia

View
View
View
View
View
View
View
View
View
Edit
File

9

N 220 28 28 2N 2R 2NN 2

Zoom in

Zoom out

Rotate - 90 anticlockwise
Flip - Horizontal

Flip - Vertical
Move > Left
Move - Right
Move > Up

Move - Down
Redraw

Print

wynik dialogu File - Quit (z zapisaniem restartu)
Edit - Undo
Edit - Redo
leave wynik dialogu File > Quit (bez zapisania restartu)
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Dodatek B. Skréty klawiszowe

Wygodne operowanie programem zapewniajg skréty klawiszowe, ktére wraz z odpowiadajacymi
im poleceniami menu przedstawia ponizsza lista.

Ctrl+0 File - Open

Ctrl+R File - Refresh

F2 File - Restart -> Save
F3 File > Restart - Load
Esc, F4 File > Quit

Del, NumpadAsterisk Edit - Undo

Ins, Shift+NumpadAsterisk Edit = Redo

Ctrl+Z Edit - Undo-redo toggle
F10 Edit - Redraw

Greater, Ctrl+NumpadPlus View = Zoom in

Less, Ctrl+NumpadMinus View - Zoom out

F12 View > Fit to BB
Ctrl+F12 View > Fit to width
Shift+F12 View - Fit to height
Left Arrow View > Move > Left
Right Arrow View - Move - Right
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Up Arrow
Down Arrow
Ctrl+Tab
Ctrl+F11
F11
Shift+F11
PgDhn

PgUp

Home

End

F5

F6

F9

F7

F8
Shift+PgUp
Shift+PgDn
Shift+Home
Shift+End
F1

View
View
View
View
View
View
Pages
Pages
Pages
Pages
Grids
Grids
Grids
Grids
Grids

9
9
9
9
9
9

Move -> Up

Move - Down

Rotate > 90 anticlockwise
Center

Reset zoom position

Reset transformations

> Next

-> Previous

-> First

-> Last

Frames - Bounding Box

Frames - Page

Frames - Printer
Frames - Unit grid
Frames - Fine grid

Options - Set multipage - Bundle
Options - Set multipage - Bundle
Options - Set multipage - Bundle
Options - Set multipage - Bundle
Help - Usage

-> Page up
- Page down
- Home

- End
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