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1
Introduction

Donald E. Knuth decided to create a new typesetting system, which would
be called TEX, because there had been a change in the printing system used
for the volumes of his book The Art of Computer Programming and Knuth
found the result of the new system awful.

The goal of TEX was then to have a system which would always produce
the same documents independently of the actual machine they were processed
on. Knuth also designed the Computer Modern family of typefaces and the
METAFONT language for font description.

The work initiated in 1977 was finished (the languages were “frozen”)
in 1989. TEX and METAFONT are not evolving any more except for minor
bug fixes (TEX versions are numbered following the decimals of π—now
3.1415926—and METAFONT the decimals of the number “e”—now 2.718281).

TEX provides basic tools (commands/instructions/“primitives”) to define
typesetting; almost every detail has to be defined, but the language allows the
creation of macros for repeatedly used constructs. So collections of macros
are loaded through format files (i.e., pre-compiled large macro collections).

Knuth created an original default format (600 commands, more or less)
which is called Plain TEX. This facilitates creating documents.

The most widely used format is LATEX (Leslie Lamport, 1985), which pro-
vides more global commands and structures for documents (article, book,. . . )
allowing easier and faster work, but sometimes with loss of flexibility due
to the more or less rigid framework. But there are many other formats and
TEX-variants in use as well, such as AMS-TEX, AMS-LATEX, ConTEXt, or
X ETEX, each having specific goals and advantages (and drawbacks).

To extend the format, one loads “packages” which are collections of macros
specific to some aspect of typesetting.

From its specification in the late 1970s, the TEX family had to evolve until

1



1. Introduction 2

now, last version March 2008, to take into account the developments in the
typesetting world outside TEX.

Some of the problems to answer were/are:

• taking into account other languages with “alphabets” larger than the
ASCII1 one or with non-Latin characters altogether,

• having more fonts, there is not much variety in the fonts created with
METAFONT (few font creators use it),

• creating documents in other formats than the normal DVI2,

• using the rich possibilities of other typesetting systems and formats like
PostScript and PDF,

• having more calculation and scripting facilities,. . .

To answer these questions and others, many “engines” and programmes
have been created around TEX, including pdftex, pdflatex, dvips, ps2pdf, and
METAPOST, which opens the TEX world to the possibilities of PostScript
and PDF. X ETEX and X ELATEXto be able to use the “normal” fonts found on
the different machines and to be able to cope with writing systems different
from the left to right systems which originated in Europe (Latin and Cyrillic
letters and associates)—right to left, vertically, pictograms,. . . Or LuaTeX
and LuaLaTeX to have a powerful scripting language.

To use TEX and the systems of its family, one has to create a “source”
document as TEX is only a system to “transform” a source document into a
(beautifully) typeset document. This source is a simple text with typesetting
instructions and one needs a programme to create it: the editor.

There are many editors able to create a TEX source; some are general
editors, others are specifically designed for TEX: here TEXworks comes in.

TEXworks is a project to create a text editor for use with the TEX
family of tools; we will refer to these as (LA)TEX. Instead of creating a new
sophisticated program, equipped with multiple tool-bars to meet any need,
TEXworks provides a simple editor, offering at first sight only a limited set
of tools for text editing as well as a single button and a menu to typeset a
(LA)TEX text.

1“American Standard Code for Information Interchange”: a character encoding scheme
including only Latin characters found in English, some common punctuation characters,
and a few other symbols such as % or $
2“Device Independent”: format of files produced by TEX
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The idea to create the editor came to Jonathan Kew, the initiator and
leader of the project, after a long period of reflection on the reasons why
potential users tend to keep away from (LA)TEX, as well as pondering the
success of the TEXShop editor on the Mac.

Finally the goal was also to provide the same editor on many operating
systems: TEXworks currently runs on Linux, Mac OS X and Windows. The
interface is always the same and the program offers the same functionality on
all three platforms.

After this introduction, the second section of this manual explains how to
install the software. In the third section, we describe the interface and create
a first document as well as show the basics of TEXworks. In the forth and
fifth section, the advanced tools provided by TEXworks are presented; you
should read these sections only after mastering the basic working of TEXworks.
These advanced tools allow much more effective working practices. The sixth
section gives a brief introduction to scripting. This section focuses on using
ready-made scripts, not on writing your own scripts (which is beyond the
scope of this manual and will be presented elsewhere). After that, the seventh
section in which some pointers to further information about TEXworks and
sources for help are compiled concludes the main part.

Finally, the appendices provide additional information how TEXworks can
be customized, about the regular expression search/replace system, and how
TEXworks can be compiled from source. A short bibliography and an index
conclude this manual.

1.1 Icons and style
Because a picture is often worth a thousand words, icons and special styling
is used throughout this manual to avoid cumbersome paraphrases or mark
specialties. Keyboard keys are usually depicted as A , with the exception
of a few special keys. These are: Shift ⇑ , Page ↑ , Page ↓ , ←↩ (return),
↑ , ↓ , ← , → , (space), 7−→ (backspace), and � (tab).

In addition, mouse clicks are depicted as (left click) and (right click;
on Mac OS X with a one-button mouse, this is usually available by holding
down Ctrl while clicking).

Apart from input instructions, several passages throughout this manual
are marked by special styling.
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Information that is only valid or relevant for a particular operating system
is marked like this:

This only concerns you if you use Windows.
Of course you can also read it if you use another operating system.
It just will not be of much use to you.

Code examples are set in a fixed-space, typewriter font, with lines above
and below to set it apart from the rest of the text:

Hello \TeX-World!

Closely related to this, chapter 3 contains several tutorials, which are
typeset just like the code examples above, but with an additional notebook
icon next to it.



2
Installation

TEXworks is only a text editor; to be able to create documents with (LA)TEX
and to typeset them to PDF, we also need what is called a TEX distribution.
This is a collection of programs and other files which will be automatically
called by TEXworks during its work. Thus, you need to install a distribution:
we will do that before starting TEXworks for the first time, as this way,
TEXworks will automatically find what it needs.

TeX Live (http://www.tug.org/texlive/), a combination of teTeX,
MacTeX and XEmTeX, is available for all three operating systems (Linux,
Mac OS X, Windows). Note that you need a reasonably recent version of
TeX Live (2012 or later at the time of writing) to use all features of TEXworks.

For Linux: most Linux distributions include a TEX distribution, but it
may not be installed by default and you will have to use the Linux package
management tools to do that. Alternatively, you can also download and
install TeX Live directly from http://www.tug.org/texlive/.

For the Mac: MacTeX, a new distribution based on gwTeX and XeTeX,
is available; see http://www.tug.org/mactex/.

For Windows: a very popular distribution is MiKTeX (http://www.
miktex.org/). MikTeX has an update programme, which has also been
ported to Linux. You can also use the XEmTeX distribution (http://www.
xemtex.org/).

For details on portable usage, and changing local configuration locations,
please see the section Portable Usage & Changing the Configuration – section
5.7 (on page 29).
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2.1 Under Windows
Most of the larger TEX distributions already contain TEXworks as a package.
Sometimes, these versions even have some distribution-specific enhancements.
So, the preferred way of installing TEXworks on Windows is to use the
package manager of your distribution. In this case, you can skip the next few
paragraphs. Be sure to read the end of this section, though, as it provides
important information about customizing TEXworks to your needs.

If you want to obtain an “official” version, obtain TEXworks by downloading
the setup from the TEXworks web site http://tug.org/texworks/ after the
installation of the TEX distribution.

Simply install TEXworks by running the setup file. During the installation,
you will be asked where to install the program, if you want to create shortcuts,
and if you want to always open .tex files with TEXworks. There are reasonable
default values that should work well for most users.

If you want full control over how and where TEXworks is put, you can
also download the .zip archive from the website and unpack it wherever you
like. Note that in this case, shortcuts and file associations must be created
manually.

When you start TEXworks for the first time, it creates a folder named
TeXworks in your home folder1. This folder will contain some sub-folders
for auto-completion, configuration, dictionaries, templates, and interface
translation/localisation files—we will see these in more detail later.2

NB. At the time of writing, if <your name> contains any non-ASCII
characters (for example accented characters), some functions of TEXworks
may not work correctly. For example, the spell-checker and forward/reverse
synchronization between the source and .pdf will be impaired.

2.2 Under Linux
Several common Linux distributions already have packages for TEXworks.
They are adequate for most users and facilitate installing TEXworks consider-
ably.

If your Linux distribution does not provide recent, adequate packages, you
need to build TEXworks from source yourself, which is fairly easy on Linux.
After the installation of the TEX distribution, go to https://github.com/

1on Windows XP, your home folder is C:\Documents and Settings\<your name>. On
Windows Vista/7, your home folder is C:\Users\<your name>.

2TEXworks will save its preferences in the registry: \HKEY_USERS\S-...\Software\TUG\
TeXworks. If this is erased, it will be recreated with default values at the next use.

http://tug.org/texworks/
https://github.com/TeXworks/texworks/wiki/Building
https://github.com/TeXworks/texworks/wiki/Building
https://github.com/TeXworks/texworks/wiki/Building
https://github.com/TeXworks/texworks/wiki/Building
https://github.com/TeXworks/texworks/wiki/Building
https://github.com/TeXworks/texworks/wiki/Building
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TeXworks/texworks/wiki/Building and follow the instructions suitable for
your Linux distributions. Also see section C.

Once the program is installed, start TEXworks. The folders .TeXworks
and .config/TUG will be created in your home directory.

2.3 Under Mac OS X
If you want to obtain an “official” version, obtain TEXworks by downloading
the archive from the TEXworks web site http://tug.org/texworks/ after
the installation of the TEX distribution.

It comes as a standalone .app package that does not require any Qt files
installed into /Library/Frameworks, or other libraries into /usr/local/lib.
Just copy the .app anywhere you like and run it.

On Mac OS X, the TEXworks resource folder will be created in your
Library folder (~/Library/TeXworks/), inside your home directory. Pref-
erences are stored in ~/Library/Preferences/org.tug.TeXworks.plist
which you can delete if you ever suspect it is causing problems.

2.4 Ready!
Finally, some files may need to be added to the “personal” files that TEXworks
creates. As the exact location of these depends on your platform, this
will be referred to as <resources> or the TEXworks resource folder
throughout this manual. On Linux, this is ~/.TeXworks, on Windows XP
it is C:\Documents and Settings\<your name>\TeXworks, on Windows
Vista/7 it is C:\Users\<your name>\TeXworks, and on Mac OS X it is
~/Library/TeXworks/ by default. The easiest way to locate this folder in re-
cent versions of TEXworks is to use the Help→Settings and Resources. . .
menu item. It opens a dialog which shows you where TEXworks saves its
settings and where it looks for resources.

After installation and first run, have a look in the sub-folders of the
TEXworks resource folder and delete any qt_temp.xxxx files; they are tem-
porary files left behind and could interfere with the normal ones, which are
installed in the same folder, later on.

https://github.com/TeXworks/texworks/wiki/Building
https://github.com/TeXworks/texworks/wiki/Building
http://tug.org/texworks/


3
First steps

Let’s now see how to create a first document: for this you’ll need to type
some text in the editor window of TEXworks. (LA)TEX is not WYSIWYG1

software, so you’ll have to type the text and the instructions for formatting it
and you’ll see the result only after “typesetting” the text. This looks a little
bit dry, but one very quickly gets used to it and it is well worth the effort.

3.1 Interface summary
When one opens the editor, it shows a very sparse interface: a title bar, a
menu bar, two small toolbars, a large typing zone (white) and, at the bottom,
a status bar. We are in the source/editor window. If you have already typeset
the document previously, the resulting .pdf will be shown on the right hand
side in the preview window.

The first toolbar has a button to typeset and an drop-
down menu to choose the format for typesetting (we’ll

choose pdfLaTeX). Knowing that the keyboard shortcut for typesetting is
Ctrl T (Mac OS X: T ) and that we almost never change the format,

we could even hide this toolbar. The selection of a format for compiling can
also be changed through the Typeset menu.

The second toolbar provides the standard
functions: New document, Open, Save |

Undo, Redo | Cut, Copy, Paste | Search, Replace.
1What You See Is What You Get.

8
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Status bar

Editing zone Preview

Title bar

Menu bar

Toolbars

Even though they are not looking like real buttons, the widgets in the
status bar can be clicked. The widgets showing the current position (line or
page, respectively), for example, open a dialog to enter a line or page to jump
to when clicked. The other widgets typically open contextual menus where
some settings can be changed.

3.2 Creating a document

3.2.1 Writing the document
As an example of the use of TEXworks, we will work with LATEX, but any other
TEX system is possible. In particular, if you need to use some special fonts2—a
mandatory font for an official template, non-Latin alphabets, etc.—the X ETEX
system is very powerful.3

2You can only use fonts (LA)TEX knows, most of which are coming in packages included in
your distribution. You cannot use your “normal” fonts, unfortunately. For more information,
see for example http://faq.tug.org/ and http://www.tug.dk/FontCatalogue/.
3See the bibliography for pointers to X ETEX and X ELATEX.

http://faq.tug.org/
http://www.tug.dk/FontCatalogue/
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Let’s create our first document now. Enter the following text exactly as
shown. To show some of the features of TEXworks/LATEX, it is in French
intentionally.

\documentclass{article}

\usepackage[utf8]{inputenc}
\usepackage[T1]{fontenc}
\usepackage{geometry}
\geometry{a4paper}

\usepackage[frenchb]{babel}

\title{Premier document}
\author{Un TeXnicien}
\date{}

\begin{document}
\maketitle

Voici un texte accentué en français!

\end{document}

Save the file in a folder for test documents (e.g., <home>\TeXworks_tests);
call the file first.tex. Note that it should have a .tex extension.

3.2.2 Typesetting the document and viewing it
Next we start typesetting4 by clicking the green button or by Ctrl T
(Mac OS X: T ).

A new panel opens between the typing area and the status bar: the output
panel, labeled Log; everything LATEX is doing is displayed there5. When LATEX
finishes this panel disappears (if there no error occurred) and a new window
will appear; in this new window, the Preview window, you can see a page
with a title “Premier document” followed by the name of the author “Un
TeXnicien”, both centred, the text “Voici un texte accentué en français !”,
and a page number at the bottom centre.
4We also use the words “compilation” and “to compile” for the same action; indeed LATEX

works on the source file to produce a .pdf output, so there is a compilation.
5see page 12 for a picture of the panel
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Notice that the mouse cursor is like a magnifier in the new window. If you
press (and hold) the left button of the mouse you can see the text under the
magnifier much bigger (it is a magnifier, isn’t it!); you can move the magnifier
and so inspect the text in detail.

To go back to the source, you can just click in its window or better use
Ctrl ’ (Mac OS X ’ ). This shortcut toggles between the two

windows. See also section 5.1 to automatically move to a specific location in
the output from the source or vice versa.

3.2.3 The work of LATEX
Let’s shortly analyse the result to understand what LATEX did and why, now.
Introductions and full tutorials can be found on the internet: see for example
lshort6 which should be installed as part of your TEX distribution, and is also
available from CTAN.7

First, we ask to create a document of the article class: this defines the
global layout of the document.

Next, we say that the input document (the source) is saved with the
Unicode encoding utf-8 and that it may contain characters which are not
present in the standard ASCII without accents. We also want to use an output
encoding T1 (the modern TEX encoding); we also want an A4 document and
not the default US letter size. Finally, we make it clear that the typography
should follow the French rules using the babel package.8 Those general
instructions for the work are done by packages called with options.

Lastly, we finish the declaration part of the document, the preamble, giving
the title, the author, and the date of the document; here we specify no date.

Next comes the body of the document, which describes the actual content,
between the lines \begin{document} and \end{document} (these are LATEX
commands).

Let’s do some experiments to show the effect of these instructions. For
this, we put a % in front of the instructions; the % and everything after it
will be considered as comment, which will be ignored by LATEX.9

Comment out the line \usepackage[utf8]{inputenc}, and typeset the
file. You should see that the accented characters are now displayed incorrectly
6The (Not So) Short Introduction to LATEX 2ε
7Comprehensive TeX Archives Network, a network of mirror servers of the central CTAN;

there, one can find almost everything about TEX, LATEX, and more: http://www.ctan.org
8This influences, e.g., automatic hyphenation of words or the way punctuation characters

are typeset
9Notice that the comments are, by default (this can be changed), coloured red by TEXworks,

so we see them well.

http://www.ctan.org
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in the preview window. If, in addition, you also comment out the line
\usepackage[frenchb]{babel}, LATEX will give an error. Just hit ←↩ to
continue the typesetting.

After these experiments, let’s modify the text as follows:
\begin{document}
\maketitle
\tableofcontents

\section{Petite démonstration}

Voici un texte accentué en français!
Suite du texte entré après avoir fait un retour chariot. Dans
l'éditeur on peut demander un passage automatique à la ligne
du texte saisi; mais le numéro de ligne n'est incrémenté que par un
retour chariot.

Nouvelle ligne en passant une ligne dans la source: c'est la
manière d'indiquer un changement de paragraphe.

\end{document}

Redo the previous experiments and observe the changes which appear.
Note that entering only one carriage return doesn’t create a new paragraph.

In LATEX, one has to have an empty line for that. In TEXworks, the line
number of the source (on the right in the status bar) numbers the lines created
with carriage return, not the wrapped lines.

3.3 And when errors occur?
When you create a document for typesetting with LATEX, you cannot avoid
making mistakes: forgetting a closing brace or an \end{} to close an envi-
ronment, using mathematical commands without switching to mathematical
mode, etc. When you compile and there is an error, LATEX stops, giving you
a chance to deal with the problem. This is shown by the stopping of the
scrolling action in the output panel, and an error message being displayed,
with LATEX waiting for an instruction to know what it should do.
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Status bar

Console bar

Output panel

One sees the typing cursor in the line between the output panel and the
status bar: the console bar.

The error message is on many lines, for example like this:

! Undefined control sequence.
l.168 ... fermante ou d'une commande \veb

+\end{}+ de fermeture d'un...
?

LATEX says that it doesn’t recognize the command name, sometimes
suggests to see the manual or to type h (plus ←↩ ) for help, points to the
line number where it noticed the error10 (here 168), and shows the place of
the error at the cut of the line (here at \veb). Finally, it shows that it waits
for an action from us by displaying a single question mark.

There are different possible actions:

• Type ←↩ and ask to continue as if nothing happened; sometimes this
allows to finish compiling, but there will be an error in the result.

• Type h ←↩ to ask for help; this help is not always clearer than the error
message, but often gives a clue.

• Type i ←↩ to tell LATEX that we will propose a replacement text. Enter
the text followed by ←↩ ; it will be used, beginning at the start of
the error, but you should correct the source afterwards as LATEX never
changes that.

10Unfortunately, this does not always have to be the place where the actual mistake was
made in the sources. This is discussed later.
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• Type x ←↩ to stop compilation. This is the traditional (LA)TEX way to
kill a typesetting process.
We can also kill the typesetting by repeating the action used to start
it: the green typesetting button will have changed to a red one with
a white cross . By clicking on that button or by hitting Ctrl T
(Mac OS X: T ) again, the LATEX process is terminated. The
output panel is still visible and so one can still see the error message.

You should note that sometimes an error appears far from its actual
position. For example, when opening an environment but not closing it,
LATEX doesn’t see the error before it encounters another end of environment
without closing of the first one. The error is often only picked up at the
\end{document} command, which shows that another environment was not
closed!

Sometimes, an error still occurs during subsequent runs of (LA)TEX even
after it was corrected in the document. This can happen because (LA)TEX
creates a number of intermediary files which can still contain the original,
erroneous code. Therefore, it is advisable to remove those files after fixing an
error. TEXworks provides a command to facilitate this—see section 5.6.

After an error occurred, the output panel remains open—even after con-
secutive typesetting runs—to help you fix the problem (which can sometimes
take several attempts and restarts of (LA)TEX). Once all problems are solved,
you can close the panel by the Windows→Hide Output Panel menu
item. As an alternative, you can also configure to output panel to hide
automatically as soon as the typesetting process finishes successfully by set-
ting Edit→Preferences. . .→Typesetting→Hide output panel to On
success. Since one can easily overlook other problems in the document (e.g.,
undefined references) that do not cause (LA)TEX to fail, this option is only
recommended to expert users.

To help you in finding and fixing error (at least if you are using LATEX),
TEXworks comes with a small script that extracts all errors, warnings, and
other noteworthy messages from the console output and presents them to you
in a simple, tabular form.
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Here, you see a list of LATEX messages, color-coded and sorted by severity.
Red represents errors, yellow indicates warnings, and blue stands for over-
and underfull box warnings. Next to the colour bar, you see the name of the
file in which the error was detected. Next to that, you see the line number (if
the script was able to determine that), as well as an excerpt from the console
output telling you what the error was. Moreover, the filename is a link which
will take you to the file (and, if a line number could be determined, also the
line) where LATEX reported the error. Hopefully, you can quickly fix any errors
that may occur this way.

In case you are not using LATEX, this script may be of little use, particularly
if the console output is formatted differently. In this case, you can simply
disable the error parsing hook script (see section 6.2).

3.4 Changing TEXworks parameters for
convenience

If the default font of the editor doesn’t suit you, it is possible to change it from
Format→Font. . . by selecting a new one in the dialogue box which appears.
This change will apply only to the current window, and until TEXworks is
restarted.

From the Typeset menu or from the drop-down on the Typesetting
tool bar, you can change the compilation format. Again this change will
only be temporary and for the current document.

To have permanent changes, you need to change the preferences through
the Edit→Preferences. . . menu item, using the Editor tab for the font
and the Typesetting tab for the compilation format: the default format is
at the bottom of the tab.



4
Going further: Editing tools

When you have had some practise with TEXworks, you’ll find the need for
more effective tools. Many of them are bundled with TEXworks. We are going
to see some of them now.

4.1 Creating a document from a template
Most documents you will create will use the same instructions in the preamble,
the same layout settings, similar heading and so on. You can use predefined
templates to get started quickly or create your own with all of these settings
already in place.

Use File→New from template. . . or Ctrl Shift ⇑ N (Mac OS X:
Shift ⇑ N ). A dialogue box opens to allow you to select one of the

templates. After selecting one and pressing OK, a document is created and
you can start to work.

If you want to create a personal template, you just have to create a suitable
document with everything you always want to do (and perhaps marking places
to fill in the rest) and save it as a .tex file in the <resources>\templates
folder, or a sub-folder of it, if you wish.

4.2 Creating a project using several source
files

When the source becomes long, it is sometimes difficult to navigate and
maintain it. In that case, it is useful to split the source into different smaller
files: one file will be the main document, with the preamble and the document

16
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environment, as well as calls to the “sub-documents”1, which could in turn
contain separate chapters, for example.

But there might be a problem if you want to start typesetting/compilation
in a sub-document: as there is neither a preamble nor a document environment
there, LATEX will stop immediately with an error.

To tell TEXworks that it should typeset the main document, one adds at
the very beginning of the sub-document the instruction:

% !TeX root = path/main_file.tex

for example:

% !TeX root = manual.tex

If the main file is in the same folder, its name is enough, as in the above
example. Otherwise, you must also give the path to the main document
(preferably relative to the sub-document in question, e.g., ../manual.tex).
Notice that the slash / and not the backslash \ should be used as directory
separator even on Windows.

Further, with MiKTeX, the call to a sub-document \input{name.tex}
should include the extension .tex to ensure proper SyncTeX functionality
(see section 5.1).

4.3 Spell-checking
You can turn on automatic spell-checking of your source document from Edit
→Spelling→<language>. It is also possible to ask TEXworks to enable
spell-checking by default by setting a dictionary in Edit→Preferences. . .
→Editor→Spell-check language.

During typing, every word the spell-checker considers wrong is underlined
by a red wavy line. A right-click on the word opens a contextual menu in
which there are some replacement suggestions. Click on the desired word to
make the replacement.

Before using the spell-checker, you need to install dictionaries in the right
folder of TEXworks: <resources>\dictionaries. The <resources> folder
can be accessed easily via Help→Settings and Resources. . . .

1Called by the commands \input{} or \include{}, see LATEX manuals for more informa-
tion.



4. Going further: Editing tools 18

On Linux, the dictionaries are usually taken from the folder /usr/share/
myspell/dicts—the default path for myspell dictionaries. Note, though,
that the maintainer of your TEXworks package may have changed this to
reflect the file system layout of your Linux distribution. You can override
this default by setting the TW_DICPATH environment variable before running
TEXworks.

One can use the available dictionaries for OpenOffice.org and other free
software;2 if you have Mozilla Thunderbird with spell-checking, you can copy
its .aff and .dic files as well, for example.

4.4 Search and replace

4.4.1 Standard functions
The options of the menu Search—Find. . . , Find again, Replace. . . ,
Replace again, and Go to Line. . . ( Ctrl F , Ctrl G , Ctrl R ,
Ctrl Shift ⇑ R , and Ctrl L , respectively)—are standard actions (Mac
OS X: F , G , R , Shift ⇑ R , and L ); the
first and the third open a dialogue box:

Here, the usual options are available: Wrap around, Find backwards,
Search/Replace within selection, or Find all occurrences. The following
options are also usual: Case sensitive and Whole words. By default, the
search is forward, towards the end of the document.

The option Search/Replace in all open files is also a frequent choice, but
not as much as the others; this allows, for example, replacement in all the
files of a project—pay attention, though, as this is very powerful.

The last option, Regular expression, is detailed in the next sub-section.
In the Search menu there are other options:

2See, for example, http://extensions.services.openoffice.org/dictionary. The
.oxt files can be renamed to .zip and then uncompressed to find the required .dic and
.aff files.

http://extensions.services.openoffice.org/dictionary
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Copy to Find copies the currently selected text into the Find field of the
Find dialogue or the Replace field of the Replace dialogue; you still
need to open the dialogues separately

Copy to Replace copies the currently selected text into the With field of
the Replace dialogue

Find Selection uses the current selection for a search without opening the
Find dialogue—very fast

Show selection scrolls the view to the currently selected text—useful if
word wrapping is turned off and you moved in the document using the
vertical scroll bar on the right

4.4.2 Advanced search and replace (regular
expressions)

The regular expressions provide a very powerful tool, but they require some
effort to be well understood. To understand them fully would require a
manual of its own3, so we’ll only give some simple ideas of use. For more
advanced uses, as well as lists of the most used codes, see section B.

Suppose we have the following text:

Voici du texte pour tester les expressions régulières dans du texte
accentué.
Voici du texte pour tester les expressions régulières dans du texte
accentué.
Voici du texte pour tester les expressions régulières. Voici du
texte pour tester les expressions régulières.
truc truc
tél.: 010-99-99-99
tél.: 00.32.10.99.99.99
tél.: 00/32-10/99.99.99

We want to

1. insert an empty line after each “accentué” (to create paragraphs in
LATEX), but not after the three telephone numbers;

2. replace each tab character between the two words “truc” of the fourth
paragraph by three spaces; and finally

3Such manuals exist on the internet.
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3. make the telephone numbers consistent by replacing the various punc-
tuation characters by spaces.

For 1., in the dialogue box Replace ( Ctrl R ) for Replace: we put
›\n‹4 and in With: ›\n\n‹. ›\n‹ is the code to match or insert a line feed.
You will need to select the first four paragraphs and the beginning of the
fifth (the first telephone number) and to tick the Replace within selection
and Regular expression options; if this was not done and an empty line has
been inserted after each line, select the telephone lines and do the reverse
action: replace ›\n\n‹ by ›\n‹. So we replaced one line feed by two, creating
an empty line.

For 2., use ›\t‹ and ›   ‹5. ›\t‹ is the code which represents a tab, while
a space is typed in literally (here represented as  ).

For 3., find ›-|\.|/‹ and replace with › ‹. Here, ›|‹ provides alternatives
(-, ., or /); for the dot we have used ›\.‹ because the dot alone is a regular
expression code which represents any character and we would have replaced
all the characters by spaces! We therefore have to use a code—prefixing the
dot with a backslash tells specifies that the normal meaning of the dot should
be used instead of the special meaning it usually has in regular expressions.

If one has strings of the same character but of different lengths (for
example 3, 4, or 5 times the sames character e) and one wants to truncate all
these strings to a string with less characters (for example 2), one can ask to
replace the string ›e{3,5}‹ by ›ee‹.

If one wants to insert the same string at the beginning of some paragraphs
separated or not by an empty line, for example ›\noindent ‹ or ›\item ‹,
one can replace ›\n\n‹ or ›\n‹ by ›\n\n\\noindent ‹ or ›\n\\noindent ‹.
Pay attention, we have a double \ in front of noindent to get one (\noindent)
because \ is an escape character in regular expressions (we’ve met it before
in the expression \.)!

If it were making sense, we could replace all the letters between “a” and
“m” by “$” using ›[a-m]‹ and ›$‹.

4the ›‹ are used here only to show the limits of the entered text and they should not
actually be entered.
5These are three space characters.
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4.5 Other tools for editing and error
tracking

4.5.1 Standard tools
It is always possible to undo an action using Edit→Undo or Ctrl Z (Mac
OS X: Z ): this way you can undo stepwise! The inverse action, redo,
is available as Edit→Redo or Ctrl Shift ⇑ Z (Mac OS X: Shift ⇑
Z ).6

TEXworks also provides the standard editing tools such as the clipboard;
therefore one can select, cut/copy and paste a piece of text normally.

You can select with the mouse by dragging over the desired text, or by
double-clicking to select a word. Using the keyboard, holding down Shift ⇑
while moving using the arrow keys will select text. You can also move and
select word by word moving left or right holding Ctrl Shift ⇑ down (
Shift ⇑ on Mac OS X). The clipboard shortcuts are the ones you’ll find in
almost every program: Ctrl X to cut, Ctrl C to copy, and Ctrl V
to paste ( X , C and V , respectively, on Mac OS X).

You can easily change the case of a selection—put everything upper
case or lower case—using Edit→Change case and next, depending on
the desired effect, ALL UPPERCASE, all lowercase, or Toggle Case
(which toggles the case of each letter individually).

It is also convenient to show the line numbers, as all error messages refer
to these numbers; you can toggle the line numbers, on the left of the editing
panel, from Format→Line Numbers.

4.5.2 Commenting
When preparing a document with (LA)TEX, it is often useful to prevent
compilation of a portion of text to be able to locate an error; you can do
this piece by piece until you find the part which causes the error. For that,
commenting the source block by block is needed.

We have seen that the symbol % marks the beginning of a comment. To
comment a big piece of text, it is sufficient to select it and ask to mark it
as comment Format→Comment or Ctrl Shift ⇑ ] (Mac OS X:
Shift ⇑ ] ). To remove the comment, select the lines and choose Format
→Uncomment or Ctrl Shift ⇑ [ (Mac OS X: Shift ⇑ [ ).7

6 Ctrl Y and Alt Shift ⇑ Backspace work as well on Windows. Y work
as well on Mac OS X.
7On some keyboards, like the French one, it is impossible to use Ctrl Shift ⇑ [ or
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4.5.3 Matching delimiters
A frequent error is to forget a closing symbol: parenthesis, bracket, square
bracket, etc. TEXworks helps with a tool to show the pairs of symbols: when
the cursor moves over one of these symbols, its partner is briefly highlighted.
You can also select an entire block using Edit→Balance Delimiters or by
the shortcut Ctrl B (Mac OS X: B ). Thus, you will immediately
see the scope of the block.

4.5.4 Smart quotes
Another similar error, but this time semantic and not hindering typesetting,
is in the use of quotes when one wants to give focus to some text.

There are two types of quotation marks in English: the ‘single’ quotes
and the “double” quotes. They are formed by ‘ and ’; these are not the
quotation marks used in programming and found on the keyboard: " and '.
Using the TEXworks smart quotes system, one can use the latter as normal
to automatically produce the typographically correct single/double opening
and close quotes.

In a .tex document, select one of the smart quotes system: Format
→Smart Quotes→TeX Ligatures, →TeX Commands, →Unicode
Characters. Then, when you want to start a quoted section in your text,
let’s say enclosed in double quotes, type ", then the text to be quoted, and
finish again by "; TEXworks will automatically insert the correct opening
quotes `` and later the correct closing ones ''. The three options give the
same result in the typeset document, but TeX Ligatures should work best
in most cases.

Finally, it is possible to define personal quotation marks systems (in the
file smart-quotes-modes.txt in the configuration folder of the resource
folder).

4.6 Auto-completion
Another tool which rapidly becomes indispensable is auto-completion. Indeed,
when you use (LA)TEX, you have to continuously enter codes to, for example,
create environments; you also have to remember to close every group you
open.

Auto-completion allows you to type a keyword, hit the � key, and have
TEXworks insert the (LA)TEX command or environment code automatically.

Ctrl Shift ⇑ ] ; these shortcuts can be changed, however—see section A.2
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As an example to insert “LATEX”, we have to type \LaTeX. This is not
difficult, but entering “\” followed by the word “LaTeX” with alternating
capitals and lower case letters could become annoying after a while.8 With
auto-completion, you just enter latex and hit � to get \LaTeX. You just
have to take care that there is no letter directly preceding or succeeding
latex—e.g., alatex—, or else the mechanism might not pick up the correct
keyword.

Another example is bmin, which gives

\begin{minipage}{}
•
\end{minipage}•

with the cursor between the empty pair of curly brackets where you need to
enter the size of the minipage. See the section A.3 for a list of the keywords
for auto-completion. Notice the “•” in the minipage environment. They are
placeholders which can be reached by Ctrl � ( � on the Mac),
repeating this shortcut cycles forward through the placeholders; by Ctrl
Shift ⇑ � ( Shift ⇑ � ), you can also cycle backwards.

If a partial keyword is given, repeatedly hitting � will cycle through
possible completions. For example, bali (the b commonly indicates the
beginning of an environment, \begin{}) creates the align environment after
one � , next align*, and after that, in succession, alignat, alignat*,
aligned, alignedat, and alignedat with options; to access the last envi-
ronments directly, they have their own codes which start by bali (balis,
baliat, baliats, balied, baliedat and baliedato).

If you want to create your own keywords, you can add a .txt file in the
completion folder inside the resources folder. The entries in the file should
have the following format:

bfigo:=\begin{figure}[#INS#]#RET##RET#\end{figure}•
\bibliography{#INS#}•

In the first case, bfigo is the assigned keyword (with :=) to be converted
into a figure environment with an optional argument; there are two carriage
returns (#RET#) after the begin, i.e., an empty line, and the cursor is placed
between the square brackets (at the position of #INS#). “•” is a place holder
as introduced before.
8In particular with keyboard layouts where \ is not directly accessible.
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In the second case, we give ourselves a shortcut, which will let us type
the first part of \bibliography{} and have TEXworks convert it to the full
name plus braces (with the cursor between them). In this case, the keyword
is the instruction itself.

Note that the .txt file containing the auto-completion information needs
to be UTF-8 encoded—this is the default encoding for all files created with
TEXworks.
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Going further: Other tools

5.1 SyncTeX’ing between source and
preview

When you are reading a document in the preview window and see something
to change, it is convenient to go immediately to the corresponding place
in the source. To do so, hold down Ctrl (Mac OS X: ) and click at
the appropriate place in the preview; the cursor will move and highlight the
corresponding location in the source window. The same is true in the other
direction: Ctrl in the source will highlight the same line in the preview
window.1

Here a remark for users under Windows: this only works if all the
names for folders/files/. . . do not have accented characters. If, for exam-
ple, your document is in C:\Documents and Settings\Propriétaire\My
Documents\thesis it will not work because of the é in Propriétaire!

5.2 Special comment strings
Special comments, at the very beginning of the files, can be used to manage
two other aspects of the compilation.

By default, TEXworks uses the “utf-8” encoding for loading and saving
files, but some files could be saved in another encoding. Common ones are
“latin1”, which is the dominant encoding on Windows when using western
languages, and “Apple Roman” which is dominant on Mac OS.
1It is also possible to use a right-click ( ) to open a context window and select “jump to

PDF” or “jump to source”.

25
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To set a different encoding for a specific file one can put the following at
the beginning of that file:

% !TeX encoding = latin1

Note that without this line, you must tell TEXworks the correct encoding
manually. Otherwise, your data could be corrupted! To override TEXworks’s
default choice of encoding, use the menu that appears when you click on the
editor window’s middle status bar widget.

If you opened a file in TEXworks that was not saved as utf-8 but is lacking
the % !TeX encoding line, it might be displayed with (some) weird characters.
In that case, you can specify the correct encoding via the status bar widget
menu in the same way, but it is imperative that you then use Reload using
selected encoding from the same menu! This forces TEXworks to open the
document again with the encoding you selected, the weird characters should
be replaced by normal ones, and only then it is safe to continue to work
normally. To avoid having to repeat this procedure each time you open this
file, you should either switch to utf-8 for saving it in the future or add a
proper % !TeX encoding line.

If we want to compile a file with another programme than the default
TEX or LATEX, we put at the beginning of the file:

% !TeX program = <the_programme>

for example:

% !TeX program = xelatex

Pay attention to this last instruction. You have to use the name of the
programme here which should be used for the whole project, as the first
encountered programme when starting typesetting is used (which is the one
from the sub-document you are in). TEXworks will use that programme, even
if another name appears in the main document!

When opening a document which contains a % !TeX program line, the
specified programme will become the one to use and its name will appear
in the drop down menu in the toolbar; you can, however, override this by
selecting a different one from the drop down list, if you want.
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In addition, you can set the spell checking language by a similar comment
line:

% !TeX spellcheck = <language_code>

The language codes available on your system are listed in parentheses in Edit
→Spelling next to the human-readable name of the language.

5.3 Formatting the source for legibility
To facilitate legibility of the source, one can use indentation as programmers
do:

\begin{itemize}
\item First element of the list;
\item second element;
\item last element:
\begin{itemize} % beginning of a sub-list

\item first sub-element;
\item second sub-element.

\end{itemize}
\end{itemize}

This increases legibility, but works well only on short lines, without text
wrapping; or if one chooses not to use text wrapping by unchecking Format
→Wrap lines.

The command Format→Indent or the shortcut Ctrl ] (Mac OS X:
] ) will indent the line, or the selected lines, by inserting a tab character.

You can repeat the process to increase the indent.
To remove one level of indentation, use Format→Unindent or the

shortcut Ctrl [ ( [ on Mac OS X).2
As indent only indents the first part of very long (wrapped) lines, this is

not very satisfactory in some cases. But one can ask TEXworks to split a long
line (longer than the width of the editing window) into short ones adding a
hard coded line feed. Format→Hard Wrap... opens a dialog box in which
you can specify the width of the lines; you can also re-format lines which have
already been split.
2See the modified shortcuts if your keyboard layout does not allow these actions.
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5.4 Showing the tags
When a document is becoming long and you want to move to a specific place
(a chapter, a section, a subsection, . . . ) you normally need to scroll the
editing window to find the desired location, or use the Find dialog if you
remember a keyword in the chapter’s title.

To the same end, though a lot more comfortable, you can also use the
structural information in the document to navigate the source: the menu item
Window→Show→Tags opens a panel showing the information detected
by TEXworks. Clicking on an item in the panel moves the cursor to the
corresponding part in the source. That panel, like any other, can be resized
by dragging its border.

The same action is possible in the PDF window from Window→Show
→Table of contents, but this only works if one has created structure tags
in the PDF file using the package hyperref.

5.5 Organising the windows
By default, the editor/source window opens on the left and the preview one
on the right (when the corresponding PDF file exists), thus splitting the
screen in two.

You can change the position of the windows in the Window menu.
→Stack and →Side by side give the default effect if there is only one
document open. If not, →Stack creates a mosaic with all the windows. The
other options allow to place the windows for your convenience. It is also
always possible to resize and move the windows manually, of course.

For the preview you can change the way it is presented and of course the
zoom by View→Actual size,→Fit to width and→Fit to window; you
can also zoom in and out. Shortcuts exist for all these actions and are shown
next to the menu items.

5.6 Cleaning the working folder
Very soon when one uses (LA)TEX, one discovers that the working folder is
cluttered by many files which have the name of the source file but different
extensions: .aux, .log, .toc, .lof, .lot, .bbl, . . .

All these are files needed by (LA)TEX to be able to create the table of
contents, lists of figures/tables, the bibliography, the cross references and,
also very importantly, to keep track of what it did (in the .log file).
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Apart from the external files, images, pictures, . . . , the only files required
are the .tex files, the sources of the document. One can erase all the others.
Sometimes, this is even necessary when (LA)TEX gets stuck after an error.

This can be done using a TEXworks command from the File menu with
the →Remove Aux files. . . item.

When you use this command, a dialog box opens in which you can
check/uncheck the files you want to remove.3 The dialog box will only list
files that actually exist in the folder; if you removed all these auxiliary files
before, you get a message box saying that there is no file to remove at the
moment.

The list of auxiliary files which are taken into account is defined in the
file texworks-config.txt in the configuration folder of the TEXworks
resources folder. You could add some if required.

5.7 Portable Usage & Changing the
Configuration

We have seen in section 2 (on page 5) that the first time you use TEXworks,
it creates a resource folder and also that it saves default preferences.

It is possible to define a personal place where one wants the resource folder
and the preferences. This can be handy when one wants a portable system
(e.g., on an USB stick) or when one wants to easily access the templates or
completion folders for modifications.

For this, create a file texworks-setup.ini in the programme folder in
which you specify the path to the folder containing the completion, configura-
tion, dictionaries,. . . folders and the configuration file (texworks.ini); there
will be two lines:

inipath=C:/myfolder/TW_conf/
libpath=C:/myfolder/TW_conf/

inipath for the configuration file and libpath for the necessary folders.
Here, TW_conf would replace the resource folder TeXworks. Note that the
referenced folder (here TW_conf) should exist—it will not be created—, and
that the / is used even on Windows (instead of the common \).

If one wants to put the resource folder in the programme folder as a
subfolder, one can use an instruction like inipath=./TW_conf/; all relative
3The name of the main file is used to list the possible candidates for deletion.
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paths are taken to be relative to the TEXworks programme folder (on Mac
OS X, the folder containing the app package is used).

One can also add a line like

defaultbinpaths=C:/Program Files/MiKTeX 2.7/miktex/bin

to specify where the programmes of the TEX distribution are located; but
this instruction is not yet completely operational, especially under Windows.
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Advanced use: Scripting

6.1 Introduction to Scripting
All the functions and utilities described so far were built into TEXworks
by default. While some of them could be configured or customized to a
certain extent, they are intended to suit the most common needs of a general
audience. However, the TEX world is very large and diverse. In order to
enable users to address their special needs—from simply making some text
bold to fulfilling special requirements for the next book or scientific paper
you want to publish—, the core functionality of TEXworks can be extended
or modified by the use of scripts.

Scripts are simple text files that you can open, read, or modify in any
text editor (including TEXworks, of course). They are written in a specific
scripting language that is essentially a programming language. At the time
of writing, TEXworks supports QtScript1 (built-in), Lua (with a plugin), and
Python (with a plugin). To see which scripting languages are available on
your system, use the Scripts→Scripting TEXworks→About Scripts. . .
menu item.

Writing scripts is beyond the scope of this manual, but is documented
elsewhere2. Here, only the installation and usage of scripts will be discussed.

TEXworks distinguishes between two types of scripts: standalone scripts
and hook scripts. The primary purpose of standalone scripts is to add new
functionality to the program. If you need a new function, such as a command
to make the selected text bold, a standalone script is the one to choose. These
scripts get an item in the Scripts menu, and you can run them simply by
1A scripting language similar to JavaScript provided by Qt.
2See, for example, Paul Norman’s page http://twscript.paulanorman.com/docs/

index.html.
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clicking on that menu item (or by using a keyboard shortcut, if the script
provides one).

Hook scripts, on the other hand, are meant to extend existing TEXworks
functions. They are hooked into the code at specific places, e.g., after the
typeset process has finished or after a file was loaded, and can add or modify
whatever TEXworks is doing. One example for this would be a script that
analyses a newly loaded file and sets the spell-checking language based on
babel commands found in the document. Thus, hook scripts do not show up
in the Scripts menu but are instead run automatically when the TEXworks
function they modify is used.

You can easily determine which type of script you have by opening the
script file. Near the top of the file, you should find a line similar to

// Type: standalone

Alternatively—once the script is installed—, you can use the dialogue available
from Scripts→Scripting TEXworks→Manage Scripts to display this
information.

6.2 Installing Scripts
A word of caution first: do not install scripts from a source you do not trust!
Before installing scripts, you should make sure that the file you are about to
install indeed does what you expect. Scripts are very powerful—they can do
almost everything a normal program can do. So while there are some security
precautions built into TEXworks, you should still be aware that scripts could
potentially harm your computer and cause (among other things) crashes and
data loss. In particular, scripts can read, create, and modify arbitrary files
on your hard drive.

That said, installing scripts is very simple. Script files are generally in-
stalled in <resources>/scripts or subdirectories of it. These subdirectories
are shown as submenus of the Scripts menu, so they can be used to group
and categorize scripts. This is especially useful if you use many different
scripts that would otherwise make the Scripts menu very confusing. One
easy way to open the scripts folder is the Scripts→Scripting TEXworks
→Show Scripts Folder menu item.

Since scripts are usually simple plain-text files, they do not come with
fancy installers. To install them, simply copy or decompress (if archived, e.g.,
in a .zip file) the script file—and any other required files that you may have
received—into <resources>/scripts or a subdirectory of it.
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After having installed a new script file, TEXworks needs to become aware
of it. It automatically scans for all scripts during start-up, so you could close
all TEXworks windows and restart the application. An alternative is provided
by the Scripts→Scripting TEXworks→Reload Script List menu item
which rescans all scripts without otherwise interfering with the program.

You can also disable scripts (or whole directories of scripts) if you want to.
This can be useful if you do not need some scripts for some time and do not
want them to clutter the Scripts menu, but do not want to uninstall them
entirely. Or if you want to prevent hook scripts from being run automatically.
To do this, open the “Manage Scripts” dialogue with the Scripts→Scripting
TEXworks→Manage Scripts menu item. Simply uncheck the script you
want to disable and it won’t bother you again.

6.3 Using Scripts
Using scripts is simple. Hook scripts are used automatically—you don’t need
to do anything. Standalone scripts show up in the Scripts menu or one of
its submenus. If you cannot find a script you are looking for, or if you find
a script you do not know the purpose of, you can use the “Manage Scripts”
dialogue to get additional information (like the author, a brief description,
etc.) about it.

Some scripts need to run other programs on your system. One example
would be a script that opens the pdf in the system’s default previewer,
e.g., for printing. Since running arbitrary commands can in some situations
be particularly dangerous, this functionality is disabled by default. You
will notice this when a dialogue pops up informing you of an error in the
script, or a similar message is displayed in the status bar. To enable scripts
to execute system commands, open the preferences dialogue via the Edit
→Preferences. . . menu item. There, go to the “Scripts” tab and check the
“Allow scripts to run system commands” option. If you want to disable this
function again later just uncheck the option. Note that this option applies
equally to all scripts—there is currently no way to allow command execution
only for some scripts.
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Beyond this manual

In this manual, the authors tried to give an overview over TEXworks and a
concise introduction to get you started. TEXworks is constantly evolving and
improving, however, so the information presented here will never be complete.

Additional, frequently updated documents are posted in the wiki hosted
on GitHub at https://github.com/TeXworks/texworks/wiki. Particularly
noteworthy are the following pages:

SpellingDictionaries describes how to obtain and install dictionaries for
the spell-checker on various systems. https://github.com/TeXworks/
texworks/wiki/SpellingDictionaries

TipsAndTricks provides a compilation of useful things to know at a glance,
such as the % !TEX root construct. https://github.com/TeXworks/
texworks/wiki/TipsAndTricks

AdvancedTypesettingTools lists the configurations for several typesetting
tools that are not included in TEXworks by default, such as latexmk
or the dvips workflows. https://github.com/TeXworks/texworks/
wiki/AdvancedTypesettingTools

If you run into problems with TEXworks, it is advisable to browse the
mailing list archives accessible via http://tug.org/pipermail/texworks/.
If you use TEXworks regularly or are interested in learning about problems
and solutions when using it for some other reason, you can also consider
subscribing to the list at http://tug.org/mailman/listinfo/texworks to
stay up-to-date. For the occasional post to the mailing list, you can also
use the Help→Email to mailing list menu item. Please make sure you
replace the default subject by something describing your issue and to include
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all information that might help resolving it. That way, you are much more
likely to get many helpful replies.

If you find a bug in TEXworks or want to suggest a new feature you
would like to see in a future version, you should have a look at the issue
list at GitHub (https://github.com/TeXworks/texworks/issues). Before
posting a new item, please make sure that a similar report or request is not
already on the list and that the issue list is indeed the right place, though. If
in doubt, please ask on the mailing list first.

Happy TEXing!

https://github.com/TeXworks/texworks/issues


A
Customizing TEXworks

A.1 Syntax highlighting
Among its many other features, TEXworks also include syntax highlighting.
This means that certain things like LATEX commands, environments, or com-
ments are coloured, underlined, or highlighted in some other way. TEXworks
also provides the ability to switch between different highlighting schemes1,
and to define your own ones. This is useful if you often work with types of
files for which no highlighting scheme is provided by default, or if you want to
adjust the highlighting schemes to better match your system’s colour scheme.

To modify the highlighting schemes, you have to edit the plain-text file
<resources>/configuration/syntax-patterns.txt. This file can contain
any number of individual sections, each defining a single highlighting scheme
to be displayed in the menu structure of TEXworks. To define a section, just
write the name enclosed in square brackets on a line of its own. Naturally,
these names should not include the ] character. By default, the following two
sections are defined:

[LaTeX]
[ConTeXt]

In addition, you can add comments to the file by starting a line with #. Empty
lines are ignored.

Each section consists of an arbitrary number of styling rules. Each such
instruction consists of three parts: a formatting instruction, a spell-check
1Use Format→Syntax Coloring to change the highlighting scheme for the current

document, and Edit→Preferences. . .→Editor→Syntax Coloring to set the default one.

36
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flag, and a regular expression2 defining what part of a text to match. These
parts must all be on the same line, and separated by whitespaces (e.g., spaces
or tabstop characters). Take for example the following line from the default
LaTeX section:

red Y %.*

The first part, red, defines the format (in this case, a red foreground colour
is specified). The second part, Y, defines that spellchecking should be enabled
for text that matches this particular rule. Sometimes, it is useful to put N
here to disable spellchecking. For example, if spellchecking would be enabled
for LATEX commands, most documents would be flooded with red underlines
indicating misspelled words when in fact they are only special commands.
Finally, the third part specifies that this rule should be applied to all text
preceded by %.

Let us take a closer look at the three parts of each rule. In its most general
form, the first part—the format instruction—looks like

<foreground_colour>/<background_colour>;<fontflags>

The <fontflags> can be specified independent of the colours (note, though,
that it must always be preceded by a ;). The background colour (together
with the /) can be omitted, but if you specify it, you also have to specify the
foreground colour.

Each colour can either be specified by an SVG name3 or by a hexadecimal
value (#rrggbb4) similar as in web documents. The <fontflags> can be any
combination of the letter B (bold), I (italic), and U (underlined).

Examples of valid formatting instructions are:

red
white/#000000
;B
blue;I
#000000/#ffff00;U

2For some details on regular expressions, see B
3See https://www.w3.org/TR/SVG11/types.html#ColorKeywords for a list of valid

names.
4Because # is also used to mark comments if given as the first character of a line, you

need to add a space, tab, or similar before specifying a hexadecimal foreground color.

https://www.w3.org/TR/SVG11/types.html#ColorKeywords
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A.2 Keyboard shortcuts
The use of keyboard shortcuts greatly facilitates typing in and the management
of the source and the preview windows. Their use is much more effective than
the use of buttons for frequently-used actions.

Below, you’ll find the shortcuts for source and preview windows. Note
that on Mac OS X, Ctrl actually refers to the Command key, which is the
usual modifier for keyboard shortcuts. Although the keyboard shortcuts are
specified with Ctrl, this will appear as the Command-key symbol in menus.
(To refer to the actual Control key on the Mac, the shortcut file should use
the name Meta).

Note that the shortcuts listed below are the default shortcuts for the
English interface of TEXworks. Different languages may use different shortcuts.

All the shortcuts can be redefined either to create new shortcuts or to
modify the existing ones to match personal uses or change shortcuts not
adapted to one particular keyboard layout. The list of possible actions to
associate with shortcuts is given after the predefined shortcuts.

To define your own shortcuts, put a file named shortcuts.ini in the
<resources>/configuration folder, next to auto-indent-patterns.txt,
delimiter-pairs.txt, . . . , texworks-config.txt.

For example, this file could contain:

actionHard_Wrap = Shift+F3
actionLast_Page = Ctrl+End
actionFirst_Page = Ctrl+Home
actionWrap_Lines = F3
actionLine_Numbers = F4
actionBalance_Delimiters = F9

The first line defines that using Shift ⇑ F3 should open the hardwrap
dialogue box in the source window; the second ( Ctrl End ) should bring
you to the last page and Ctrl Home (third line) should take you to the
first page; with F3 you want to wrap/unwrap lines in the source, with F4
you will show/hide line numbers and with F9 you intend to select the text
between corresponding delimiters in the source.
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A.2.1 Predefined shortcuts
For working in the source window:

Shortcut Action
Ctrl+’ Go to Preview
Ctrl+= Show Selection
Ctrl+A Select All
Ctrl+Alt+S Save All
Ctrl+B Balance Delimiters
Ctrl+C Copy
Ctrl+E Copy to Find
Ctrl+F Find...
Ctrl+G Find Again
Ctrl+H Find Selection
Ctrl+L Go to Line...
Ctrl+N New
Ctrl+O Open...
Ctrl+Q Quit TeXworks
Ctrl+R Replace...
Ctrl+S Save
Ctrl+Shift+C Insert Citations...
Ctrl+Shift+E Copy to Replace
Ctrl+Shift+N New from Template...
Ctrl+Shift+R Replace Again
Ctrl+Shift+S Save As...
Ctrl+Shift+Z Redo
Ctrl+Shift+[ Uncomment
Ctrl+Shift+] Comment
Ctrl+T Typeset
Ctrl+V Paste
Ctrl+W Close
Ctrl+X Cut
Ctrl+Z Undo
Ctrl+[ Unindent
Ctrl+\ Hide Console Output
Ctrl+] Indent
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Moving the cursor (hold Shift ⇑ to select):

Shortcut Action
→ 1 character right
Ctrl+→ 1 word right
← 1 character left
Ctrl+← 1 word left
↑ 1 line up
↓ 1 line down
PgUp 1 screen up
PgDown 1 screen down
Home Begin of line
Ctrl+Home Begin of document
End End of line
Ctrl+End End of document

For working in the preview window:

Shortcut Action
Alt+Left Go to previous view
Ctrl+’ Go to Source
Ctrl++ Zoom In
Ctrl+- Zoom Out
Ctrl+1 Actual Size
Ctrl+2 Fit to Width
Ctrl+3 Fit to Window
Ctrl+4 Fit to Content Width
Ctrl+Backspace Clear
Ctrl+C Copy
Ctrl+F Find...
Ctrl+G Find Again
Ctrl+J Go to Page...
Ctrl+N New
Ctrl+O Open...
Ctrl+P Print PDF...
Ctrl+PgDown Next Page
Ctrl+PgUp Previous Page
Ctrl+Q Quit TeXworks
Ctrl+Shift+F Full Screen
Ctrl+Shift+N New from Template...
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Shortcut Action
Ctrl+Shift+Z Redo
Ctrl+T Typeset
Ctrl+V Paste
Ctrl+W Close
Ctrl+X Cut
Ctrl+Z Undo

A.2.2 Actions listed alphabetically

actionAbout_Scripts actionPageMode_Single
actionAbout_TW actionPageMode_TwoPagesContinuous
actionActual_Size actionPaste
actionApply_to_Selection actionPlace_on_Left
actionAutoIndent_None actionPlace_on_Right
actionAuto_Follow_Focus actionPreferences
actionBalance_Delimiters actionPrevious_Completion
actionClear actionPrevious_Completion_Placeholder
actionClear_Recent_Files actionPrevious_Page
actionClose actionPrevious_ViewRect
actionComment actionPrintPdf
actionCopy actionQuit_TeXworks
actionCopy_to_Find actionRedo
actionCopy_to_Replace actionRemove_Aux_Files
actionCut actionReplace
actionFind actionReplace_Again
actionFind_Again actionRevert_to_Saved
actionFind_Selection actionSave
actionFirst_Page actionSave_All
actionFit_to_Content_Width actionSave_As
actionFit_to_Width actionScroll
actionFit_to_Window actionSelect_All
actionFont actionSelect_Image
actionFull_Screen actionSelect_Text
actionGoToHomePage actionSettings_and_Resources
actionGo_to_Line actionShow_Hide_Console
actionGo_to_Page actionShow_Scripts_Folder
actionGo_to_Preview actionShow_Selection
actionGo_to_Source actionSide_by_Side
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actionHard_Wrap actionSmartQuotes_None
actionIndent actionStack
actionInsert_Citations actionSyntaxColoring_None
actionJump_To_PDF actionTile
actionLast_Page actionTo_Lowercase
actionLine_Numbers actionTo_Uppercase
actionMagnify actionToggle_Case
actionManage_Scripts actionTypeset
actionNew actionUncomment
actionNew_from_Template actionUndo
actionNext_Completion actionUnindent
actionNext_Completion_Placeholder actionUpdate_Scripts
actionNext_Page actionWrap_Lines
actionNone actionWriteToMailingList
actionOpen actionZoom_In
actionPageMode_Continuous actionZoom_Out

A.2.3 Actions listed by menu
For the source window:

Edit
actionBalance_Delimiters actionPreferences
actionClear actionRedo
actionCopy actionSelect_All
actionCut actionTo_Lowercase
actionInsert_Citations actionTo_Uppercase
actionNone actionToggle_Case
actionPaste actionUndo

File
actionClear_Recent_Files actionRemove_Aux_Files
actionClose actionRevert_to_Saved
actionNew actionSave
actionNew_from_Template actionSave_All
actionOpen actionSave_As
actionQuit_TeXworks

Format
actionApply_to_Selection actionLine_Numbers
actionAutoIndent_None actionSmartQuotes_None
actionComment actionSyntaxColoring_None
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actionFont actionUncomment
actionHard_Wrap actionUnindent
actionIndent actionWrap_Lines

Help
actionAbout_TW actionSettings_and_Resources
actionGoToHomePage actionWriteToMailingList

Scripts
actionAbout_Scripts actionShow_Scripts_Folder
actionManage_Scripts actionUpdate_Scripts

Search
actionCopy_to_Find actionGo_to_Line
actionCopy_to_Replace actionReplace
actionFind actionReplace_Again
actionFind_Again actionShow_Selection
actionFind_Selection

Typeset
actionTypeset

Window
actionAuto_Follow_Focus actionShow_Hide_Console
actionGo_to_Preview actionSide_by_Side
actionPlace_on_Left actionStack
actionPlace_on_Right actionTile

For the preview window:

Edit
actionCopy actionRedo
actionPreferences actionUndo

File
actionClear_Recent_Files actionOpen
actionClose actionPrintPdf
actionNew actionQuit_TeXworks
actionNew_from_Template

Help
actionAbout_TW actionSettings_and_Resources
actionGoToHomePage actionWriteToMailingList
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Scripts
actionAbout_Scripts actionShow_Scripts_Folder
actionManage_Scripts actionUpdate_Scripts

Search
actionFind actionFind_Again

Typeset
actionTypeset

View
actionActual_Size actionNext_Page
actionFirst_Page actionPageMode_Continuous
actionFit_to_Content_Width actionPageMode_Single
actionFit_to_Width actionPageMode_TwoPagesContinuous
actionFit_to_Window actionPrevious_Page
actionFull_Screen actionZoom_In
actionGo_to_Page actionZoom_Out
actionLast_Page

Window
actionGo_to_Source actionSide_by_Side
actionPlace_on_Left actionStack
actionPlace_on_Right actionTile

A.2.4 Other actions
In addition to the static actions listed above, there are also actions for scripts.
These are dynamic in nature, as they are created on-the-fly for the available
scripts (which may change when you install scripts, remove them, or change
some settings). All of these actions are of the form Script: <script_title>,
where <script_title> must be replaced appropriately. If you have a script
that shows up as My Script, for example, the corresponding action would be
named Script: My Script.

A.3 Roots for completion
We give here the keywords for auto-completion as they are supplied by
TEXworks. They are given in the files tw-basic.txt, tw-context.txt (ini-
tially empty) and tw-latex.txt in the <resource>\completion folder.

We give them in three columns: the first two show the keywords, the third
the (LA)TEX code produced. In some cases there is only the code, this means
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that you can start to enter the (LA)TEX code and try to complete it with � .
During completion, the system inserts line feeds and puts the cursor at

the first place where one has to enter information to complete the typing. To
represent the line feeds we used R and I for the input point.

So, a line like “\begin{abstract}RIR\end{abstract}•” should be inter-
preted as

\begin{abstract}

\end{abstract}•

with the cursor being position on the central, empty line.
It is possible to see that the keywords have some pattern. The mathemati-

cal variables have a keyword starting with x, when they are in a mathematical
environment; when they are used alone in the text you add d in front. For
example, xa and dxa give \alpha, if there is a capital there is a c, as xo for
\omega and xco for \Omega. The keywords for environments start with b: bali
for \begin{align} (b is a mnemonic for \begin). When the environment has
possible options, there is one or more o added to the base name: bminp gives
\begin{minipage}{}... while bminpo gives \begin{minipage}[]{}....

Keywords defined in tw-basic.txt (defined in TEX):

xa \xa \alpha
xb \xb \beta

\bsk \bigskip
\bigskipR

xch \xch \chi
xcd \xcd \Delta
xd \xd \delta
xe \xe \epsilon
xet \xet \eta
xcg \xcg \Gamma
xg \xg \gamma

\hskip
\indent
\input

xio \xio \iota
xcl \xcl \Lambda
xl \xl \lambda

\msk \medskip
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\medskipR
xm \xm \mu

\noindent
xn \xn \nu
xco \xco \Omega
xo \xo \omega

\par
xcph \xcph \Phi
xph \xph \phi
xcp \xcp \Pi
xp \xp \pi
xcps \xcps \Psi
xps \xps \psi
xr \xr \rho

\scriptsize
xcs \xcs \Sigma
xs \xs \sigma

\ssk \smallskipR
xt \xt \tau
tex \tex \TeX
texs \texs \TeX\
xcth \xcth \Theta
xth \xth \theta
xcu \xcu \Upsilon
xu \xu \upsilon
xve \xve \varepsilon
xvph \xvph \varphi
xvp \xvp \varpi
xvr \xvr \varrho
xvs \xvs \varsigma
xvth \xvth \vartheta

\vskip
xcx \xcx \Xi
xx \xx \xi
xz \xz \zeta
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Keywords defined in tw-latex.txt (defined in LATEX):

ncol \ncol &
dd \dd \( I \)•

\adc \addtocounter{I}{•}
adcount \addtocounter{I}{•}R

\adl \addtolength{I}{•}
adlen \addtolength{I}{•}R

\author{I}R
\begin{

babs \babs \begin{abstract}RIR\end{abstract}•
balis \balis \begin{align*}RIR\end{align*}•
baliats \baliats \begin{alignat*}{I}R•R\end{alignat*}•
baliat \baliat \begin{alignat}{I}R•R\end{alignat}•
baliedat \baliedat \begin{alignedat}RIR\end{alignedat}•
baliedato \baliedato \begin{alignedat}[I]R•R\end{alignedat}•
balied \balied \begin{aligned}{I}R•R\end{aligned}•
bali \bali \begin{align}RIR\end{align}•
bapp \bapp \begin{appendix}RIR\end{appendix}•
barr \begin{array}RIR\end{array}•
bbmat \bbmat \begin{bmatrix}RIR\end{bmatrix}•
bcase \bcase \begin{cases}RIR\end{cases}•
bcent \bcent \begin{center}RIR\end{center}•
bcenum \bcenum \begin{compactenum}R\itemRIR\end{compactenum}•
bcenumo \bcenumo \begin{compactenum}[I]R\itemR•R\end{compactenum}•
bcitem \bcitem \begin{compactitem}R\itemRIR\end{compactitem}•
bcitemo \bcitemo \begin{compactitem}[I]R\itemR•R\end{compactitem}•
bdes \bdes \begin{description}R\item[I]R•R\end{description}•
bdoc \bdoc \begin{document}RRIRR\end{document}
benu \benu \begin{enumerate}R\itemRIR\end{enumerate}•
benuo \benuo \begin{enumerate}[I]R\itemR•R\end{enumerate}•
beqns \beqns \begin{eqnarray*}RIR\end{eqnarray*}•
beqn \beqn \begin{eqnarray}RIR\end{eqnarray}•
bequs \bequs \begin{equation*}RIR\end{equation*}•
bequ \bequ \begin{equation}RIR\end{equation}•
bfig \bfig \begin{figure}RIR\end{figure}•
bfigo \bfigo \begin{figure}[I]R•R\end{figure}•
bflaligs \bflaligs \begin{flalign*}RIR\end{flalign*}•
bflalig \bflalig \begin{flalign}RIR\end{flalign}•
bfll \bfll \begin{flushleft}RIR\end{flushleft}•
bflr \bflr \begin{flushright}RIR\end{flushright}•
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bgaths \bgaths \begin{gather*}RIR\end{gather*}•
bgathed \bgathed \begin{gathered}RIR\end{gathered}•
bgathedo \bgathedo \begin{gathered}[I]R•R\end{gathered}•
bgath \bgath \begin{gather}RIR\end{gather}•
bite \bite \begin{itemize}R\itemRIR\end{itemize}•
biteo \biteo \begin{itemize}[I]R\itemR•R\end{itemize}•
blett \blett \begin{letter}{I}R•R\end{letter}•
blist \blist \begin{list}{I}{•}R\itemR•R\end{list}•
bminpo \bminpo \begin{minipage}[I]{•}R•R\end{minipage}•
bminp \bminp \begin{minipage}{I}R•R\end{minipage}•
bmults \bmults \begin{multline*}RIR\end{multline*}•
bmult \bmult \begin{multline}RIR\end{multline}•
bpict \bpict \begin{picture}RIR\end{picture}•
bpmat \bpmat \begin{pmatrix}RIR\end{pmatrix}•
bquot \bquot \begin{quotation}RIR\end{quotation}•
bquo \bquo \begin{quote}RIR\end{quote}•
bsplit \bsplit \begin{split}RIR\end{split}•
bsubeq \bsubeq \begin{subequations}RIR\end{subequations}•
btabb \btabb \begin{tabbing}RIR\end{tabbing}•
btabls \btabls \begin{table*}RIR\end{table*}•
btbls \btbls \begin{table*}RIR\end{table*}•
btablso \btablso \begin{table*}[I]R•R\end{table*}•
btblso \btblso \begin{table*}[I]R•R\end{table*}•
btabl \btabl \begin{table}RIR\end{table}•
btbl \btbl \begin{table}RIR\end{table}•
btablo \btablo \begin{table}[I]R•R\end{table}•
btblo \btblo \begin{table}[I]R•R\end{table}•
btabs \btabs \begin{tabular*}{I}{•}R•R\end{tabular*}•
btabx \btabx \begin{tabularx}{I}{•}R•R\end{tabularx}•
btab \btab \begin{tabular}{I}R•R\end{tabular}•
bbib \bbib \begin{thebibliography}{I}R\bibitem{•}R•R\end{thebibli-

ography}•
bindex \bindex \begin{theindex}RIR\end{theindex}•
btheo \btheo \begin{theorem}RIR\end{theorem}•
btitpg \btitpg \begin{titlepage}RIR\end{titlepage}•
btrivl \btrivl \begin{trivlist}RIR\end{trivlist}•
bvarw \bvarw \begin{varwidth}{I}R•R\end{varwidth}•
bverb \bverb \begin{verbatim}RIR\end{verbatim}•
bvers \bvers \begin{verse}RIR\end{verse}•
bfd \bfseries
bibitemo \bibitem[I]{•}R•
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bibitem \bibitem{I}R•
bibstyle \bibstyle \bibliographystyle{I}
biblio \bibliography{I}

\boxed{I}
\caption{I}R
\cdots

center \centering
\chapter{I}

chap \chapter{I}R
\cite{I}
\cline{I}
\date{I}R
\ddddot{I}
\dddot{I}
\ddots
\ddot{I}
\documentclass[I]{•}R
\documentclass{I}R
\dots
\dotsb
\dotsc
\dotsi
\dotsm
\dotso

emd \em
em \emph{I}

\end{I}R
\eqref{I}
\fboxrule{I}
\fboxsep{I}

fbox \fbox{I}
\footnotesize

foot \footnote{I}
frac \frac{I}{•}
fboxoo \fboxoo \framebox[I][•]{•}
fboxo \fboxo \framebox[I]{•}
hw \headwidth

\hlineR
\hspace*{I}
\hspace{I}

incgo \includegraphics[I]{•}R
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incg \includegraphics{I}R
\include{I}R
\input{I}R
\intertext{I}
\itemRI

ito \item[I]R•
itd \itshape
lbl \lbl \label{I}

\large
\Large

latex \latex \LaTeX
latexs \latexs \LaTeX\
latexe \latexe \LaTeXe
latexes \latexes \LaTeXe\

\ldots
\listfilesR

listf \listf \listoffiguresR
listt \listt \listoftablesR

\makeatletter
\makeatother

mboxoo \mboxoo \makebox[I][•]{•}
mboxo \mboxo \makebox[I]{•}
mpar \mpar \marginpar{I}
mbf \mbf \mathbf{I}
mcal \mcal \mathcal{I}
mit \mit \mathit{I}
mnorm \mnorm \mathnormal{I}
mrm \mrm \mathrm{I}
msf \msf \mathsf{I}
mtt \mtt \mathtt{I}
mbox \mbox{I}
mdd \mdseries
multc \multc \multicolumn{I}{•}{•}
multic \multicolumn{I}{•}{•}
nct \newcolumntype{I}{•}
newct \newcolumntype{I}{•}
ncmoo \newcommand{I}[•][•]{•}R
newcoo \newcommand{I}[•][•]{•}R
ncmo \newcommand{I}[•]{•}R
newco \newcommand{I}[•]{•}R
ncm \newcommand{I}{•}R
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newc \newcommand{I}{•}R
nenvoo \newenvironment{I}[•][•]{•}{•}R
neweoo \newenvironment{I}[•][•]{•}{•}R
nenvo \newenvironment{I}[•]{•}{•}R
neweo \newenvironment{I}[•]{•}{•}R
nenv \newenvironment{I}{•}{•}R
newe \newenvironment{I}{•}{•}R
newlen \newlength{I}R
nlen \newlength{I}R
newlin \newlineR
nline \newlineR
newpg \newpageR
npg \npg \newpageR

\newtheorem{I}[•]{•}R
\newtheorem{I}{•}R
\newtheorem{I}{•}[•]R
\nocite{I}
\normalsize
\pagebreakR

pgref \pageref{I}
pgs \pagestyle{I}R
pars \paragraph*{I}R
paro \paragraph[I]{•}R
par \paragraph{I}R
parboxo \parbox[I]{•}{•}
pboxo \pboxo \parbox[I]{•}{•}
parbox \parbox{I}{•}
pbox \pbox \parbox{I}{•}
rboxoo \rboxoo \raisebox{I}[•][•]{•}
rboxo \rboxo \raisebox{I}[•]{•}
rbox \rbox \raisebox{I}{•}
ref \ref{I}
rncmoo \renewcommand{I}[•][•]{•}R
rnewcoo \renewcommand{I}[•][•]{•}R
rncmo \renewcommand{I}[•]{•}R
rnewco \renewcommand{I}[•]{•}R
rncm \renewcommand{I}{•}R
rnewc \renewcommand{I}{•}R
rmc \rmfamily

\rule[I]{•}{•}
\rule{I}{•}
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scd \scshape
secs \section*{I}R
seco \section[I]{•}R
sec \section{I}R

\setlength{I}{•}
hw2tw \setlength{\headwidth}{\textwidth}R
sfd \sffamily
sld \slshape
sqrto \sqrto \sqrt[I]{•}
sqrt \sqrt \sqrt{I}
stcount \stepcounter{I}R
spars \spars \subparagraph*{I}
sparo \sparo \subparagraph[I]{•}
spar \spar \subparagraph{I}
ssecs \ssecs \subsection*{I}R
sseco \sseco \subsection[I]{•}R
ssec \ssec \subsection{I}R
sssecs \sssecs \subsubsection*{I}R

\ssseco \subsubsection[I][•]R
ssseco \subsubsection[I]{•}R
sssec \sssec \subsubsection{I}R
tableof-
contents

\tableofcontentsR

toc \toc \tableofcontentsR
tilde \tilde \textasciitilde
bf \bf \textbf{I}
— \textemdash\
– \textendash\
it \it \textit{I}

\rm \textrm{I}
sc \sc \textsc{I}
sf \sf \textsf{I}
sl \sl \textsl{I}
tt \tt \texttt{I}
up \up \textup{I}
tw \tw \textwidth

\text{I}
\thanks{I}R
\title{I}R

ttd \ttfamily
upd \upshape
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url \url{I}
usepo \usepackage[I]{•}R
usep \usepackage{I}R

\vdots
\vspace*{I}R
\vspace{I}R
{abstract}RIR\end{abstract}•
{align*}RIR\end{align*}•
{alignat*}{I}R•R\end{alignat*}•
{alignat}{I}R•R\end{alignat}•
{alignedat}{I}R•R\end{alignedat}•
{aligned}RIR\end{aligned}•
{aligned}[I]R•R\end{aligned}•
{align}RIR\end{align}•
{appendix}RIR\end{appendix}•
{array}RIR\end{array}•
{bmatrix}RIR\end{bmatrix}•
{cases}RIR\end{cases}•
{center}RIR\end{center}•
{compactenum}R\itemRIR\end{compactenum}•
{compactenum}[I]R\itemR•R\end{compactenum}•
{compactitem}R\itemRIR\end{compactitem}•
{compactitem}[I]R\itemR•R\end{compactitem}•
{description}R\item[I]R•R\end{description}•
{document}RRIRR\end{document}
{enumerate}R\itemRIR\end{enumerate}•
{enumerate}[I]R\itemR•R\end{enumerate}•
{eqnarray*}RIR\end{eqnarray*}•
{eqnarray}RIR\end{eqnarray}•
{equation}RIR\end{equation}•
{figure}RIR\end{figure}•
{figure}[I]R•R\end{figure}•
{flalign*}RIR\end{flalign*}•
{flalign}RIR\end{flalign}•
{flushleft}RIR\end{flushleft}•
{flushright}RIR\end{flushright}•
{gather*}RIR\end{gather*}•
{gathered}RIR\end{gathered}•
{gathered}[I]R•R\end{gathered}•
{gather}RIR\end{gather}•
{itemize}R\itemRIR\end{itemize}•
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{itemize}[I]R\itemR•R\end{itemize}•
{letter}{I}R•R\end{letter}•
{list}{I}{•}R\itemR•R\end{list}•
{minipage}[I]{•}R•R\end{minipage}•
{minipage}{I}R•R\end{minipage}•
{multline*}RIR\end{multline*}•
{multline}RIR\end{multline}•
{picture}RIR\end{picture}•
{pmatrix}RIR\end{pmatrix}•
{quotation}RIR\end{quotation}•
{quote}RIR\end{quote}•
{split}RIR\end{split}•
{subequations}RIR\end{subequations}•
{tabbing}RIR\end{tabbing}•
{table*}RIR\end{table*}•
{table*}[I]R•R\end{table*}•
{table}RIR\end{table}•
{table}[I]R•R\end{table}•
{tabular*}{I}{•}R•R\end{tabular*}•
{tabularx}{I}{•}R•R\end{tabularx}•
{tabular}{I}R•R\end{tabular}•
{thebibliography}RIR\end{thebibliography}•
{theindex}RIR\end{theindex}•
{theorem}RIR\end{theorem}•
{titlepage}RIR\end{titlepage}•
{trivlist}RIR\end{trivlist}•
{varwidth}{I}R•R\end{varwidth}•
{verbatim}RIR\end{verbatim}•
{verse}RIR\end{verse}•

Keywords defined in tw-latex-pkg.txt (defined by various packages):

\addbibresource{I}R
botr \bottomruleR

\citep{I}
\citet{I}

cmidr \cmidrule(I){•}
cmidro \cmidrule[I](•){•}

\enquote{I}
geometry \geometry{•}
href \href{I}{•}
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\midruleR
\printbibliographyR
\printbibliography[I]R

topr \topruleR
{compactenum}R\itemRIR\end{compactenum}•
{compactenum}[I]R\itemR•R\end{compactenum}•
{compactitem}R\itemRIR\end{compactitem}•
{compactitem}[I]R\itemR•R\end{compactitem}•
{tikzpicture}RIR\end{tikzpicture}•
{tikzpicture}[I]R•R\end{tikzpicture}•

Keywords defined in tw-beamer.txt (defined by the beamer package):

\action<I>{•}
\againframe<I>[•]{•}R
\againframe<I>{•}R
\againframe{I}R
\alert<I>{•}
\alert{I}
\alt<I>{•}{•}

bfrm \begin{frame}RIR\end{frame}•
\framesubtitle<I>{•}R
\framesubtitle{I}R
\frametitle<I>[•]{•}R
\frametitle{I}R
\framezoom<I><•>(•,•)(•,•)
\framezoom<I><•>[•](•,•)(•,•)
\includeonlyframes{I}R
\includeonlylecture{I}R
\invisible<I>{•}
\lecture{I}{•}R
\note<I>[•]{•}R
\note<I>{•}R
\note{I}R
\only<I>{•}
\onslide<I>{•}
\pauseR
\pause[I]R
\structure{I}R
\temporal<I>{•}{•}{•}
\uncover<I>{•}
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\usebeamercolor{I}R
\visible<I>{•}
{actionenv}<I>RR\end{actionenv}•
{alertenv}<I>RR\end{alertenv}•
{altenv}<I>{•}{•}{•}{•}RR\end{altenv}•
{beamercolorbox}[I]{•}RR\end{beamercolorbox}•
{beamercolorbox}{I}RR\end{beamercolorbox}•
{block}<I>{•}RR\end{block}•
{block}{I}RR\end{block}•
{columns}RIR\end{columns}•
{columns}[I]R•R\end{columns}•
{column}[I]{•}RR\end{column}•
{column}{I}RR\end{column}•
{frame}RIR\end{frame}•
{frame}[I]{•}RR\end{frame}•
{frame}{I}RR\end{frame}•
{onlyenv}<I>RR\end{onlyenv}•
{overlayarea}{I}{•}RR\end{overlayarea}•
{overprint}RIR\end{overprint}•
{structureenv}RIR\end{structureenv}•

Keywords defined in tw-context.txt (defined in ConTEXt):

\starttext
\stoptext

There are also environment codes (above) without \begin{ (which is itself
a keyword); this allows to finish the environment name alone by � if one
started to input it manually.



B
Regular expressions

As TEXworks is built on Qt4, the available regular expressions—which are
often referred to as regexp—are a subset of those found in Qt4. See the site
of Qt41 for more information. It is possible to find other information about
regexps on the net2 or from books. But pay attention that not all systems
(programming languages, editors, . . . ) use the same set of instructions; there
is no “standard set”, unfortunately.

B.1 Introduction
When searching and replacing, one has to define the text to be found. This
can be the text itself (e.g., “Abracadabra”), but often it is necessary to define
the strings in a more generic and powerful way to avoid repeating the same
operation many times with only small changes from one time to the next; if,
for example, one wants to replace sequences of the letter a by ones of the
letter o, but only those sequences of 3, 4, 5, 6 or 7 a; this would require
repeating (and slightly adjusting) the find and replace procedure 5 times.
Another example: replace all vowels by §—again, this would take 5 replace
operations. Here come the regular expressions!

A simple character (a or 9) represents itself. But a set of characters can
be defined: [aeiou] will match any vowel, [abcdef] the letters a, b, c, d, e,
and f ; this last set can be shortened as [a-f] using “-” between the two ends
of the range. This can even be combined: [a-zA-Z0-9] will match all letters
and all numbers.
1http://doc.trolltech.com/4.4/qregexp.html#details—this section is based on the

information provided there
2see, for example, Wikipedia
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To define a complementary set3, one uses “ˆ”: the caret negates the
character set if it occurs at the beginning, i.e., immediately after the opening
square bracket. [ˆabc] matches anything except a, b, c.

B.2 Codes to represent special sets
When using regexps, one very often has to create a search expession which
represents other strings in a generic way. If you are looking for a string that
matches email addresses, for example, the letters and symbols will vary; still,
you could search for any string which corresponds to the structure of an
email address (<text>@<text>.<text>, roughly). To facilitate this, there are
abbreviations to represent letters, figures, symbols, . . .

These codes replace and facilitate the definition of sets; for example, to
instead of manually defining the set of digits [0-9], one can use “\d”. The
following table lists the replacement codes.4

3A set of characters that are not allowed to occur for this regular expression to match the
text
4simplified from Qt4 at trolltech, see note 1
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Element Meaning
c Any character represents itself unless it has a special regexp

meaning. Thus c matches the character c.
\c A special character that follows a backslash matches the char-

acter itself except where mentioned below. For example, if you
wished to match a literal caret at the beginning of a string you
would write “\^”.

\n This matches the ASCII line feed character (LF, Unix newline,
used in TEXworks).

\r This matches the ASCII carriage return character (CR).
\t This matches the ASCII horizontal tab character (HT).
\v This matches the ASCII vertical tab character (VT; almost

never used).
\xhhhh This matches the Unicode character corresponding to the hex-

adecimal number hhhh (between 0x0000 and 0xFFFF). \0ooo
(i.e., zero-ooo) matches the ASCII/Latin-1 character correspond-
ing to the octal number ooo (between 0 and 0377).

. (dot) This matches any character (including newline). So if you want
to match the dot character iteself, you have to escape it with
“\.”.

\d This matches a digit.
\D This matches a non-digit.
\s This matches a white space.
\S This matches a non-white space.
\w This matches a word character or “_”).
\W This matches a non-word character.
\1, . . . The n-th back-reference, e.g. \1, \2, etc.; used in the replace-

ment string with capturing patterns—see below
Using these abbreviations is better than describing the set, because the

abbreviations remain valid in different alphabets.
Pay attention that the end of line is often taken as a white space. Under

TEXworks the end of line is referred to by “\n”.

B.3 Repetition
One doesn’t work only on single letters, digits, symbols; most of the time,
these are repeated (e.g., a number is a repetition of digits and symbols—in
the right order).
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To show the number of repetitions, one uses a so called “quantifier”:
a{1,1} means at least one and only one a, a{3,7} means between at least 3
and at most 7 a; {1,1} is redundant, of course, so a{1,1} = a.

This can be combined with the set notation: [0-9]{1,2} will correspond
to at least one digit and at most two, the integer numbers between 0 and 99.
But this will match any group of 1 or 2 digits within any arbitrary string
(which may have a lot of text before and after the integer); if we want this
to match only if the whole string consists entirely of 1 or 2 digits (without
any other characters preceding or following them), we can rewrite the regular
expression to read ˆ[0-9]{1,2}$; here, the ˆ specifies that any match must
start at the first character of the string, while the $ says that any matching
substring must end at the last character of the string, so the string can only
be comprised of one or two digits (ˆ and $ are so-called “assertions”—more
on them later).

Here is a table of quantifiers.5 E represents an arbitrary expression (letter,
abbreviation, set).

E{n,m} Matches at least n occurrences of the expression and at most
m occurrences of the expression.

E{n} Matches exactly n occurrences of the expression. This is the
same E{n,n} or as repeating the expression n times.

E{n,} Matches at least n occurrences of the expression.
E{,m} Matches at most m occurrences of the expression.
E? Matches zero or one occurrence of E. This quantifier effectively

means the expression is optional (it may be present, but doesn’t
have to). It is the same as E{0,1}.

E+ Matches one or more occurrences of E. This is the same as
E{1,}.

E* Matches zero or more occurrences of E. This is the same as
E{0,}. Beware, the * quantifier is often used by mistake instead
of the + quantifier. Since it matches zero or more occurrences,
it will match even if the expression is not present in the string.

B.4 Alternatives and assertions
When searching, it is often necessary to search for alternatives, e.g., apple,
pear, or cherry, but not pineapple. To separate the alternatives, one uses |:
apple|pear|cherry. But this will not prevent to find pineapple, so we have to
5simplified from Qt4 at trolltech, see note 1
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specify that apple should be standalone, a whole word (as is often called in
the search dialog boxes).

To specify that a string should be considered standalone, we specify
that it is surrounded by word separators/boundaries (begin/end of sentence,
space), like \bapple\b. For our alternatives example we will group them
by parentheses and add the boundaries \b(apple|pear|cherry)\b. Apart
from \b we have already seen ˆ and $ which mark the boundaries of the
whole string.

Here a table of the “assertions” which do not correspond to actual charac-
ters and will never be part of the result of a search. 6

^ The caret signifies the beginning of the string. If you wish to
match a literal ˆ, you must escape it by writing \^

$ The dollar signifies the end of the string. If you wish to match
a literal $, you must escape it by writing \$

\b A word boundary.
\B A non-word boundary. This assertion is true wherever \b is

false.
(?=E) Positive lookahead. This assertion is true if the expression E

matches at this point.
(?!E) Negative lookahead. This assertion is true if the expression E

does not match at this point.
Notice the different meanings of ˆ as assertion and as negation inside a

character set!

B.5 Final notes
Using rexexp is very powerful, but also quite dangerous; you could change
your text at unseen places and sometimes reverting to the previous situation is
not possible entirely. If you immediately see the error, you can try Ctrl Z .

Showing how to exploit the full power of regexp would require much more
than this extremely short summary; in fact it would require a full manual on
it own.

Also note that there are some limits in the implementation of regexps in
TEXworks; in particular, the assertions (ˆ and $) only consider the whole file,
and there are no look-behind assertions.

Finally, do not forget to “tick” the regexp option when using them in the
Find and Replace dialogs and to un-tick the option when not using regexps.

6simplified from Qt4 at trolltech, see note 1



C
Compiling TEXworks

A complete guide how to compile TEXworks is far beyond the scope of this
manual. However, most users should find precompiled versions suitable for
their system come either with their TEX distribution or their operating system.
If this is not the case, several precompiled versions can also be downloaded
from http://www.tug.org/texworks/.

Compiling TEXworks yourself is only necessary if your system is not (yet)
supported, if you want to always have the latest features (and bugs), or
generally want to help in improving TEXworks further. To this end, there are
some documents giving detailed instructions to compile TEXworks on different
machines.

https://github.com/TeXworks/texworks/wiki/Building

https://github.com/TeXworks/texworks/wiki/Building-on-Mac-
OS-X-(Homebrew)

https://github.com/TeXworks/texworks/wiki/Building-on-
Windows-(MinGW)
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font, 15
encoding, 26

latin1, 25
utf-8, 11, 25

errors, 12
extension .tex, 10

files
format, 1

folder
〈resources〉, 7
.TeXworks, 7
.config/TUG, 7
auto-completion, 6
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dictionaries, 6
resource, 6
resource Mac, 7
templates, 6
TeXworks, 6
translations, 6

installation, 5
Linux, 6
Mac, 7
Portable Usage, 29
Windows, 6
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keyboard shortcuts, 38
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predefined, 39
shortcuts.ini, 38

Knuth, Donald E., 1
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log, 10

METAFONT, 1
METAPOST, 2

output panel, 10

hide, 14

packages, 1, 11
PDF, 2
Portable Usage, 29
PostScript, 2
preamble, 11
preferences, 15
preview, 8
preview window, 10
programme

default, 26
project, 16

regular expressions, 19, 57
alternatives/assertions, 60
introduction, 57
repetition, 59
sets, 58

scripts, 31
installing, 32
managing, 33
using, 33
writing, 31

search/replace, see editing
shortcuts, see keyboard shortcuts
source/editor, 8
spell-checking, 17

.aff files, 18

.dic files, 18
SyncTeX, 25
syntax highlighting, 36

tags, 28
structure, 28
table of contents, 28

template, 16
TEX, 1

AMS-TEX, 1
ConTEXt, 1
LATEX, 1, 9
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distribution, see TEX distribu-
tion

dvips, 2
LuaTeX, 2
pdftex, 2
XeTeX, 2

TEX
Plain, 1

TEX distribution, 5
Linux, 5
Mac, 5

MacTeX, 5
TeX Live, 5
Windows, 5

MikTeX, 5
TEXShop, 3
TEXworks, 2

parameters, 15
toolbar, 8
typeset, 8
typing cursor, 13

utf-8, see encoding, utf-8

weird characters, see encoding
windows, 28
wrap lines

automatic, 27
hard, 27

WYSIWYG, 8

zoom, 28
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