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Abstract

This document describes how to use sapthesis.cls, a LATEX document
class for the typesetting of the theses of the “Sapienza – University of Rome”.
The official web page of sapthesis is
http://biccari.altervista.org/c/informatica/latex/sapthesis.php.
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1 Introduction

After several years in my faculty I noticed that usually students spend a lot of
time to refine the aesthetic aspect of their LATEX documents instead of focusing on
the content. This is against the philosophy of LATEX, which was created to relieve
the writer from the typesetter’s work. Apart from the time spent, the resulting
documents are obviously all different from each other and good aesthetic results
are not always achieved. This has a negative impact both on the student’s work and
on the university. Moreover in 2007 the Sapienza university changed completely its
logo and a lot of strict graphic rules for official documents were introduced.1

For these reasons I thought that a LATEX class for the theses of my university
would have been a good idea. Sapthesis is the result of my work. To give a look to
a document composed by sapthesis class see the file sapthesis-example.pdf.
In that file the page layout and the layout choices are explained. Sapthesis is
released under the terms of the latest version of the LATEX Project Public License.

I would thank the Italian TEX user group (GuIT) for the help provided, in
particular Enrico Gregorio. I would thank also (alphabetically) Claudio Beccari,
Davide Di Bucchianico, Gabriele Di Segni, Matteo Ipri, Giovanni Nuccetelli,
Davide Paltrinieri, Francesco Pannarale and Matteo Siccardi.

2 Requirements and installation

The simplest way to install sapthesis is by the package manager of your TEX
distribution (TEX Live or MiKTEX). For manual installation see the README file.

The sapthesis package provides: the sapthesis.cls class file; the documen-
tation sapthesis-doc.pdf (this file) and its source code; the logos of Sapienza
university; sapthesis-example.pdf, an usage example of the class and its source
code; an English BibTEX style, called sapthesis.bst, which can be used, obvi-
ously, only if you use the BibTEX way to compose your bibliography and if your
thesis is written in English (its usage is not mandatory).

Sapthesis explicitely loads the packages xkeyval, geometry, ifxetex, xltx-
tra, fontenc, textcomp, lmodern, caption, graphicx, color, booktabs, amsmath,
fancyhdr. Do not include these packages in the preamble of your document!

1A thesis is not an official document and therefore these guidelines can not be applied (private
communication with Laura Gobbo, Ufficio Stampa e Comunicazione Sapienza – Università di Roma).
However some Microsoft Word templates, with a completely different style, are provided. To give a
look to the new Sapienza style see Identità visiva.
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3 Usage

A LATEX document based on sapthesis can be compiled only by the commands
pdflatex and xelatex. In this manual only pdflatex will be considered.

As usual, in order to use this class, you need to call it by� �
\documentclass[options]{sapthesis}� �
You have to specify the class options for your case (see Sec. 3.1). Then you have to
provide some fundamental information (title, author, etc. . . ) by specific commands
(see Sec. 3.2). Finally remember to follow a source code structure similar to those
of the examples given in App. A and B. Especially the usage of the commands
\frontmatter, \mainmatter and \backmatter is mandatory, otherwise the
page style of the document will be wrong!

This class supports, at the moment, two languages: Italian and English. En-
glish is the default. If your thesis contains only English or very few paragraphs
in another language, do not use the babel package because completely useless.
Instead, if you write in italian, load the babel package with the italian option:
\usepackage[italian]{babel}.

3.1 Class options

The following options can be passed in the documentclass command.

PhD Option to typeset a Dottorato di Ricerca (PhD) thesis.

LaM Option to typeset a Laurea Magistrale (Master’s degree) thesis.

Lau Option to typeset a Laurea (Bachelor’s degree) thesis.

MasterP Option to typeset a thesis for a Master di primo livello (First level master).

MasterS Option to typeset a thesis for a Master di secondo livello (Second level
master).

draft The usual draft option of the LATEX Standard Classes.

oneside The usual oneside option of the LATEX Standard Classes.

twoside (default) The usual twoside option of the LATEX Standard Classes.
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bn This option typesets the title page in black and white (using the b/w logo,
sapienza-MLblack-pos.pdf, instead of the colored one) and passes the
monochrome option to color and xcolor packages.

binding=length (zero default binding) The value of this option is an offset of
the text column. It is useful to take into account the margin for the binding
(ask to your bookbinder for information).

noexaminfo Remove the final exam informations.

italian or english Explicitly declare the language of the title page. Useful
when you want to write the title page in a language and the thesis in a
different language.

nodefaultfont Avoid the loading of packages fontenc, textcomp and lmodern.

romandiff See App. C.

fem Use the feminine (only Italian): “candidata” instead of “candidato”.

3.2 Commands for the title page

As usual, the title page is generated by the \maketitle command. It needs some
information that you can supply by the following commands in the preamble of the
document.

\title{...} Mandatory.

\author{...} Mandatory

\IDnumber{...} Mandatory. Your ID number (matricola in Italian)

\course[...]{...} Mandatory. Use the official Italian name of the course. The
optional argument specifies the course name in another language, which is
needed in the case of PhD’s theses because of the “requirements” declaration.

\courseorganizer{...} Mandatory.

\cycle{...} Mandatory only for PhD’s. Use the form: \cycle{XXII}

\submitdate{...} Mandatory. Use the form \submitdate{April 2009} for
PhD’s and the form \submitdate{2009/2010} for Laurea theses.
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\copyyear{...} Mandatory. Copyright year (usually the graduation year).

\advisor{...} You must specify at least one advisor. If you have more than one
advisor, put several advisor commands in the correct order:
\advisor{Prof. Pippo} \advisor{Dr. Pluto}

\coadvisor{...} Optional. Co-advisors of the thesis. Same syntax of the
\advisor command.

\authoremail{...} Mandatory. Email of the thesis author. It is automatically
hyper-linked if hyperref package is loaded.

\examdate{...} Optional. Date of the final exam. Use the form
\examdate{16 February 2010}.

\examiner{...} Optional. Specifies the members of the board of examiners of
the final exam. Usage similar to \advisor command.

\versiondate{...} Optional. Date version of the thesis.

\website{...} Optional. Thesis website. Automatically hyper-linked if hyper-
ref package is loaded.

\ISBN{...} Optional. ISBN

3.3 Other commands and environments

\dedication{...} A command to compose the dedication.

abstract An environment to compose the abstract of your document. This envi-
ronment has an optional parameter to choose the title of the abstract section.
If you use a language for the abstract different from that of the thesis, consider
the \selectlanguage{...} command provided by the babel package.

acknowledgments An environment to compose the acknowledgments of your
document. This environment has an optional parameter to choose the title
of the acknowledgments section. If you use a language for the acknowledg-
ments different from that of the thesis, consider the \selectlanguage{...}
command provided by the babel package.

The sapthesis class defines also the color sapred which is the Sapienza red:
RGB(130,36,51). This color is switched to black if the bn option is in use. Example
of usage: ...\textcolor{sapred}{blah blah blah}...
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4 Recommendations

• Do not change the default layout and do not use packages which can modify
the layout of your thesis.

• Do not load the following packages in the preamble of your document
because already loaded by sapthesis: xkeyval, geometry, ifxetex, xltxtra,
fontenc, textcomp, lmodern, caption, graphicx, color, booktabs, amsmath,
fancyhdr.

• As you already should know, LATEX can process only documents in pure
ASCII. If you want to insert directly other characters, not included in the 128
ASCII characters (for example accented letters), you have to use a particular
text encoding for your source file. Then you have to “tell” to LATEX which
encoding you have chosen by the packages inputenc or inputenx.

However, if your thesis is in English, I suggest to avoid the use of a particular
text encoding for the source code because you will insert non ASCII charac-
ters very seldom. For this reason it is better to write these characters by the
usage of the LATEX commands (for example \'e for the é letter), avoiding to
load inputenc or inputenx package. This has another advantage, in fact
your source file will be very portable.

• Respect the following thesis structure:

– Title page (\maketitle command)

– Dedication (\dedication command)

– Abstract (abstract environment)

– Acknowledgements (acknowledgments environment)

– Table of contents (\tableofcontens command)

– Chapters

– Appendices

– Bibliography

• It is recommended to avoid or limit the acknowledgments in a thesis, it is not
very professional. The dedication should be enough.
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• Do not put any preface in your thesis. The preface should be written only by
an eminent expert in the field to comment exceptionally important results of
the student.

• Usually tables and figures are centered. Remember that, according to the ty-
pographic rules, the table captions should be placed above the table, whereas
the figure caption should be placed below the figure.

• If the figure has a small width, it is possible to put the figure caption aside
the figure using the sidecap package (not preloaded in sapthesis.cls).

• Avoid the use of colors unless really necessary. Remember that the figures
should be readable even if they are printed in gray scale!

• Subscripts and superscripts should be in italic if they represent variable
quantities, whereas should be in roman if they are simply labels.

• The name of operators should be typed in roman. Example: use sin ($\sin$)
instead of sin ($sin$).

• The margin notes are rarely used in scientific documents and should not be
used in a thesis.

• Do not divide the bibliography per chapter unless it is really necessary. This
will save you from wasting a lot of time to prepare your LATEX source code.
Order your bibliography alphabetically according to the first author surname:
this order is very useful, contrary to the other typical order, the citation order.
In this regard I recommend the usage of the backref package.

References
Many people want to (or are compelled to) write in LATEX without studying a basic
manual. Here follows a brief list of documents, especially useful for italian students.

[1] L. Pantieri & T. Gordini, L’arte di scrivere con LATEX, (2011)

[2] S. Pakin, The comprehensive LATEX symbol list, (2009)

[3] E. Gregorio, LATEX: breve guida ai pacchetti di uso più comune, (2010)
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A PhD thesis example� �
\documentclass[binding=0.6cm,PhD]{sapthesis}

\usepackage{microtype}
\usepackage{hyperref}
\hypersetup{pdftitle={My thesis},pdfauthor={Francesco Biccari}}

\title{My thesis}
\author{Francesco Biccari}
\IDnumber{123456}
\course[Philology]{Filologia}
\courseorganizer{Scuola di Dottorato in Scienze Filologiche}
\cycle{XXII}
\submitdate{October 2009}
\copyyear{2009}
\advisor{Prof. Caio}
\advisor{Dr. Sempronio}
\authoremail{pippo@pippo.com}

\begin{document}

\frontmatter
\maketitle
\dedication{Dedicated to\\ Donald Knuth}

\begin{abstract}
This thesis deals with myself.
\end{abstract}

\tableofcontents

\mainmatter
\chapter{Introduction}
...

\backmatter
\cleardoublepage
\phantomsection % Give this command only if hyperref is loaded
\addcontentsline{toc}{chapter}{\bibname}
% Here put the code for the bibliography. You can use BibTeX or
% the BibLaTeX package or the simple environment thebibliography.

\end{document}� �
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B Laurea (Magistrale) thesis example� �
\documentclass[binding=0.6cm,Lau]{sapthesis} % LaM for a Laurea Magistrale

\usepackage{microtype}
\usepackage[italian]{babel}
\usepackage[utf8]{inputenx}
\usepackage{hyperref}
\hypersetup{pdftitle={La mia tesi},pdfauthor={Francesco Biccari}}

\title{La mia tesi}
\author{Francesco Biccari}
\IDnumber{123456}
\course{Fisica}
\courseorganizer{Facoltà di Scienze Matematiche, Fisiche e Naturali}
\submitdate{2011/2012}
\copyyear{2012}
\advisor{Prof. Caio}
\advisor{Dr. Sempronio}
\authoremail{pippo@pippo.com}

\begin{document}

\frontmatter
\maketitle
\dedication{Dedicato a\\ Donald Knuth}

\begin{abstract}
Questa tesi parla di me.
\end{abstract}

\tableofcontents

\mainmatter
\chapter{Introduzione}
...

\backmatter
\cleardoublepage
\phantomsection % Give this command only if hyperref is loaded
\addcontentsline{toc}{chapter}{\bibname}
% Here put the code for the bibliography. You can use BibTeX or
% the BibLaTeX package or the simple environment thebibliography.

\end{document}� �
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C Other useful commands

\eu Napier’s number, e, in roman.

\iu Imaginary unit, i, in roman.

\der[...]{...}{...} Derivative. The optional parameter is the order of the
derivative. The following two arguments are the numerator and the denomi-
nator. The differential symbol is automatically inserted.

\pder[...]{...}{...} Partial derivative. Same as above

\rb{...} Roman suBscript

\rp{...} Roman suPerscript

\tb{...} Text suBscript

\tp{...} Text suPerscript

\un{...} Useful command to typeset measurement units in the correct way, e.g.
25\un{m/s}, 13\un{kg\,cmˆ{-3}}. It can be used both inside or outside
the math environment. For heavy usage of measurement units and to insert
numbers in the form 1.4e-5, the package siunitx is recommended.

\mnote{...} Fancy margin notes

\g Shortcut for the \degree command. Example: 45\g produces 45°.

\C Shortcut for the \celsius command. Example: 37\,\C produces 37 °C. (Not
available in math mode compiling with xelatex).

\A Angstrom. Example: 10\,\A produces 10 Å.

\micro Micro prefix. Example: 7\,\micro m produces 7 µm.

\ohm Ohm. Example: 100\,\ohm produces 100Ω.

\di Differential symbol with automatic spacing.
Example: $\int x \di x$ produces

∫
x dx. If you prefer the differential

symbol in roman (d) you can give the option romandiff in the document
class options.

\x Shortcut for the \times command. E.g.: $7 \x 10ˆ5$ produces 7 × 105.
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D A very brief introduction to the TEX world

TEX, the document preparation system designed by Donald Knuth in 1978, is a
program to typeset documents. It is a mark-up macro language: you write a source
code decorated with TEX commands, which is then compiled to obtain the final
product, a document in pdf format in our case. LATEX is just a set of macros written
in TEX to simplify the writing of the source code: you can think about it as a simpler
programming language with respect to TEX. A source code written in LATEX can be
compiled by several “compilers’: pdflatex (the most common), or xelatex, or
others. The following list of LATEX manuals, may be especially useful for Italian
authors.

• L. Pantieri & T. Gordini, L’arte di scrivere con LATEX, (2012)

• S. Pakin, The comprehensive LATEX symbol list, (2009)

• E. Gregorio, LATEX: breve guida ai pacchetti di uso più comune, (2010)

In order to use LATEX, you have to install a TEX distribution. It contains the
compilers, several fonts and other files needed by the compilers and also many
packages, which can be thought as libraries or extensions of LATEX. The most famous
distributions are MiKTeX (available only for Windows), TeX Live (available both
for Windows and Linux) and MacTeX (available only for Mac OS).

Finally we will discuss about the editor, that is the program used to write your
source code. Since a source code written in LATEX, like in any other programming
language, is a simple text file, you can write your code with any text editor you
want (for example Notepad in Windows). However the suggested editors are:

• TeXworks. Already installed with any TEX distribution. Very simple and
powerful. Use TeXworks if you are not an expert. Enrico Gregorio has
written a very good and brief TeXworks manual in Italian, which can be
found at this page: http://profs.sci.univr.it/~gregorio/egtex.html.

• TeXstudio (cross-platform), TeXmaker (cross-platform), TeXshop (only for
Mac), Kile (only for Linux). Powerful editors. Not for beginners.

• Avoid other editors unless you know what you are doing! (For example do
not use TeXnicCenter!)
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Now we will explain how to compile the example document provided in the
sapthesis package. Double click on the file sapthesis-example.tex. TeX-
works should start showing the source code. The pdflatex compiler should be
automatically selected thanks to the magic lines placed at the beginning of the file.
Now in order to compile press the green button. At the end of the compilation the
resulting pdf appears in a separate window. Remember to compile at least three
times, because LATEX needs more than one compilation to correctly resolve the
internal cross references (for example for the table of contents composition, or
when you refer to a figure by the \label \ref mechanism).

E Using LyX

LyX is an advanced LATEX editor which does not simply show the source code like
any text editor, but instead it renders maths, images, tables and some text formatting
commands. However this “layer” between the writer and the real source code is
sometimes frustrating and many authors discourage the usage of LyX.

Using sapthesis with LyX is quite straightforward.

• Install sapthesis by the package manager of your TEX distribution or manu-
ally.

• First of all go in Tools > Preferences > Language Settings > Language
and choose "none" in Language package. This step is necessary because LyX
not only loads babel with the desired language, but it passes the language
also as an option for the class! This triggers an error in many classes.

• Go in View > View Source. This step is not necessary but it is very useful
to observe the LATEX code produced by LyX (on the right choose “Complete
source”).

• Copy the file sapthesis.layout in the directory
C:\Program Files\Lyx20\Resources\layouts\
and then click on Tools > Reconfigure.

Now you are ready to use sapthesis. Create a new document and go in
Document > Settings > Document Class. Here you can choose sapthesis as the
class for the document and write the class options. Then you have to write the
preamble of the document in Document > Settings > LaTeX Preamble.
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