summaryrefslogtreecommitdiff
path: root/Master/texmf-dist/source/latex/urlbst/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'Master/texmf-dist/source/latex/urlbst/configure.ac')
-rw-r--r--Master/texmf-dist/source/latex/urlbst/configure.ac86
1 files changed, 86 insertions, 0 deletions
diff --git a/Master/texmf-dist/source/latex/urlbst/configure.ac b/Master/texmf-dist/source/latex/urlbst/configure.ac
new file mode 100644
index 00000000000..cd41ab186c1
--- /dev/null
+++ b/Master/texmf-dist/source/latex/urlbst/configure.ac
@@ -0,0 +1,86 @@
+dnl Process this file with autoconf to produce a configure script
+AC_REVISION($Revision: 1.16 $)
+
+AC_INIT(urlbst, 0.6-1, norman@astro.gla.ac.uk)
+RELEASEDATE="2008 June 16"
+AC_SUBST(RELEASEDATE)
+
+AC_PREREQ(2.50)
+
+AC_CONFIG_SRCDIR([urlbst.in])
+
+AC_PATH_PROG(PERL, perl)
+
+
+dnl Add --with-eprints: tune default support for eprints
+WITHEPRINTS=0
+AC_SUBST(WITHEPRINTS)
+EPRINTURL=http://arxiv.org/abs/
+AC_SUBST(EPRINTURL)
+
+dnl Add --with-doi: tune default support for DOI fields
+WITHDOIRESOLVER=0
+AC_SUBST(WITHDOIRESOLVER)
+DOIURL=http://dx.doi.org/
+AC_SUBST(DOIURL)
+
+dnl Add --with-pubmed
+WITHPUBMEDRESOLVER=0
+AC_SUBST(WITHPUBMEDRESOLVER)
+PUBMEDURL=http://www.ncbi.nlm.nih.gov/pubmed/
+AC_SUBST(PUBMEDURL)
+
+AC_ARG_WITH(eprints,
+[ --with-eprints[[=url]] Include eprint support by default, giving optional URL],
+ if test "$withval" = "yes"; then
+ WITHEPRINTS=1
+ elif test "$withval" = "no"; then
+ WITHEPRINTS=0
+ else
+ WITHEPRINTS=1
+ EPRINTURL=$withval
+ fi)
+
+AC_ARG_WITH(doi,
+[ --with-doi=[[=url]] Include support for a DOI resolver by default, giving optional URL],
+ if test "$withval" = yes; then
+ WITHDOIRESOLVER=1
+ elif test "$withval" = no; then
+ WITHDOIRESOLVER=0
+ else
+ WITHDOIRESOLVER=1
+ DOIURL=$withval
+ fi)
+
+AC_ARG_WITH(pubmed,
+[ --with-pubmed=[[=url]] Include support for a PUBMED resolver by default, giving optional URL],
+ if test "$withval" = yes; then
+ WITHPUBMEDRESOLVER=1
+ elif test "$withval" = no; then
+ WITHPUBMEDRESOLVER=0
+ else
+ WITHPUBMEDRESOLVER=1
+ PUBMEDURL=$withval
+ fi)
+
+
+dnl Add --with-href: set default support for hyperlinks
+dnl Default is to have no hyperlinks
+WITHHREF=0
+AC_SUBST(WITHHREF)
+
+AC_ARG_WITH(href,
+[ --with-href[[=int]] Include eprint hyperlinks (0/1/2=none/hypertex/hyperref)],
+ if test "$withval" = yes; then
+ WITHHREF=2
+ elif test "$withval" = no; then
+ WITHHREF=0
+ else
+ WITHHREF=$withval
+ fi)
+
+
+AC_CONFIG_FILES(Makefile urlbst.tex urlbst.html)
+AC_CONFIG_FILES(urlbst, [chmod +x urlbst])
+
+AC_OUTPUT