summaryrefslogtreecommitdiff
path: root/Build/source/utils/xindy/xindy-src/make-rules/alphabets/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Build/source/utils/xindy/xindy-src/make-rules/alphabets/Makefile.am')
-rw-r--r--Build/source/utils/xindy/xindy-src/make-rules/alphabets/Makefile.am7
1 files changed, 4 insertions, 3 deletions
diff --git a/Build/source/utils/xindy/xindy-src/make-rules/alphabets/Makefile.am b/Build/source/utils/xindy/xindy-src/make-rules/alphabets/Makefile.am
index 63060b28839..abe84581faa 100644
--- a/Build/source/utils/xindy/xindy-src/make-rules/alphabets/Makefile.am
+++ b/Build/source/utils/xindy/xindy-src/make-rules/alphabets/Makefile.am
@@ -246,7 +246,9 @@ DOCS = $(DOCS_CPS) $(DOCS_LAT) $(DOCS_CYR) $(DOCS_OTHER) $(DOCS_UTF8)
alphabets-inc.tex : $(DOCS)
$(RM) $@
- echo '\chapter{Latin scripts}' >>$@
+# zsh, dash, others make echo '\f' output a form feed. Likewise they
+# interpret \c (no further output). Sigh.
+ printf '\%s{Latin scripts}' "chapter" >>$@
echo '\ienc{cp1252}' >>$@
echo '\section{Codepage 1252}' >>$@
for i in $(DOCS_CP1252); do echo "\\input{$$i}" >>$@; done
@@ -275,9 +277,8 @@ alphabets-inc.tex : $(DOCS)
echo '\section{Codepage latin9}' >>$@
for i in $(DOCS_LATIN9); do echo "\\input{$$i}" >>$@; done
echo '\ienc{cp1251}' >>$@
-# zsh, dash, others make echo '\f' output a form feed. Sigh.
printf '\%s{T2A}\n' "fenc" >>$@
- echo '\chapter{Cyrillic scripts}' >>$@
+ printf '\%s{Cyrillic scripts}' "chapter" >>$@
echo '\section{Codepage 1251}' >>$@
for i in $(DOCS_CYR_1251); do echo "\\input{$$i}" >>$@; done
# echo '\ienc{iso-8859-7}' >>$@