summaryrefslogtreecommitdiff
path: root/Build/source/utils/xindy/xindy-2.4/user-commands/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Build/source/utils/xindy/xindy-2.4/user-commands/Makefile.am')
-rw-r--r--Build/source/utils/xindy/xindy-2.4/user-commands/Makefile.am81
1 files changed, 81 insertions, 0 deletions
diff --git a/Build/source/utils/xindy/xindy-2.4/user-commands/Makefile.am b/Build/source/utils/xindy/xindy-2.4/user-commands/Makefile.am
new file mode 100644
index 00000000000..09ba93a87ee
--- /dev/null
+++ b/Build/source/utils/xindy/xindy-2.4/user-commands/Makefile.am
@@ -0,0 +1,81 @@
+## Use `autoreconf' in top-level directory to recreate all
+## autoconf/automake files.
+## Or, call `automake Makefile' to create only Makefile.in.
+
+## Copyright (C) 2004-2005 by Gour.
+## Copyright (C) 2008 by Joachim Schrod.
+##
+## This program is free software; you can redistribute it and/or
+## modify it under the terms of the GNU General Public License as
+## published by the Free Software Foundation; either version 2 of the
+## License, or (at your option) any later version.
+##
+## This program is distributed in the hope that it will be useful, but
+## WITHOUT ANY WARRANTY; without even the implied warranty of
+## MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+## General Public License for more details.
+##
+## You should have received a copy of the GNU General Public License
+## along with this program in the file COPYING; if not, write to the
+## Free Software Foundation, Inc., 51 Franklin Street, Fifth Floor,
+## Boston, MA 02110-1301 USA.
+
+scripts = texindy xindy
+
+bin_SCRIPTS =
+
+if TEXLIVE_BUILD
+
+noinst_SCRIPTS = $(scripts)
+
+scriptspath = texmf/scripts/xindy
+scriptsdir = ${prefix}/$(scriptspath)
+install-exec-hook:
+ $(MKDIR_P) "$(DESTDIR)$(scriptsdir)"
+ @for f in $(scripts); do \
+ $(INSTALL_SCRIPT) $$f "$(DESTDIR)$(scriptsdir)/$$f.pl"; \
+ done
+ case "$(bindir)" in \
+ */bin) $(MAKE) $(AM_MAKEFLAGS) REL=.. install-links;; \
+ */bin/*) $(MAKE) $(AM_MAKEFLAGS) REL=../.. install-links;; \
+ *) echo "strange directory '$(bindir)' for linked scripts" >&2; \
+ exit 1;; \
+ esac
+.PHONY: install-links
+install-links:
+ @cd "$(DESTDIR)$(bindir)" && \
+ for f in $(scripts); do \
+ rm -f $$f; \
+ echo "creating link '$$f' -> '$(REL)/$(scriptspath)/$$f.pl'"; \
+ $(LN_S) $(REL)/$(scriptspath)/$$f.pl $$f || exit 1; \
+ done
+uninstall-hook:
+ @for f in $(scripts); do \
+ rm -f "$(DESTDIR)$(bindir)/$$f"; \
+ rm -f "$(DESTDIR)$(scriptsdir)/$$f.pl"; \
+ done
+
+sed_cmd = sed -e 's:@is_TL\@:yes:'
+
+else !TEXLIVE_BUILD
+
+bin_SCRIPTS += $(scripts)
+
+sed_cmd = sed -e 's:@libdir\@:$(libdir):'
+
+endif !TEXLIVE_BUILD
+
+texindy: texindy.in Makefile
+ $(sed_cmd) $(srcdir)/$@.in >$@
+ chmod +x $@
+
+xindy: xindy.in Makefile
+ $(sed_cmd) $(srcdir)/$@.in >$@
+ chmod +x $@
+
+man_MANS = texindy.1 xindy.1
+
+EXTRA_DIST = $(man_MANS) texindy.in xindy.in
+
+CLEANFILES = $(scripts)
+