summaryrefslogtreecommitdiff
path: root/Build/source/utils/xindy-new/xindy/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Build/source/utils/xindy-new/xindy/src/Makefile.am')
-rw-r--r--Build/source/utils/xindy-new/xindy/src/Makefile.am16
1 files changed, 9 insertions, 7 deletions
diff --git a/Build/source/utils/xindy-new/xindy/src/Makefile.am b/Build/source/utils/xindy-new/xindy/src/Makefile.am
index 7797540cf6f..d7aac1f3854 100644
--- a/Build/source/utils/xindy-new/xindy/src/Makefile.am
+++ b/Build/source/utils/xindy-new/xindy/src/Makefile.am
@@ -23,15 +23,15 @@
# Where the modules are found at runtime.
MODULEDIR = $(pkglibdir)/modules
-# Since automake has no CLISP support, we need to explicitly add make
-# rules to create the xindy kernel below and stop automake from
-# looking for C sources.
+
+# Automake has no CLISP support; moreover xindy.mem is not a binary
+# to be stripped upon 'make install-strip'. We define it as DATA.
mem_DATA = xindy.mem
# Tell the dist target about our sources, define the object files for
# our own rule and the .lib files for the clean definition. Don't use
# gmake-isms.
-dist_xindy_mem_sources = base.lsp ordrules.lsp locref.lsp idxstyle.lsp \
+FASSRC = base.lsp ordrules.lsp locref.lsp idxstyle.lsp \
index.lsp version.lsp markup.lsp
FAS = base.fas ordrules.fas locref.fas idxstyle.fas \
index.fas version.fas markup.fas
@@ -46,13 +46,15 @@ CLISP = @CLISP@ -q -E iso-8859-1
xindy.mem: $(DEFAULTS) $(FAS) $(DUMP_XINDY)
rm -f $(MEMFILE)
$(CLISP) $(srcdir)/$(DUMP_XINDY)
- gzip $(MEMFILE)
- mv $(MEMFILE).gz $(MEMFILE)
+ if test "$(host_os)" != "mingw32"; then \
+ gzip -9n $@; \
+ mv $@.gz $@; \
+ fi
$(DEFAULTS): $(DEFAULTS).in Makefile
sed 's|@MODULEDIR[@]|$(MODULEDIR)|g' <$(srcdir)/$(DEFAULTS).in >$(DEFAULTS)
-EXTRA_DIST = $(DEFAULTS).in $(dist_xindy_mem_sources) dump-xindy.lsp
+EXTRA_DIST = $(DEFAULTS).in $(FASSRC) dump-xindy.lsp
SUFFIXES = .fas .lsp
.lsp.fas: