summaryrefslogtreecommitdiff
path: root/Build/source/utils/texinfo/util/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Build/source/utils/texinfo/util/Makefile.am')
-rw-r--r--Build/source/utils/texinfo/util/Makefile.am47
1 files changed, 32 insertions, 15 deletions
diff --git a/Build/source/utils/texinfo/util/Makefile.am b/Build/source/utils/texinfo/util/Makefile.am
index 6451fa9b653..fec2df92dbf 100644
--- a/Build/source/utils/texinfo/util/Makefile.am
+++ b/Build/source/utils/texinfo/util/Makefile.am
@@ -1,4 +1,4 @@
-# $Id: Makefile.am,v 1.14 2004/08/26 11:43:18 karl Exp $
+# $Id: Makefile.am,v 1.34 2008/03/25 10:51:20 akim Exp $
# Makefile.am for texinfo/util.
# Run automake in .. to produce Makefile.in from this.
#
@@ -10,21 +10,20 @@
# WITHOUT ANY WARRANTY, to the extent permitted by law; without even the
# implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.
-bin_PROGRAMS = ginstall-info texindex
-bin_SCRIPTS = texi2dvi texi2pdf
+bin_PROGRAMS = texindex
+bin_SCRIPTS = texi2dvi texi2pdf pdftexi2dvi
-# Use `ginstall-info' in the definition of PROGRAMS and in dependencies
-# because automake generates an install-info target in every Makefile (a
-# bug, IMHO, but this is easier than patching Automake.)
-ginstall_info_SOURCES = install-info.c
-
-# Transform `ginstall-info' to `install-info' before applying any
-# user-specified name transformations.
-transform = s/ginstall-info/install-info/; $(program_transform_name)
+# for auctex.
+pdftexi2dvi: texi2pdf
+ cp -f $(srcdir)/texi2pdf $@
localedir = $(datadir)/locale
-INCLUDES = -I$(top_srcdir)/lib -I../intl -DLOCALEDIR=\"$(localedir)\"
-LDADD = ../lib/libtxi.a $(LIBINTL)
+AM_CPPFLAGS = \
+ -I$(top_srcdir) \
+ -I$(top_srcdir)/gnulib/lib \
+ -I$(top_builddir)/gnulib/lib \
+ -DLOCALEDIR=\"$(localedir)\"
+LDADD = ../lib/libtxi.a $(top_builddir)/gnulib/lib/libgnu.a $(LIBINTL)
dist_pkgdata_DATA = texinfo.dtd texinfo.xsl
pkgdata_DATA = texinfo.cat
@@ -35,11 +34,29 @@ texinfo.cat: texinfo-cat.in $(top_srcdir)/doc/version.texi
sed 's/__VERSION__/@VERSION@/g' $(srcdir)/texinfo-cat.in >$@
# Most of these are for fun. The only official/installed ones are the
-# texi2* scripts.
+# *texi2* scripts.
#
EXTRA_DIST = README deref.c dir-example fix-info-dir fixfonts \
fixref.gawk gdoc gen-dir-node gendocs.sh gendocs_template infosrch \
- install-info-html outline.gawk \
+ install-info-html outline.gawk pdftexi2dvi \
prepinfo.awk tex3patch texi-docstring-magic.el texi2dvi texi2pdf txitextest \
$(dist_pkgdata_DATA) texinfo-cat.in
CLEANFILES = $(pkgdata_DATA)
+
+
+# Let's not stress people's TeX installations, etc.
+if MAINTAINER_MODE
+TESTS = \
+bibtex.test \
+dvipdf.test \
+latex2html.test \
+local.test \
+texi2dvi.test
+
+EXTRA_DIST += $(TESTS)
+
+# Each test case depends on defs.
+check_SCRIPTS = defs
+distclean-local:
+ -rm -rf testSubDir
+endif