summaryrefslogtreecommitdiff
path: root/Build/source/utils/texinfo/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'Build/source/utils/texinfo/configure.ac')
-rw-r--r--Build/source/utils/texinfo/configure.ac84
1 files changed, 49 insertions, 35 deletions
diff --git a/Build/source/utils/texinfo/configure.ac b/Build/source/utils/texinfo/configure.ac
index d6c9a8bb6ad..ef15831fbe9 100644
--- a/Build/source/utils/texinfo/configure.ac
+++ b/Build/source/utils/texinfo/configure.ac
@@ -1,5 +1,5 @@
# Process this file with autoconf to produce a configure script.
-# $Id: configure.ac,v 1.50 2004/12/22 13:29:44 karl Exp $
+# $Id: configure.ac,v 1.87 2008/04/17 17:54:16 karl Exp $
#
# This file is free software; as a special exception the author gives
# unlimited permission to copy and/or distribute it, with or without
@@ -9,12 +9,18 @@
# WITHOUT ANY WARRANTY, to the extent permitted by law; without even the
# implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.
#
-AC_PREREQ(2.59)# Minimum Autoconf version required.
-#
-AC_INIT([GNU Texinfo], [4.8])
-AC_CONFIG_HEADERS(config.h:config.in)# Keep filename to 8.3 for MS-DOS.
+AC_INIT([GNU Texinfo], [4.12], [bug-texinfo@gnu.org])
+
+dnl Must come before AM_INIT_AUTOMAKE.
+AC_CONFIG_AUX_DIR([build-aux])
+AM_INIT_AUTOMAKE([1.10.1 readme-alpha dist-lzma])
+
+# Minimum Autoconf version required.
+AC_PREREQ(2.59)
+
+# Where to generate output; srcdir location.
+AC_CONFIG_HEADERS([config.h:config.in])dnl Keep filename to 8.3 for MS-DOS.
AC_CONFIG_SRCDIR([makeinfo/makeinfo.c])
-AM_INIT_AUTOMAKE([dist-bzip2])
# When the Texinfo source is imported into other repositories
# (NetBSD and TeX Live), timestamps are generally not preserved. This
@@ -23,17 +29,25 @@ AM_MAINTAINER_MODE
# Checks for programs.
AC_PROG_CC
-AC_PROG_GCC_TRADITIONAL
-AC_PROG_INSTALL
-AC_PROG_MAKE_SET
+
+# Since we use gnulib: gl_EARLY must be called as soon as possible after
+# the C compiler is checked. The others could be later, but we just
+# keep everything together.
+gl_EARLY
+
+dnl Rest of Gnulib.
+gl_INIT
+
+
+# Since we make a helper library.
AC_PROG_RANLIB
AM_MISSING_PROG(HELP2MAN, help2man)
-AC_ISC_POSIX
-AC_MINIX
+AC_PROG_INSTALL
+AC_PROG_MAKE_SET
# Needed on sysV68 for sigblock, sigsetmask. But check for it in libc first.
-AC_CHECK_FUNC(sigblock, , AC_CHECK_LIB(bsd, sigblock))
+AC_CHECK_FUNC(sigblock, , [AC_CHECK_LIB(bsd, sigblock)])
# Checks for header files.
AC_HEADER_STAT
@@ -62,19 +76,15 @@ AC_STRUCT_TM
AC_CHECK_DECLS([memchr, strcoll, strerror])
# Checks for library functions.
-AC_FUNC_ALLOCA
AC_FUNC_STRCOLL
AC_FUNC_VPRINTF
# in theory only pre-sysvr3 systems needed this and it's not likely
# that anyone compiling new texinfo still has such a thing? we'll see.
# AC_FUNC_SETVBUF_REVERSED
-AC_CHECK_FUNCS(bzero getcwd memset setvbuf sigaction sigprocmask \
+AC_CHECK_FUNCS(bzero getcwd memset setlocale setvbuf sigaction sigprocmask \
sigsetmask strchr)
AC_REPLACE_FUNCS(memcpy memmove strdup strerror)
-# strcasecmp and strncasecmp, gnulib-style.
-gl_STRCASE
-
# We want to recognize djgpp to avoid the useless warning about no
# term library.
AC_CANONICAL_BUILD
@@ -82,7 +92,7 @@ AC_CANONICAL_BUILD
# We need to run some of our own binaries, most notably makedoc, but as
# long as we have this process, we also use our own makeinfo and
# install-info.
-#
+#
# This means that if we are cross compiling, we have to configure the
# package twice: once with the native compiler (this is done in a
# subdirectory $native_tools), and once with the cross compiler.
@@ -102,10 +112,11 @@ else
AC_MSG_NOTICE([[Doing configure of native tools (${build}).]])
cd "$native_tools" || exit 1
# Run secondary configure in alternate environment or
- # it gets the wrong CC etc. env -i gives this build host configure
- # a clean environment.
- env -i CC="${BUILD_CC}" AR="${BUILD_AR}" RANLIB="${BUILD_RANLIB}" \
- PATH="${PATH}" \
+ # it gets the wrong CC etc.
+ # env -i gives this build host configure a clean environment;
+ # consequently, we have to re-initialize $PATH.
+ env -i CC="$BUILD_CC" AR="$BUILD_AR" RANLIB="$BUILD_RANLIB" \
+ PATH="$PATH" \
tools_only=1 \
${confdir}/configure --build=${build} --host=${build} \
--disable-rpath --disable-nls
@@ -134,15 +145,14 @@ fi
# HP-UX 9 (at least) needs -lncurses which defines termcap variables PC etc.
AC_MSG_CHECKING(for library with termcap variables)
AC_CACHE_VAL(ac_cv_var_ospeed,
-oldLIBS=$LIBS
+[oldLIBS=$LIBS
for trylib in $termlib ${TERMLIB_VARIANTS}; do
if test "x$trylib" != "x$termlib"; then
LIBS="$oldLIBS -l$termlib -l$trylib"
else
LIBS="$oldLIBS -l$termlib"
fi
- AC_TRY_LINK(,
-[#ifdef HAVE_NCURSES_TERMCAP_H
+ AC_LINK_IFELSE([AC_LANG_PROGRAM([], [[#ifdef HAVE_NCURSES_TERMCAP_H
#include <ncurses/termcap.h>
#else
#ifdef HAVE_TERMCAP_H
@@ -161,10 +171,10 @@ BC++;
UP++;
PC++;
return ospeed != 0;
-], ac_cv_var_ospeed=$trylib; break)
+]])], [ac_cv_var_ospeed=$trylib; break])
done
LIBS=$oldLIBS
-)
+])
AC_MSG_RESULT($ac_cv_var_ospeed)
if test -n "$ac_cv_var_ospeed" \
&& test "x$termlib" != "x$ac_cv_var_ospeed"; then
@@ -179,9 +189,6 @@ if test "x$termlib" = xncurses; then
AC_CHECK_HEADERS(ncurses/termcap.h)
fi
-# gnulib.
-gl_FUNC_MKSTEMP
-
# For teTeX and TeX Live.
AC_CANONICAL_HOST
AC_ARG_ENABLE([multiplatform],
@@ -207,17 +214,24 @@ AM_CONDITIONAL(INSTALL_WARNINGS,
test x"$install_warnings" = xtrue || test x"$install_warnings" = xyes)
# i18n support. To update to a new version of gettext, run:
-# gettextize -f -c --intl
-AM_GNU_GETTEXT_VERSION(0.14.1)
-AM_GNU_GETTEXT()
+# gettextize -f -c
+AM_GNU_GETTEXT_VERSION([0.17])
+AM_GNU_GETTEXT([external])
+
+# The test suite.
+AC_CONFIG_FILES([install-info/tests/defs])
+AC_CONFIG_FILES([util/defs])
+AC_CHECK_PROGS([HEVEA], [hevea], [])
+AC_CHECK_PROGS([TEX], [tex], [])
AC_CONFIG_FILES([
Makefile
doc/Makefile
+ gnulib/lib/Makefile
info/Makefile
- intl/Makefile
+ install-info/Makefile
+ install-info/tests/Makefile
lib/Makefile
- m4/Makefile
makeinfo/Makefile
makeinfo/tests/Makefile
po/Makefile.in