summaryrefslogtreecommitdiff
path: root/Build/source/utils/t1utils/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'Build/source/utils/t1utils/configure.in')
-rw-r--r--Build/source/utils/t1utils/configure.in16
1 files changed, 10 insertions, 6 deletions
diff --git a/Build/source/utils/t1utils/configure.in b/Build/source/utils/t1utils/configure.in
index 9e9fee3907c..3511718b3e9 100644
--- a/Build/source/utils/t1utils/configure.in
+++ b/Build/source/utils/t1utils/configure.in
@@ -101,10 +101,14 @@ dnl
# For teTeX and TeX Live.
AC_CANONICAL_HOST
-AC_ARG_ENABLE(multiplatform,
- [ --enable-multiplatform put executables in bin/PLATFORM])
-test "x$enable_multiplatform" = xyes \
- && test "x$bindir" = 'x${exec_prefix}/bin' \
- && bindir="$bindir/$host"
+AC_ARG_ENABLE([multiplatform],
+ [AS_HELP_STRING([--enable-multiplatform],
+ [put executables into bin/PLATFORM and libraries into lib/PLATFORM])])dnl
+# if enable_multiplatform is set in the environment, use that.
+if test "x$enable_multiplatform" = xyes; then
+ test "x$bindir" = 'x${exec_prefix}/bin' && bindir="$bindir/$host"
+ test "x$libdir" = 'x${exec_prefix}/lib' && libdir="$libdir/$host"
+fi
-AC_OUTPUT(Makefile)
+AC_CONFIG_FILES([Makefile])
+AC_OUTPUT