summaryrefslogtreecommitdiff
path: root/Build/source/utils/psutils/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Build/source/utils/psutils/Makefile.am')
-rw-r--r--Build/source/utils/psutils/Makefile.am79
1 files changed, 45 insertions, 34 deletions
diff --git a/Build/source/utils/psutils/Makefile.am b/Build/source/utils/psutils/Makefile.am
index ae222da2bfc..8843bf8ea34 100644
--- a/Build/source/utils/psutils/Makefile.am
+++ b/Build/source/utils/psutils/Makefile.am
@@ -1,10 +1,36 @@
##
OS = UNIX
PAPER = a4
+CHMOD = chmod
+BINMODE = +x
AM_CPPFLAGS = -DUNIX -DPAPER=\"$(PAPER)\"
bin_PROGRAMS = epsffit psbook psnup psresize psselect pstops
+bin_SCRIPTS = getafm showchar \
+ extractres fixdlsrps fixfmps fixmacps fixpsditps fixpspps \
+ fixscribeps fixtpps fixwfwps fixwpps fixwwps includeres psmerge
+CLEANFILES = $(bin_SCRIPTS)
+
+PERL = /usr/bin/env perl
+MAKETEXT = $(PERL) $(srcdir)/maketext
+
+man1_MANS = epsffit.1 psbook.1 psnup.1 psresize.1 psselect.1 pstops.1 \
+ getafm.1 \
+ extractres.1 fixdlsrps.man fixfmps.man fixmacps.man \
+ fixpsditps.man fixpspps.man fixscribeps.man fixtpps.man \
+ fixwfwps.man fixwpps.man fixwwps.man includeres.man psmerge.man
+dist_man_MANS = $(man1_MANS)
+
+%: %.pl
+ $(MAKETEXT) OS=$(OS) PERL="$(PERL)" $< >$@
+
+%: %.sh
+ cp $< $@
+ $(CHMOD) $(BINMODE) $@
+
+%.1: %.man
+ $(MAKETEXT) PAPER=$(PAPER) "MAN=$(man1_MANS)" $< >$@
epsffit_SOURCES = \
config.h \
@@ -57,60 +83,45 @@ pstops_SOURCES = \
psutil.c \
psutil.h
+##
EXTRA_DIST = \
LICENSE
-## Not used
-##
+# scripts.
EXTRA_DIST += \
- Makefile.bcc \
- Makefile.msc \
- Makefile.nt \
- Makefile.os2 \
- Makefile.sc \
- Makefile.unix \
- Makefile.wat \
- descrip.mms \
- epsffit.man \
- extractres.man \
+ getafm.sh \
+ showchar.sh \
extractres.pl \
- fixdlsrps.man \
fixdlsrps.pl \
- fixfmps.man \
fixfmps.pl \
- fixmacps.man \
fixmacps.pl \
- fixpsditps.man \
fixpsditps.pl \
- fixpspps.man \
fixpspps.pl \
- fixscribeps.man \
fixscribeps.pl \
- fixtpps.man \
fixtpps.pl \
- fixwfwps.man \
fixwfwps.pl \
- fixwpps.man \
fixwpps.pl \
- fixwwps.man \
fixwwps.pl \
- getafm.man \
- getafm.sh \
- includeres.man \
includeres.pl \
+ psmerge.pl \
+#
+
+## Not used
+##
+EXTRA_DIST += \
+ Makefile.bcc \
+ Makefile.msc \
+ Makefile.nt \
+ Makefile.os2 \
+ Makefile.sc \
+ Makefile.unix \
+ Makefile.wat \
+ descrip.mms \
maketext \
md68_0.ps \
md71_0.ps \
- psbook.man \
- psnup.man \
- psmerge.man \
- psmerge.pl \
- psresize.man \
- psselect.man \
- pstops.man \
- showchar.sh
+#
## Eventually delete these files
##
EXTRA_DIST += Makefile.in.orig configure.in.orig
-