summaryrefslogtreecommitdiff
path: root/Build/source/utils/m-tx/mtx-0.60d/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'Build/source/utils/m-tx/mtx-0.60d/configure.ac')
-rw-r--r--Build/source/utils/m-tx/mtx-0.60d/configure.ac33
1 files changed, 33 insertions, 0 deletions
diff --git a/Build/source/utils/m-tx/mtx-0.60d/configure.ac b/Build/source/utils/m-tx/mtx-0.60d/configure.ac
new file mode 100644
index 00000000000..a5c59e86466
--- /dev/null
+++ b/Build/source/utils/m-tx/mtx-0.60d/configure.ac
@@ -0,0 +1,33 @@
+# -*- Autoconf -*-
+# Process this file with autoconf to produce a configure script.
+
+AC_PREREQ([2.63])
+AC_INIT([mtx], [0.60d], [dpl@sun.ac.za])
+AC_CONFIG_SRCDIR([analyze.c])
+AC_CONFIG_HEADERS([config.h])
+AM_INIT_AUTOMAKE(mtx,0.60d)
+
+# Checks for programs.
+AC_PROG_CC
+AC_PROG_INSTALL
+AC_PROG_MAKE_SET
+AC_PROG_RANLIB
+
+# Checks for libraries.
+
+# Checks for header files.
+AC_CHECK_HEADERS([memory.h stddef.h stdlib.h string.h strings.h])
+
+# Checks for typedefs, structures, and compiler characteristics.
+AC_HEADER_STDBOOL
+AC_TYPE_SIZE_T
+
+# Checks for library functions.
+AC_FUNC_ERROR_AT_LINE
+AC_FUNC_MALLOC
+AC_FUNC_STRTOD
+AC_CHECK_FUNCS([memchr memmove memset strchr strrchr strtol])
+
+AC_CONFIG_FILES([Makefile
+ libp2c/Makefile])
+AC_OUTPUT