summaryrefslogtreecommitdiff
path: root/Build/source/utils/dialog/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'Build/source/utils/dialog/configure.ac')
-rw-r--r--Build/source/utils/dialog/configure.ac14
1 files changed, 8 insertions, 6 deletions
diff --git a/Build/source/utils/dialog/configure.ac b/Build/source/utils/dialog/configure.ac
index f0f3662efa6..6605873ae83 100644
--- a/Build/source/utils/dialog/configure.ac
+++ b/Build/source/utils/dialog/configure.ac
@@ -1,12 +1,12 @@
dnl Process this file with autoconf to produce a configure script.
dnl
-dnl Copyright (C) 2009 Peter Breitenlohner <tex-live@tug.org>
+dnl Copyright (C) 2009, 2010 Peter Breitenlohner <tex-live@tug.org>
dnl
dnl This file is free software; the copyright holder
dnl gives unlimited permission to copy and/or distribute it,
dnl with or without modifications, as long as this notice is preserved.
dnl
-m4_define([dialog_version], [1.1-20080819])[]dnl using unmodified dialog-1.1-20080819 source tree
+m4_define([dialog_version], [1.1-20080819])[]dnl using unmodified dialog source tree
AC_PREREQ([2.65])
AC_INIT([dialog for TeX Live], dialog_version, [peb@mppmu.mpg.de])
AC_CONFIG_SRCDIR([dialog-]dialog_version[/dialog.c])
@@ -27,10 +27,12 @@ AC_SUBST([DIALOG_TREE])
# Initialize the subdir machinery
AC_CONFIG_SUBDIRS([])
-# when building dialog, configure the subdir $DIALOG_TREE
-# but prevent autoreconf from recursing into this subdir.
-test "x$enable_dialog" = xyes && subdirs=$DIALOG_TREE
-AM_CONDITIONAL([build], [test "x$enable_dialog" = xyes])
+if test "x$enable_build" != xno || test -f config.force; then
+ # when building dialog, configure the subdir $DIALOG_TREE
+ # but prevent autoreconf from recursing into this subdir.
+ subdirs=$DIALOG_TREE
+ echo timestamp >config.force
+fi
AC_CONFIG_FILES([Makefile])