summaryrefslogtreecommitdiff
path: root/Build/source/utils/biber/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'Build/source/utils/biber/configure.ac')
-rw-r--r--Build/source/utils/biber/configure.ac14
1 files changed, 9 insertions, 5 deletions
diff --git a/Build/source/utils/biber/configure.ac b/Build/source/utils/biber/configure.ac
index a8f01e2f23f..29e5a7d7dc0 100644
--- a/Build/source/utils/biber/configure.ac
+++ b/Build/source/utils/biber/configure.ac
@@ -1,6 +1,6 @@
dnl See ./README for our basic strategy here.
dnl
-dnl Copyright (C) 2011 Karl Berry <tex-live@tug.org>
+dnl Copyright (C) 2011, 2012 Karl Berry <tex-live@tug.org>
dnl
dnl This file is free software; the copyright holder
dnl gives unlimited permission to copy and/or distribute it,
@@ -19,6 +19,10 @@ dnl Checks for programs.
AC_PROG_INSTALL
AC_PROG_MAKE_SET
+BIBER_BINARY=
+
+if test "x$enable_build" != xno || test -f config.force; then
+
dnl Determine the TeX Live platform name.
KPSE_TL_PLATFORM
@@ -50,17 +54,17 @@ elif test -r "$srcdir/$biber_bin"; then
# check if freebsd os version is new enough.
if test "$OSVERSION" -ge 701000; then
BIBER_BINARY="$biber_bin"
- else
- BIBER_BINARY= # too old, skip it
fi
else
# not freebsd, just take it.
BIBER_BINARY="$biber_bin"
fi
-else
- BIBER_BINARY=
fi
AC_MSG_RESULT([$BIBER_BINARY])
+
+echo timestamp >config.force
+fi
+
AC_SUBST([BIBER_BINARY])
AC_CONFIG_FILES([Makefile])