summaryrefslogtreecommitdiff
path: root/Build/source/texk/web2c/man/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Build/source/texk/web2c/man/Makefile.am')
-rw-r--r--Build/source/texk/web2c/man/Makefile.am34
1 files changed, 29 insertions, 5 deletions
diff --git a/Build/source/texk/web2c/man/Makefile.am b/Build/source/texk/web2c/man/Makefile.am
index 5fc7899b760..dde3b31f85d 100644
--- a/Build/source/texk/web2c/man/Makefile.am
+++ b/Build/source/texk/web2c/man/Makefile.am
@@ -7,6 +7,9 @@ man_sources = $(bootstrap_man_sources)
EXTRA_DIST = $(bootstrap_man_sources)
bootstrap_man_sources = cweb.man tangle.man
+# Symlinks within $(man1dir): FILE:LINK indicates LINK.1->FILE.1
+man1_links = cweb:ctangle cweb:cweave
+
if WEB
man_sources += $(web_man_sources)
endif WEB
@@ -23,10 +26,10 @@ EXTRA_DIST += tex.man
if MF
man_sources += mf.man
if MFN
-man_sources += # mf-nowin.man
+man1_links += mf:mf-nowin
endif MFN
endif MF
-EXTRA_DIST += mf.man # mf-nowin.man
+EXTRA_DIST += mf.man
if MP
man_sources += mpost.man
@@ -40,12 +43,14 @@ EXTRA_DIST += etex.man
if PDFTEX
man_sources += $(pdftex_man_sources)
+man1_links += pdftex:pdflatex
endif PDFTEX
EXTRA_DIST += $(pdftex_man_sources)
-pdftex_man_sources = pdftex.man pdftosrc.man
+pdftex_man_sources = pdftex.man pdftosrc.man ttf2afm.man
if LUATEX
man_sources += luatex.man
+man1_links += tangle:luatangle
endif LUATEX
EXTRA_DIST += luatex.man
@@ -55,12 +60,15 @@ endif XETEX
EXTRA_DIST += # xetex.man
if OTANGLE
-man_sources += # otangle.man
+man_sources += $(otangle_man_sources)
+man1_links += dvicopy:odvicopy dvitype:odvitype tangle:otangle
endif OTANGLE
-EXTRA_DIST += # otangle.man
+EXTRA_DIST += $(otangle_man_sources)
+otangle_man_sources = ofm2opl.man opl2ofm.man ovf2ovp.man ovp2ovf.man
if ALEPH
man_sources += aleph.man
+man1_links += aleph:lambda
endif ALEPH
EXTRA_DIST += aleph.man
@@ -74,6 +82,22 @@ misc_man_sources = \
include $(top_srcdir)/../am/man.am
+install-data-hook:
+ @cd $(DESTDIR)$(man1dir) && \
+ for s in $(man1_links); do \
+ link=`echo $$s | sed 's,.*:,,'`; \
+ file=`echo $$s | sed 's,:.*,,'`; \
+ rm -f $$link.1; \
+ echo "creating link '$$link.1' -> '$$file.1'"; \
+ $(LN_S) $$file.1 $$link.1; \
+ done
+
+uninstall-hook:
+ @for s in $(man1_links); do \
+ link=`echo $$s | sed 's,.*:,,'`; \
+ rm -f $(DESTDIR)$(man1dir)/$$link.1; \
+ done
+
## Obsolete ?
##
EXTRA_DIST += \