summaryrefslogtreecommitdiff
path: root/Build/source/texk/web2c/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'Build/source/texk/web2c/configure.in')
-rw-r--r--Build/source/texk/web2c/configure.in29
1 files changed, 29 insertions, 0 deletions
diff --git a/Build/source/texk/web2c/configure.in b/Build/source/texk/web2c/configure.in
index d91600af948..15515751596 100644
--- a/Build/source/texk/web2c/configure.in
+++ b/Build/source/texk/web2c/configure.in
@@ -169,6 +169,18 @@ else
with_pdfetex=no
fi
+# For luaTeX.
+if test -d $srcdir/luatexdir; then
+ # Create build dir, if necessary.
+ test -d luatexdir || mkdir luatexdir
+ test "${with_luatex+set}" = set || with_luatex=yes
+else
+ if test "x$with_luatex" = xyes; then
+ AC_MSG_WARN(The luaTeX sources are not available.)
+ fi
+ with_luatex=no
+fi
+
# For XeTeX
if test -d $srcdir/xetexdir \
&& test -d $srcdir/etexdir; then
@@ -182,6 +194,7 @@ fi
# Check whether C++ compiler works. Prevent exit if it doesn't.
if test "x$with_pdftex" = xyes ||
+ test "x$with_luatex" = xyes ||
test "x$with_pdfetex" = xyes ||
test "x$with_xetex" = xyes
then
@@ -196,10 +209,13 @@ then
&& AC_MSG_WARN(No C++ compiler: pdfTeX will not be compiled.)
test "x$with_pdfetex" = xyes \
&& AC_MSG_WARN(No C++ compiler: pdfeTeX will not be compiled.)
+ test "x$with_luatex" = xyes \
+ && AC_MSG_WARN(No C++ compiler: luaTeX will not be compiled.)
test "x$with_xetex" = xyes \
&& AC_MSG_WARN(No C++ compiler: XeTeX will not be compiled.)
with_pdftex=no
with_pdfetex=no
+ with_luatex=no
with_xetex=no
true
}
@@ -217,6 +233,7 @@ CXXHACKLINK='$(kpathsea_cxx_link)'
CXXHACKLDLIBS='$(LOADLIBES)'
if test "x$with_cxx_runtime_hack" = xyes &&
{ test "x$with_pdftex" = xyes ||
+ test "x$with_luatex" = xyes ||
test "x$with_pdfetex" = xyes ||
test "x$with_xetex" = xyes; }
then
@@ -282,6 +299,13 @@ else
fi
AC_SUBST(PETEX)
+if test "x$with_luatex" = xyes; then
+ LTEX=
+else
+ LTEX='#! '
+fi
+AC_SUBST(LTEX)
+
if test "x$with_xetex" = xyes; then
XETEX=
else
@@ -400,6 +424,11 @@ then
KPSE_CONFIG_FILES([pdftexdir/Makefile])
fi
+# Ditto luatex.
+if test "$with_luatex" = yes; then
+ KPSE_CONFIG_FILES([luatexdir/Makefile])
+fi
+
dnl Create tests subdirectory.
test -d tests || mkdir tests