summaryrefslogtreecommitdiff
path: root/Build/source/texk/web2c/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'Build/source/texk/web2c/configure.ac')
-rw-r--r--Build/source/texk/web2c/configure.ac18
1 files changed, 18 insertions, 0 deletions
diff --git a/Build/source/texk/web2c/configure.ac b/Build/source/texk/web2c/configure.ac
index 95d5df2ee3d..68033caaf36 100644
--- a/Build/source/texk/web2c/configure.ac
+++ b/Build/source/texk/web2c/configure.ac
@@ -251,6 +251,7 @@ KPSE_PTEXENC_FLAGS
KPSE_ZLIB_FLAGS
KPSE_LIBPNG_FLAGS
KPSE_XPDF_FLAGS
+KPSE_POPPLER_FLAGS
KPSE_ZZIPLIB_FLAGS
KPSE_GRAPHITE_FLAGS
KPSE_FREETYPE2_FLAGS
@@ -273,6 +274,21 @@ AS_IF([test "x$kpse_cv_have_getPDFMajorVersion" = xyes],
AC_LANG_POP([C++])
KPSE_RESTORE_FLAGS
+# Checks for xpdf (libpoppler) features.
+KPSE_ADD_FLAGS([poppler])
+AC_LANG_PUSH([C++])
+AC_CACHE_CHECK([for PDFDoc::getPDFMajorVersion],
+ [kpse_cv_have_getPDFMajorVersion],
+ [AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[#include <PDFDoc.h>]],
+ [[PDFDoc *pdfDoc; pdfDoc->getPDFMajorVersion();]])],
+ [kpse_cv_have_getPDFMajorVersion=yes],
+ [kpse_cv_have_getPDFMajorVersion=no])])
+AS_IF([test "x$kpse_cv_have_getPDFMajorVersion" = xyes],
+ [AC_DEFINE([HAVE_GETPDFMAJORVERSION], 1,
+ [Define to 1 if class `PDFDoc' has the `getPDFMajorVersion' member.])])
+AC_LANG_POP([C++])
+KPSE_RESTORE_FLAGS
+
dnl Write output here, instead of putting a zillion -D's on the command line.
AC_CONFIG_HEADERS([w2c/c-auto.h:c-auto.in],
[sed -e 's/^#define PACKAGE/#define WEB2C_PACKAGE/' \
@@ -307,6 +323,8 @@ AH_BOTTOM([#endif /* !WEB2C_C_AUTO_H */])
dnl Additional config header for luaTeX
AC_CONFIG_HEADERS([ff-config.h:luatexdir/luafontloader/ff-config.in])
+dnl This is also for luatex
+KPSE_CROSS_PATH_PROG([TXTTOZLIB], [txt2zlib], [./txt2zlib])
# For cross-compilation. Put at the end so there is a fair chance
# these are still visible when the configure script has finished.