summaryrefslogtreecommitdiff
path: root/Build/source/texk/ttfdump/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Build/source/texk/ttfdump/Makefile.am')
-rw-r--r--Build/source/texk/ttfdump/Makefile.am12
1 files changed, 9 insertions, 3 deletions
diff --git a/Build/source/texk/ttfdump/Makefile.am b/Build/source/texk/ttfdump/Makefile.am
index 018623bc1d8..63b1eeaf5e5 100644
--- a/Build/source/texk/ttfdump/Makefile.am
+++ b/Build/source/texk/ttfdump/Makefile.am
@@ -1,11 +1,12 @@
## Makefile.am for the TeX Live subdirectory texk/ttfdump/
##
-## Copyright (C) 2009, 2011 Peter Breitenlohner <tex-live@tug.org>
+## Copyright (C) 2009-2012 Peter Breitenlohner <tex-live@tug.org>
## You may freely use, modify and/or distribute this file.
##
ACLOCAL_AMFLAGS = -I ../../m4
-INCLUDES = -I$(top_srcdir)/include
+INCLUDES = -I$(top_srcdir)/include $(KPATHSEA_INCLUDES)
+AM_CPPFLAGS = -DUNIX -DKPATHSEA
AM_CFLAGS = $(WARNING_CFLAGS)
noinst_LIBRARIES = libttf.a
@@ -63,11 +64,13 @@ EXTRA_DIST = \
libttf/interp.c \
libttf/stack.c
+$(libttf_a_OBJECTS): $(KPATHSEA_DEPEND)
+
bin_PROGRAMS = ttfdump
ttfdump_SOURCES = src/ttfdump.c
-LDADD = libttf.a
+LDADD = libttf.a $(KPATHSEA_LIBS)
dist_man1_MANS = docs/ttfdump.1
@@ -78,6 +81,9 @@ EXTRA_DIST += \
docs/ttfdump.html \
docs/ttfdump.ps
+## Rebuild libkpathsea
+@KPATHSEA_RULE@
+
## Tests.
##
TESTS = tests/ttfdump.test