summaryrefslogtreecommitdiff
path: root/Build/source/texk/kpathsea/man/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Build/source/texk/kpathsea/man/Makefile.am')
-rw-r--r--Build/source/texk/kpathsea/man/Makefile.am20
1 files changed, 20 insertions, 0 deletions
diff --git a/Build/source/texk/kpathsea/man/Makefile.am b/Build/source/texk/kpathsea/man/Makefile.am
index d7db63f961e..647a5c80cdd 100644
--- a/Build/source/texk/kpathsea/man/Makefile.am
+++ b/Build/source/texk/kpathsea/man/Makefile.am
@@ -19,3 +19,23 @@ KPATHSEA_PATHS_H = ${top_builddir}/..
include $(top_srcdir)/../am/man.am
+# Symlinks within $(man1dir): FILE:LINK indicates LINK.1->FILE.1
+man1_links = \
+ mktexlsr:texhash
+
+install-data-hook:
+ @cd $(DESTDIR)$(man1dir) && \
+ for s in $(man1_links); do \
+ link=`echo $$s | sed 's,.*:,,'`; \
+ file=`echo $$s | sed 's,:.*,,'`; \
+ rm -f $$link.1; \
+ echo "creating link '$$link.1' -> '$$file.1'"; \
+ $(LN_S) $$file.1 $$link.1; \
+ done
+
+uninstall-hook:
+ @for s in $(man1_links); do \
+ link=`echo $$s | sed 's,.*:,,'`; \
+ rm -f $(DESTDIR)$(man1dir)/$$link.1; \
+ done
+