summaryrefslogtreecommitdiff
path: root/Build/source/texk/kpathsea/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Build/source/texk/kpathsea/Makefile.am')
-rw-r--r--Build/source/texk/kpathsea/Makefile.am4
1 files changed, 4 insertions, 0 deletions
diff --git a/Build/source/texk/kpathsea/Makefile.am b/Build/source/texk/kpathsea/Makefile.am
index c89cb80fbfd..29050d33e5a 100644
--- a/Build/source/texk/kpathsea/Makefile.am
+++ b/Build/source/texk/kpathsea/Makefile.am
@@ -191,6 +191,10 @@ kpseinclude_HEADERS = \
##
paths.h: stamp-paths
stamp-paths: texmf.cnf bsnl.awk
+# ensure grep is not completely broken, e.g., from GREP_OPTIONS.
+ echo a | grep -v b >/dev/null || { echo "*** grep broken, goodbye."; exit 1; }
+#
+# generate paths.h without build machine directories.
echo "/* paths.h: Generated from texmf.cnf. */" >paths.tmp
awk -f $(srcdir)/bsnl.awk $(srcdir)/texmf.cnf \
| sed -e 's/%.*//' -e 's/^[ ]*//' -e 's/[ ]*$$//' \