summaryrefslogtreecommitdiff
path: root/Build/source/texk/kpathsea/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Build/source/texk/kpathsea/Makefile.am')
-rw-r--r--Build/source/texk/kpathsea/Makefile.am24
1 files changed, 16 insertions, 8 deletions
diff --git a/Build/source/texk/kpathsea/Makefile.am b/Build/source/texk/kpathsea/Makefile.am
index 890ce706742..331db788168 100644
--- a/Build/source/texk/kpathsea/Makefile.am
+++ b/Build/source/texk/kpathsea/Makefile.am
@@ -86,7 +86,7 @@ if MINGW32
libkpathsea_la_SOURCES += mingw32.c
endif MINGW32
-$(libkpathsea_la_SOURCES): paths.h
+$(libkpathsea_la_OBJECTS): paths.h kpathsea.h
EXTRA_DIST += \
putenv.c \
@@ -98,6 +98,7 @@ kpseincludedir = ${includedir}/kpathsea
nodist_kpseinclude_HEADERS = \
c-auto.h \
+ kpathsea.h \
paths.h
kpseinclude_HEADERS = \
@@ -116,7 +117,6 @@ kpseinclude_HEADERS = \
c-stat.h \
c-std.h \
c-unistd.h \
- c-vararg.h \
cnf.h \
concatn.h \
config.h \
@@ -128,7 +128,6 @@ kpseinclude_HEADERS = \
fontmap.h \
getopt.h \
hash.h \
- kpathsea.h \
lib.h \
line.h \
magstep.h \
@@ -152,8 +151,6 @@ kpseinclude_HEADERS = \
xopendir.h \
xstat.h
-$(kpseinclude_HEADERS): paths.h
-
## First null out comments and leading/trailing whitespace, then remove
## lines that define invalid C identifiers, then remove blank lines and
## lines that define lowercase values (those are never path values). Each
@@ -213,9 +210,20 @@ stamp-paths: texmf.cnf
cp paths.tmp paths.h; \
fi
rm -f paths.tmp
- date >stamp-paths
-
-DISTCLEANFILES = paths.h stamp-paths
+ date >$@
+
+kpathsea.h: paths.h
+ rm -f $@
+ echo '/* This is a generated file */' >$@
+ echo '/* collecting all kpathsea headers. */' >>$@
+ echo '#include <kpathsea/config.h>' >>$@
+ echo '#include <kpathsea/c-auto.h>' >>$@
+ echo '#include <kpathsea/paths.h>' >>$@
+ (cd $(srcdir) && ls -1 *.h) \
+ | grep -v '\(config\|paths\|kpathsea\|mingw32\|win32lib\)\.h' \
+ | sed -e 's,^,#include <kpathsea/,' -e s',$$,>,' >>$@
+
+DISTCLEANFILES = paths.h stamp-paths kpathsea.h
## The programs
bin_PROGRAMS = kpseaccess kpsereadlink kpsestat kpsewhich