summaryrefslogtreecommitdiff
path: root/Build/source/texk/dvisvgm/dvisvgm-src/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'Build/source/texk/dvisvgm/dvisvgm-src/configure.ac')
-rw-r--r--Build/source/texk/dvisvgm/dvisvgm-src/configure.ac51
1 files changed, 25 insertions, 26 deletions
diff --git a/Build/source/texk/dvisvgm/dvisvgm-src/configure.ac b/Build/source/texk/dvisvgm/dvisvgm-src/configure.ac
index be86119b2c0..1693253cb7f 100644
--- a/Build/source/texk/dvisvgm/dvisvgm-src/configure.ac
+++ b/Build/source/texk/dvisvgm/dvisvgm-src/configure.ac
@@ -4,8 +4,8 @@
# Process this file with autoconf to produce a configure script.
AC_PREREQ(2.59)
-AC_INIT([dvisvgm],[2.6],[martin.gieseking@uos.de])
-DATE="September 2018"
+AC_INIT([dvisvgm],[2.6.1],[martin.gieseking@uos.de])
+DATE="October 2018"
AC_CONFIG_SRCDIR(src)
AC_CONFIG_HEADERS([config.h])
AC_CONFIG_MACRO_DIR([m4])
@@ -106,20 +106,17 @@ AM_CONDITIONAL([USE_BUNDLED_LIBS], [test "x$enable_bundled_libs" = "xyes"])
# If option --enable-bundled-libs is not given, look for system libraries of brotli, potrace, woff2, and xxhash.
AS_IF([test "x$enable_bundled_libs" != "xyes"],
- [AC_CHECK_HEADER([potracelib.h],
- [AC_CHECK_LIB(m, sqrt)] # required to pass potrace check
- [AC_CHECK_LIB(potrace, potrace_trace,,
- [AC_MSG_ERROR([system library 'libpotrace' not found])])],
- [AC_MSG_ERROR([header file 'potracelib.h' for system library 'libpotrace' not found])])]
- [AS_IF([test "x$enable_woff" = "xyes"],
- [PKG_CHECK_MODULES([BROTLI], [libbrotlienc],,
- [AC_MSG_ERROR([system library 'libbrotlienc' not found])])]
- [PKG_CHECK_MODULES([WOFF2], [libwoff2enc],,
- [AC_MSG_ERROR([system library 'libwoff2enc' not found])])])]
+ [AC_CHECK_HEADER(potracelib.h,
+ [AC_SEARCH_LIBS(potrace_trace, [potrace], [have_potrace=yes])])]
[AC_CHECK_HEADER([xxhash.h],
- [AC_CHECK_LIB(xxhash, XXH32,,
- [AC_MSG_ERROR([system library 'libxxhash' not found])])],
- [AC_MSG_ERROR([header file 'xxhash.h' for system library 'libxxhash' not found])])])
+ [AC_SEARCH_LIBS(XXH32, [xxhash], [have_xxhash=yes])])]
+ [AS_IF([test "x$enable_woff" = "xyes"],
+ [PKG_CHECK_MODULES(BROTLI, [libbrotlienc], [have_brotli=yes])]
+ [PKG_CHECK_MODULES(WOFF2, [libwoff2enc], [have_woff2=yes])])])
+AM_CONDITIONAL(HAVE_POTRACE, [test "x$have_potrace" = "xyes"])
+AM_CONDITIONAL(HAVE_BROTLI, [test "x$have_brotli" = "xyes"])
+AM_CONDITIONAL(HAVE_WOFF2, [test "x$have_woff2" = "xyes"])
+AM_CONDITIONAL(HAVE_XXHASH, [test "x$have_xxhash" = "xyes"])
AS_IF([test "x$enable_woff" != "xyes"],
[AC_DEFINE([DISABLE_WOFF], 1, [Define if WOFF support is disabled])],
@@ -190,17 +187,20 @@ CPPFLAGS="$CPPFLAGS_SAVE"
CFLAGS="$CFLAGS_SAVE"
LDFLAGS="$LDFLAGS_SAVE"
-# Check for utilities required to build the manpage
-build_manpage="no"
-AC_CHECK_PROG(ASCIIDOC, asciidoc, yes)
-AS_IF([test "x$ASCIIDOC" = "xyes"], [
- AC_CHECK_PROG(XMLTO, xmlto, yes)
- AS_IF([test "x$XMLTO" = "xyes"], [
- AC_CHECK_PROG(XSLTPROC, xsltproc, yes)
- AS_IF([test "x$XSLTPROC" = "xyes"],[build_manpage="yes"])])])
-AS_IF([test "x$build_manpage" != "xyes"],
+AC_ARG_ENABLE([manpage],
+ [AS_HELP_STRING([--disable-manpage], [disable generation of manual page @<:@default=no@:>@])])
+AS_IF([test "x$enable_manpage" != "xno"],[
+ enable_manpage="no"
+ # Check for utilities required to build the manpage
+ AC_CHECK_PROG(ASCIIDOC, asciidoc, yes)
+ AS_IF([test "x$ASCIIDOC" = "xyes"], [
+ AC_CHECK_PROG(XMLTO, xmlto, yes)
+ AS_IF([test "x$XMLTO" = "xyes"], [
+ AC_CHECK_PROG(XSLTPROC, xsltproc, yes)
+ AS_IF([test "x$XSLTPROC" = "xyes"],[enable_manpage="yes"])])])])
+AS_IF([test "x$enable_manpage" != "xyes"],
AC_MSG_NOTICE([generation of manual page has been disabled]))
-AM_CONDITIONAL([BUILD_MANPAGE], [test "x$build_manpage" = "xyes"])
+AM_CONDITIONAL([BUILD_MANPAGE], [test "x$enable_manpage" = "xyes"])
AX_CODE_COVERAGE
AS_IF([ test "$enable_code_coverage" = "yes" ], [
@@ -229,7 +229,6 @@ AC_CONFIG_FILES([
src/version.hpp
tests/Makefile
tests/data/Makefile
- doc/dvisvgm.txt
doc/Makefile])
AC_OUTPUT