summaryrefslogtreecommitdiff
path: root/Build/source/texk/detex/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Build/source/texk/detex/Makefile.am')
-rw-r--r--Build/source/texk/detex/Makefile.am35
1 files changed, 35 insertions, 0 deletions
diff --git a/Build/source/texk/detex/Makefile.am b/Build/source/texk/detex/Makefile.am
new file mode 100644
index 00000000000..87c4ddd5082
--- /dev/null
+++ b/Build/source/texk/detex/Makefile.am
@@ -0,0 +1,35 @@
+ACLOCAL_AMFLAGS = -I ../../m4
+
+INCLUDES = $(KPATHSEA_INCLUDES)
+AM_CPPFLAGS = -DKPATHSEA
+
+## The Makefile.in from 2002 by Thomas Esser applied the sed script
+## states.sed to detex.l in order to "convert long labels to a shorter
+## form so lex(1) won't overflow". This should no longer be needed.
+## Moreover, Automake distributes the `detex.c' generated from `detex.l'.
+
+bin_PROGRAMS = detex
+
+detex_SOURCES = detex.h detex.l
+
+LDADD = $(LEXLIB) $(KPATHSEA_LIBS)
+
+detex_DEPENDENCIES = $(KPATHSEA_DEPEND)
+
+## Rebuild libkpathsea
+@KPATHSEA_RULE@
+
+dist_man1_MANS = detex.man
+
+dist_check_SCRIPTS = detex.test
+
+TESTS = detex.test
+
+EXTRA_DIST = test.lout test.tex test.tout
+
+CLEANFILES = test.out texmf.cnf
+
+## Not used
+##
+EXTRA_DIST += states.sed
+