summaryrefslogtreecommitdiff
path: root/Build/source/libs/zziplib/include/zzip/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Build/source/libs/zziplib/include/zzip/Makefile.am')
-rw-r--r--Build/source/libs/zziplib/include/zzip/Makefile.am36
1 files changed, 36 insertions, 0 deletions
diff --git a/Build/source/libs/zziplib/include/zzip/Makefile.am b/Build/source/libs/zziplib/include/zzip/Makefile.am
new file mode 100644
index 00000000000..a1de19ed297
--- /dev/null
+++ b/Build/source/libs/zziplib/include/zzip/Makefile.am
@@ -0,0 +1,36 @@
+## Proxy Makefile.am to install zziplib headers for TeX Live.
+##
+## Copyright (C) 2010 Peter Breitenlohner <tex-live@tug.org>
+##
+## This file is free software; the copyright holder
+## gives unlimited permission to copy and/or distribute it,
+## with or without modifications, as long as this notice is preserved.
+##
+ZZIPLIB_SRC = $(top_srcdir)/$(ZZIPLIB_TREE)/zzip
+
+ZZIPLIB_HDRS = \
+ $(ZZIPLIB_SRC)/autoconf.h \
+ $(ZZIPLIB_SRC)/conf.h \
+ $(ZZIPLIB_SRC)/fetch.h \
+ $(ZZIPLIB_SRC)/file.h \
+ $(ZZIPLIB_SRC)/format.h \
+ $(ZZIPLIB_SRC)/info.h \
+ $(ZZIPLIB_SRC)/lib.h \
+ $(ZZIPLIB_SRC)/plugin.h \
+ $(ZZIPLIB_SRC)/stdint.h \
+ $(ZZIPLIB_SRC)/types.h \
+ $(ZZIPLIB_SRC)/write.h \
+ $(ZZIPLIB_SRC)/zzip.h
+
+all-local:
+ @for file in $(ZZIPLIB_HDRS); do \
+ test -f $$file || continue; \
+ inst=`echo $$file | sed -e 's/^.*\///'`; \
+ test -f $$inst || { \
+ echo "$(LN_S) $$file $$inst"; \
+ $(LN_S) $$file $$inst; } || exit 1; \
+ done
+
+distclean-local:
+ rm -f *.h
+