summaryrefslogtreecommitdiff
path: root/Build/source/libs/zlib/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Build/source/libs/zlib/Makefile.am')
-rw-r--r--Build/source/libs/zlib/Makefile.am23
1 files changed, 20 insertions, 3 deletions
diff --git a/Build/source/libs/zlib/Makefile.am b/Build/source/libs/zlib/Makefile.am
index 056249aa4f4..d5d598c1af5 100644
--- a/Build/source/libs/zlib/Makefile.am
+++ b/Build/source/libs/zlib/Makefile.am
@@ -23,6 +23,9 @@ EXTRA_DIST = $(ZLIB_TREE)
##
EXTRA_DIST += $(ZLIB_TREE)-PATCHES
+## Prepare for switch zlib-1.2.3 -> zlib-1.2.4
+EXTRA_DIST += $(OTHER_TREE) $(OTHER_TREE)-PATCHES
+
# in case of an SVN repository
dist-hook:
rm -rf `find $(distdir) -name .svn`
@@ -42,7 +45,6 @@ nodist_libz_a_SOURCES = \
$(ZLIB_TREE)/crc32.h \
$(ZLIB_TREE)/deflate.c \
$(ZLIB_TREE)/deflate.h \
- $(ZLIB_TREE)/gzio.c \
$(ZLIB_TREE)/infback.c \
$(ZLIB_TREE)/inffast.c \
$(ZLIB_TREE)/inffast.h \
@@ -57,6 +59,20 @@ nodist_libz_a_SOURCES = \
$(ZLIB_TREE)/zutil.h \
$(ZLIB_TREE)/zutil.c
+if ZLIB123
+nodist_libz_a_SOURCES += \
+ $(ZLIB_TREE)/gzio.c
+ZCONF_SRC = zconf.in.h
+else
+nodist_libz_a_SOURCES += \
+ $(ZLIB_TREE)/gzclose.c \
+ $(ZLIB_TREE)/gzguts.h \
+ $(ZLIB_TREE)/gzlib.c \
+ $(ZLIB_TREE)/gzread.c \
+ $(ZLIB_TREE)/gzwrite.c
+ZCONF_SRC = zconf.h.in
+endif
+
$(libz_a_OBJECTS): zconf.h
if build
@@ -70,8 +86,9 @@ LDADD = libz.a
nodist_example_SOURCES = $(ZLIB_TREE)/example.c
nodist_minigzip_SOURCES = $(ZLIB_TREE)/minigzip.c
-zconf.h: $(ZLIB_TREE)/zconf.in.h Makefile
- sed < $< '/HAVE_UNISTD_H/s%^#if [01]%#if $(WITH_UNISTD)%' >$@
+zconf.h: $(ZLIB_TREE)/$(ZCONF_SRC) config.status
+ echo '$(SHELL) ./config.status $@'
+ $(SHELL) ./config.status $@
DISTCLEANFILES = zconf.h