summaryrefslogtreecommitdiff
path: root/Build/source/libs/teckit/teckit/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Build/source/libs/teckit/teckit/Makefile.am')
-rw-r--r--Build/source/libs/teckit/teckit/Makefile.am27
1 files changed, 27 insertions, 0 deletions
diff --git a/Build/source/libs/teckit/teckit/Makefile.am b/Build/source/libs/teckit/teckit/Makefile.am
new file mode 100644
index 00000000000..36e5522a210
--- /dev/null
+++ b/Build/source/libs/teckit/teckit/Makefile.am
@@ -0,0 +1,27 @@
+## Proxy Makefile.am to install TECkit headers for TeX Live.
+##
+## Copyright (C) 2009 Peter Breitenlohner <tex-live@tug.org>
+##
+## This file is free software; the copyright holder
+## gives unlimited permission to copy and/or distribute it,
+## with or without modifications, as long as this notice is preserved.
+##
+TECKIT_SRC = $(top_srcdir)/$(TECKIT_TREE)/source/Public-headers
+
+TECKIT_HDRS = \
+ $(TECKIT_SRC)/TECkit_Common.h \
+ $(TECKIT_SRC)/TECkit_Compiler.h \
+ $(TECKIT_SRC)/TECkit_Engine.h
+
+all-local:
+ @for file in $(TECKIT_HDRS); do \
+ test -f $$f || continue; \
+ inst=`echo $$file | sed -e 's/^.*\///'`; \
+ test -f $$inst || { \
+ echo "$(LN_S) $$file $$inst"; \
+ $(LN_S) $$file $$inst; } || exit 1; \
+ done
+
+distclean-local:
+ rm -f *.h
+