summaryrefslogtreecommitdiff
path: root/Build/source/libs/teckit/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Build/source/libs/teckit/Makefile.am')
-rw-r--r--Build/source/libs/teckit/Makefile.am85
1 files changed, 80 insertions, 5 deletions
diff --git a/Build/source/libs/teckit/Makefile.am b/Build/source/libs/teckit/Makefile.am
index fef026304ce..d8fe5e6d2e9 100644
--- a/Build/source/libs/teckit/Makefile.am
+++ b/Build/source/libs/teckit/Makefile.am
@@ -1,7 +1,82 @@
-AUTOMAKE_OPTIONS = 1.6
+##
+ACLOCAL_AMFLAGS = -I ../../m4
-SUBDIRS = lib bin docs test
+INCLUDES = -I$(top_srcdir)/source/Public-headers $(ZLIB_INCLUDES)
+AM_CPPFLAGS = -DNDEBUG
+
+if build
+EXTRA_LIBRARIES = libTECkit_Compiler.a
+noinst_LIBRARIES = libTECkit.a
+endif
+
+libTECkit_Compiler_a_SOURCES = \
+ source/Compiler.cpp \
+ source/UnicodeNames.cpp
+
+libTECkit_Compiler_a_DEPENDENCIES = $(ZLIB_DEPEND)
+
+libTECkit_a_SOURCES = \
+ source/Engine.cpp
+
+## included from source/Engine.cpp
+EXTRA_DIST = source/NormalizationData.c
+
+libTECkit_a_DEPENDENCIES = $(ZLIB_DEPEND)
+
+noinst_HEADERS = \
+ source/Compiler.h \
+ source/Engine.h \
+ source/Public-headers/TECkit_Common.h \
+ source/Public-headers/TECkit_Compiler.h \
+ source/Public-headers/TECkit_Engine.h \
+ source/TECkit_Format.h \
+ source/ulong_chartraits.h
+
+## Rebuild zlib
+@ZLIB_RULE@
+
+## Not used
+##
+EXTRA_DIST += \
+ SFconv \
+ autogen.sh \
+ ax_misc.m4 \
+ ax_prog_rc.m4 \
+ bin \
+ docs/Calling_TECkit_from_VB.doc \
+ docs/Makefile.am \
+ docs/Makefile.in \
+ docs/TECkit_Binary_Format.doc \
+ docs/TECkit_Binary_Format.doc.pdf \
+ docs/TECkit_Language_2.1.doc \
+ docs/TECkit_Language_2.1.doc.pdf \
+ docs/TECkit_version_2.1.doc \
+ docs/TECkit_version_2.1.doc.pdf \
+ lib \
+ license/LICENSING.txt \
+ license/License_CPLv05.txt \
+ license/License_LGPLv21.txt \
+ source/Carbon.r \
+ source/Compiler_ver.rc \
+ source/Engine_ver.rc \
+ source/MakeNormData.pl \
+ source/MakeUnicodeNames.pl \
+ source/Makefile.am \
+ source/Perl \
+ source/Prefix_Mac.h \
+ source/Prefix_Win32.h \
+ source/Public-headers/Makefile.am \
+ source/REALplugin.cp \
+ source/Sample-tools \
+ source/TECkit_Compiler.cmd \
+ source/TECkit_Compiler.exp \
+ source/TECkit_Engine.cmd \
+ source/TECkit_Engine.exp \
+ source/test.cp \
+ source/version_defs.h \
+ test
+
+## Eventually delete these files
+##
+EXTRA_DIST += Makefile.am.orig configure.ac.orig
-EXTRA_DIST = license/License_CPLv05.txt
-EXTRA_DIST += license/License_LGPLv21.txt
-EXTRA_DIST += license/LICENSING.txt