summaryrefslogtreecommitdiff
path: root/Build/source/libs/pixman/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'Build/source/libs/pixman/configure.ac')
-rw-r--r--Build/source/libs/pixman/configure.ac7
1 files changed, 6 insertions, 1 deletions
diff --git a/Build/source/libs/pixman/configure.ac b/Build/source/libs/pixman/configure.ac
index 5fe61aed6cb..9750a2a676d 100644
--- a/Build/source/libs/pixman/configure.ac
+++ b/Build/source/libs/pixman/configure.ac
@@ -32,7 +32,6 @@ AC_C_INLINE
AC_CONFIG_HEADERS([config.h])
AM_CONDITIONAL([build], [test "x$enable_build" != xno])
-AC_SEARCH_LIBS([sqrt], [m])
if :; then
AC_DEFINE([PIXMAN_NO_TLS], 1, [We do not want threading])
@@ -52,6 +51,12 @@ dnl add all these to config.h.in but do not define them in config.h
[Whether the tool chain supports __attribute__((constructor))])
fi
+dnl Check for missing sqrtf() as, e.g., for Solaris 9
+AC_SEARCH_LIBS([sqrtf], [m], ,
+ [AC_DEFINE([sqrtf], [sqrt],
+ [Define to sqrt if you do not have the `sqrtf' function.])
+ AC_SEARCH_LIBS([sqrt], [m])])
+
dnl PIXMAN_LINK_WITH_ENV(env-setup, program, true-action, false-action)
dnl
dnl Compiles and links the given program in the environment setup by env-setup