summaryrefslogtreecommitdiff
path: root/Build/source/libs/mpfr/mpfr-src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Build/source/libs/mpfr/mpfr-src/Makefile.am')
-rw-r--r--Build/source/libs/mpfr/mpfr-src/Makefile.am27
1 files changed, 20 insertions, 7 deletions
diff --git a/Build/source/libs/mpfr/mpfr-src/Makefile.am b/Build/source/libs/mpfr/mpfr-src/Makefile.am
index b05fe760a3f..89242c6a725 100644
--- a/Build/source/libs/mpfr/mpfr-src/Makefile.am
+++ b/Build/source/libs/mpfr/mpfr-src/Makefile.am
@@ -1,4 +1,4 @@
-# Copyright 2000-2019 Free Software Foundation, Inc.
+# Copyright 2000-2020 Free Software Foundation, Inc.
# This Makefile.am is free software; the Free Software Foundation
# gives unlimited permission to copy and/or distribute it,
# with or without modifications, as long as this notice is preserved.
@@ -9,6 +9,12 @@
# PARTICULAR PURPOSE.
+# Since we do not require GNU "make", let's select the POSIX behavior to
+# uniformize the behavior a bit more with various "make" implementations
+# and ease maintenance. This target should be removed only if one day,
+# we need to require GNU "make".
+.POSIX:
+
AUTOMAKE_OPTIONS = gnu
# ACLOCAL_AMFLAGS will be fully deprecated in Automake 2.0;
@@ -24,28 +30,35 @@ pkgconfigdir = $(libdir)/pkgconfig
pkgconfig_DATA = mpfr.pc
nobase_dist_doc_DATA = AUTHORS BUGS COPYING COPYING.LESSER NEWS TODO \
- examples/ReadMe examples/divworst.c examples/rndo-add.c examples/sample.c \
- examples/version.c examples/can_round.c
+ examples/ReadMe examples/can_round.c examples/divworst.c \
+ examples/rndo-add.c examples/sample.c examples/threads.c \
+ examples/version.c
-EXTRA_DIST = PATCHES VERSION doc/README.dev doc/check-typography \
- tools/ck-clz_tab tools/ck-copyright-notice tools/ck-news \
- tools/ck-version-info tools/get_patches.sh \
+EXTRA_DIST = PATCHES VERSION doc/README.dev doc/check-typography doc/mini-gmp \
+ tools/check_mparam.c tools/ck-clz_tab tools/ck-copyright-notice \
+ tools/ck-mparam tools/ck-news tools/ck-version-info tools/get_patches.sh \
$(DATAFILES)
bench:
cd tools/bench && $(MAKE) $(AM_MAKEFLAGS) bench
-# Various checks for "make dist".
+# Various checks for "make dist" / "make distcheck".
+# Warning! With "make distcheck", neither the top-level directory nor
+# the tools directory is writable.
# * Check consistency concerning -version-info. Moreover if the VERSION
# file doesn't end with "-dev", check that the -version-info value is
# up-to-date. Note: this is a heuristic, to detect some mistakes.
# * Check that copyright notices exist and appear to be correct.
# * Check the NEWS file.
+# * Check the __clz_tab sizes.
+# * Check the mparam.h files.
+# * Check typography in mpfr.texi (Texinfo rules).
dist-hook:
cd $(srcdir) && tools/ck-version-info
cd $(srcdir) && tools/ck-copyright-notice
cd $(srcdir) && tools/ck-news
cd $(srcdir) && tools/ck-clz_tab
+ $(srcdir)/tools/ck-mparam
cd $(srcdir)/doc && ./check-typography
# Check that MPFR does not use GMP internal symbols. Of course, do not run