summaryrefslogtreecommitdiff
path: root/Build/source/libs/luajit/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'Build/source/libs/luajit/configure.ac')
-rw-r--r--Build/source/libs/luajit/configure.ac24
1 files changed, 21 insertions, 3 deletions
diff --git a/Build/source/libs/luajit/configure.ac b/Build/source/libs/luajit/configure.ac
index 299f12e9d69..40ab8581032 100644
--- a/Build/source/libs/luajit/configure.ac
+++ b/Build/source/libs/luajit/configure.ac
@@ -7,17 +7,18 @@ dnl gives unlimited permission to copy and/or distribute it,
dnl with or without modifications, as long as this notice is preserved.
dnl
m4_include([version.ac])[] dnl define luajit_version
-AC_INIT([luajit for TeX Live], luajit_version, [luigi.scarso@gmail.com])
+AC_INIT([luajit for TeX Live], luajit_version, [tex-k@tug.org])
AC_PREREQ([2.65])
AC_CONFIG_SRCDIR([LuaJIT-]luajit_version[/src/luajit.h])
AC_CONFIG_AUX_DIR([../../build-aux])
-AC_CONFIG_MACRO_DIR([../../m4])
+AC_CONFIG_MACRO_DIRS([../../m4 m4])
KPSE_BASIC([luajit])
AC_CANONICAL_HOST
AC_PROG_CC
+AM_PROG_AS
AC_PROG_RANLIB
AC_PROG_LN_S
@@ -25,17 +26,34 @@ AC_SEARCH_LIBS([sqrt], [m])
KPSE_COND_WIN32
+AM_CPPFLAGS=['-I$(srcdir)/LuaJIT-]luajit_version[/src -DLUAJIT_ENABLE_LUA52COMPAT']
+LJ_ARCH()
+AS_CASE([$LJHOST],
+ [Windows], [LJVM_MODE=peobj
+ AM_CPPFLAGS="$AM_CPPFLAGS -malign-double"],
+ [Darwin | iOS], [LJVM_MODE=machasm],
+ [LJVM_MODE=elfasm])
+AM_CONDITIONAL([PEOBJ], [test "x$LJVM_MODE" = xpeobj])
+AC_SUBST([LJVM_MODE])
+AC_SUBST([AM_CPPFLAGS])
+
AM_CONDITIONAL([build], [test "x$enable_build" != xno])
AC_SUBST([LUAJIT_TREE], [LuaJIT-]luajit_version)
-AC_CONFIG_FILES([Makefile])
+dnl Not used but avoids putting a zillion useless -D's on the command line.
+AC_CONFIG_HEADERS([config.h])
+
+AC_CONFIG_FILES([Makefile include/Makefile])
AC_CONFIG_SUBDIRS([native])
AS_IF([test "x$cross_compiling" = xyes],
[AC_SUBST([CROSS], [$host-])])
+dnl Pass DASM_ARCH to the subdirectory native.
+AC_CONFIG_COMMANDS_POST([ac_configure_args="$ac_configure_args DASM_ARCH=$DASM_ARCH"])
+
dnl The subdirectory native must be configured for the build system.
dnl When cross compiling, can not share the cache file with the subdirectory!
AC_CONFIG_COMMANDS_POST([AS_IF([test "x$cross_compiling" = xyes],