summaryrefslogtreecommitdiff
path: root/Build/source/libs/luajit/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'Build/source/libs/luajit/configure.ac')
-rw-r--r--Build/source/libs/luajit/configure.ac16
1 files changed, 16 insertions, 0 deletions
diff --git a/Build/source/libs/luajit/configure.ac b/Build/source/libs/luajit/configure.ac
index f8ecce6d473..38ba43f560e 100644
--- a/Build/source/libs/luajit/configure.ac
+++ b/Build/source/libs/luajit/configure.ac
@@ -28,6 +28,12 @@ AC_SEARCH_LIBS([dlopen], [dl])
KPSE_LUAJIT_DEFINES
KPSE_LARGEFILE([LUAJIT_DEFINES])
+AS_CASE([$host_os],
+ [cygwin* | mingw* | msys*], [LJHOST='Windows'],
+ [darwin*], [LJHOST='Darwin'],
+ [solaris* | sunos*], [LJHOST='SunOS'],
+ [linux*], [LJHOST='Linux'],
+ [LJHOST='Other'])
LJ_ARCH()
AS_CASE([$LJHOST],
[Windows], [LJVM_MODE=peobj
@@ -35,10 +41,20 @@ AS_CASE([$LJHOST],
[Darwin | iOS], [LJVM_MODE=machasm],
[LJVM_MODE=elfasm])
AM_CONDITIONAL([PEOBJ], [test "x$LJVM_MODE" = xpeobj])
+
+AC_SUBST([LJHOST])
AC_SUBST([LJVM_MODE])
AM_CONDITIONAL([build], [test "x$enable_build" != xno])
+if test "x$enable_build" != xno || test -f config.force; then
+
+AS_IF([test "x$lj_cpp" != xok],
+ [AC_MSG_ERROR([Sorry, can not preprocess <lj_arch.h>])])
+
+echo timestamp >config.force
+fi
+
AC_SUBST([LUAJIT_TREE], [LuaJIT-]luajit_version)
dnl Not used but avoids putting a zillion useless -D's on the command line.